aboutsummaryrefslogtreecommitdiff
path: root/mail/opensmtpd
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2018-05-03 23:17:24 +0000
committerDima Panov <fluffy@FreeBSD.org>2018-05-03 23:17:24 +0000
commit4e17d75935f3f1de8b0fb66b7e07bc0b78ff2fcb (patch)
treead0510167bb2bc95774585439f77f095e5cb6818 /mail/opensmtpd
parent8e0c383b2c2a5874507cf290d85318ca06d424d9 (diff)
downloadports-4e17d75935f3f1de8b0fb66b7e07bc0b78ff2fcb.tar.gz
ports-4e17d75935f3f1de8b0fb66b7e07bc0b78ff2fcb.zip
Notes
Diffstat (limited to 'mail/opensmtpd')
-rw-r--r--mail/opensmtpd/Makefile2
-rw-r--r--mail/opensmtpd/files/patch-smtpd-rfc2822.c19
-rw-r--r--mail/opensmtpd/files/patch-smtpd-smtp_session.c11
3 files changed, 31 insertions, 1 deletions
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index d426d05cb70e..3e813dae527d 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -4,7 +4,7 @@
PORTNAME= opensmtpd
PORTVERSION= 5.9.2p1
PORTEPOCH= 1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
http://distfiles.pirateparty.in/ashish/
diff --git a/mail/opensmtpd/files/patch-smtpd-rfc2822.c b/mail/opensmtpd/files/patch-smtpd-rfc2822.c
new file mode 100644
index 000000000000..67952346556e
--- /dev/null
+++ b/mail/opensmtpd/files/patch-smtpd-rfc2822.c
@@ -0,0 +1,19 @@
+--- smtpd/rfc2822.c.orig 2018-05-01 13:33:10.000000000 +0000
++++ smtpd/rfc2822.c 2018-05-01 13:34:47.931554000 +0000
+@@ -53,4 +53,7 @@
+ struct rfc2822_hdr_miss_cb *hdr_miss_cb;
++
++ if (!rp->in_hdr)
++ goto end;
+
+ TAILQ_FOREACH(hdr_cb, &rp->hdr_cb, next)
+ if (strcasecmp(hdr_cb->name, rp->header.name) == 0) {
+@@ -151,6 +152,8 @@
+ return;
+
+ header_callback(rp);
++
++ missing_headers_callback(rp);
+ }
+
+ void
diff --git a/mail/opensmtpd/files/patch-smtpd-smtp_session.c b/mail/opensmtpd/files/patch-smtpd-smtp_session.c
new file mode 100644
index 000000000000..990888bf463d
--- /dev/null
+++ b/mail/opensmtpd/files/patch-smtpd-smtp_session.c
@@ -0,0 +1,11 @@
+--- smtpd/smtp_session.c.orig 2018-05-01 13:35:00.375262000 +0000
++++ smtpd/smtp_session.c 2018-05-01 13:37:22.637096000 +0000
+@@ -1345,6 +1345,8 @@
+ s->dataeom = 1;
+ if (iobuf_queued(&s->obuf) == 0)
+ smtp_data_io_done(s);
++ else
++ io_reload(&s->oev);
+ return;
+ }
+