aboutsummaryrefslogtreecommitdiff
path: root/mail/openwebmail
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-01-03 11:26:54 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-01-03 11:26:54 +0000
commit77233e9759c9fb77c2a947103ad54f7eb171d812 (patch)
tree4c451913b6d68168ba3ffd92ac708ca1d0014d90 /mail/openwebmail
parentdcc0b77050d493b847af53ee39a6d31db31b8634 (diff)
downloadports-77233e9759c9fb77c2a947103ad54f7eb171d812.tar.gz
ports-77233e9759c9fb77c2a947103ad54f7eb171d812.zip
Notes
Diffstat (limited to 'mail/openwebmail')
-rw-r--r--mail/openwebmail/Makefile29
-rw-r--r--mail/openwebmail/distinfo2
-rw-r--r--mail/openwebmail/pkg-deinstall4
-rw-r--r--mail/openwebmail/pkg-install8
4 files changed, 33 insertions, 10 deletions
diff --git a/mail/openwebmail/Makefile b/mail/openwebmail/Makefile
index db2aac23bac2..642309dd7a41 100644
--- a/mail/openwebmail/Makefile
+++ b/mail/openwebmail/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= openwebmail
-PORTVERSION= 2.21
+PORTVERSION= 2.30
CATEGORIES= mail
MASTER_SITES= http://openwebmail.com/openwebmail/download/ \
http://turtle.ee.ncku.edu.tw/openwebmail/download/
EXTRACT_SUFX= .tgz
MAINTAINER= leeym@FreeBSD.org
-COMMENT= A webmail system designed to manage very big mail folder files in a memory efficient way
+COMMENT= A webmail system designed to manage big mail folder files efficiently
RUN_DEPENDS= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
@@ -34,7 +34,7 @@ PLIST= ${WRKDIR}/.PLIST.${PKGNAME}
.if !defined(WITHOUT_SPEEDYCGI)
BUILD_DEPENDS+= speedy_suid:${PORTSDIR}/www/p5-CGI-SpeedyCGI
RUN_DEPENDS+= speedy_suid:${PORTSDIR}/www/p5-CGI-SpeedyCGI
-EXTRA_PATCHES= ${PATCH_WRKSRC}/uty/suidperl2speedy.diff
+EXTRA_PATCHES= ${PATCH_WRKSRC}/uty/suidperl2speedy_suid.diff
.else
_CUSTOMIZED= yes
.endif
@@ -59,6 +59,11 @@ RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
_CUSTOMIZED= yes
.endif
+.if defined(WITH_ANTIWORD)
+RUN_DEPENDS+= antiword:${PORTSDIR}/textproc/antiword
+_CUSTOMIZED= yes
+.endif
+
.if defined(WITH_IMAGEMAGICK)
RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
_CUSTOMIZED= yes
@@ -68,7 +73,7 @@ pre-fetch:
.if ${PERL_LEVEL} > 500800
@${ECHO} ""
@${ECHO} "WARNING:"
- @${ECHO} "Please make sure that your perl is built with -DSUIDPERL_ENABLED,"
+ @${ECHO} "Please make sure that your PERL is built with -DSUIDPERL_ENABLED,"
@${ECHO} "otherwise please build openwebmail with WITHOUT_SPEEDYCGI=yes"
@${ECHO} ""
.endif
@@ -84,6 +89,9 @@ pre-fetch:
.if defined(WITH_ISPELL)
@${ECHO} "ISpell support will be added."
.endif
+.if defined(WITH_ANTIWORD)
+ @${ECHO} "Antiword support will be added."
+.endif
.if defined(WITHOUT_SPEEDYCGI)
@${ECHO} "SpeedyCGI support will NOT be added."
.endif
@@ -96,6 +104,7 @@ pre-fetch:
@${ECHO} "Type \"make WITH_ZLIB=yes\" if you want Zlib support."
@${ECHO} "Type \"make WITH_QUOTA=yes\" if you want Quota support."
@${ECHO} "Type \"make WITH_ISPELL=yes\" if you want ISpell support."
+ @${ECHO} "Type \"make WITH_ANTIWORD=yes\" if you want Antiword support."
@${ECHO} "Type \"make WITHOUT_SPEEDYCGI=yes\" if you DONT want SpeedyCGI support."
@${ECHO} "Type \"make WITH_IMAGEMAGICK=yes\" if you want ImageMagick support."
@${ECHO} "You can use them in combinations."
@@ -107,8 +116,7 @@ post-patch:
@${PERL} -pi.bak -e 's,${LOCALBASE}/www/cgi-bin/openwebmail,${OWCGIDIR},g' ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
@${PERL} -pi.bak -e 's,${LOCALBASE}/www/data/openwebmail,${OWDATADIR},g' ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
.if !defined(WITHOUT_SPEEDYCGI)
- @${ECHO} "savedsuid_support no" >> ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
- @${PERL} -pi.bak -e 's,${LOCALBASE}/bin/speedy,${LOCALBASE}/bin/speedy_suid,g' ${PATCH_WRKSRC}/openwebmail*pl
+ @${ECHO} "has_savedsuid_support no" >> ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
.else
@${PERL} -pi.bak -e 's,/usr/bin/suidperl,${PERL},g' ${PATCH_WRKSRC}/openwebmail*pl
.endif
@@ -116,8 +124,9 @@ post-patch:
pre-install:
@${FIND} ${WRKSRC}/*/openwebmail \( -name "*.bak" -or -name "*.orig" \) -delete
.if !exists(${PLIST})
- @${ECHO} "@unexec if cmp -s %D/www/cgi-bin/openwebmail/etc/openwebmail.conf %D/www/cgi-bin/openwebmail/etc/openwebmail.conf-dist; then rm -f %D/www/cgi-bin/openwebmail/etc/openwebmail.conf; fi" > ${PLIST}
+ @${ECHO} "@unexec if cmp -s %D/www/cgi-bin/openwebmail/etc/openwebmail.conf %D/www/cgi-bin/openwebmail/etc/openwebmail.conf-dist; then ${RM} -f %D/www/cgi-bin/openwebmail/etc/openwebmail.conf; fi" > ${PLIST}
@${FIND} ${WRKSRC}/*/openwebmail -type f -o -type l | ${SED} -e 's,${WRKSRC},www,g' | sort -u >> ${PLIST}
+ @${ECHO} "www/cgi-bin/openwebmail/etc/dbm.conf" >> ${PLIST}
.for f in b2g g2b lunar
@${ECHO} "www/cgi-bin/openwebmail/etc/${f}.db" >> ${PLIST}
.endfor
@@ -137,11 +146,13 @@ do-install:
.if !exists(${OWCGIDIR}/etc/openwebmail.conf)
@${CP} ${OWCGIDIR}/etc/openwebmail.conf-dist ${OWCGIDIR}/etc/openwebmail.conf
.endif
- @${CHMOD} 0770 ${OWCGIDIR}/etc/sessions ${OWCGIDIR}/etc/users
- @${CHMOD} 4755 ${OWCGIDIR}/openwebmail*pl
+ @${PERL} ${OWCGIDIR}/uty/dbmtest.pl | ${GREP} "^dbm" > ${OWCGIDIR}/etc/dbm.conf
.if defined(WITHOUT_SPEEDYCGI)
@${PERL} ${OWCGIDIR}/uty/wrapsuid.pl ${OWCGIDIR}
.endif
@${OWCGIDIR}/openwebmail-tool.pl --init --no
+post-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
.include <bsd.port.post.mk>
diff --git a/mail/openwebmail/distinfo b/mail/openwebmail/distinfo
index 5639e53c0f10..073fdefb05a8 100644
--- a/mail/openwebmail/distinfo
+++ b/mail/openwebmail/distinfo
@@ -1 +1 @@
-MD5 (openwebmail-2.21.tgz) = a7bf580b0e6a2f1cd896a4ca6a55355c
+MD5 (openwebmail-2.30.tgz) = 585a19c3192065be279f22c947a48e83
diff --git a/mail/openwebmail/pkg-deinstall b/mail/openwebmail/pkg-deinstall
index 30b614fbcf36..895d43b968bc 100644
--- a/mail/openwebmail/pkg-deinstall
+++ b/mail/openwebmail/pkg-deinstall
@@ -1,2 +1,6 @@
#!/bin/sh
+if [ "$2" != "DEINSTALL" ]; then
+ exit 0
+fi
+
rm -fr ${PKG_PREFIX}/www/cgi-bin/openwebmail/etc/sessions/*
diff --git a/mail/openwebmail/pkg-install b/mail/openwebmail/pkg-install
new file mode 100644
index 000000000000..53c5ab67c94a
--- /dev/null
+++ b/mail/openwebmail/pkg-install
@@ -0,0 +1,8 @@
+#!/bin/sh
+if [ "$2" != "POST-INSTALL" ]; then
+ exit 0
+fi
+
+chmod 0770 ${PKG_PREFIX}/www/cgi-bin/openwebmail/etc/sessions
+chmod 0700 ${PKG_PREFIX}/www/cgi-bin/openwebmail/etc/users
+chmod 4755 ${PKG_PREFIX}/www/cgi-bin/openwebmail/openwebmail*pl