aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Email-Folder/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2006-08-05 10:28:27 +0000
committerLars Thegler <lth@FreeBSD.org>2006-08-05 10:28:27 +0000
commit01e9ad88b8bce438ad95cf902596d52b73d0a6a3 (patch)
tree706b806e8c94103096784d1f5191564e06d9edee /mail/p5-Email-Folder/Makefile
parent2bd0580765cff84a20bbd07e708f01c53fe05068 (diff)
downloadports-01e9ad88b8bce438ad95cf902596d52b73d0a6a3.tar.gz
ports-01e9ad88b8bce438ad95cf902596d52b73d0a6a3.zip
Notes
Diffstat (limited to 'mail/p5-Email-Folder/Makefile')
-rw-r--r--mail/p5-Email-Folder/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/mail/p5-Email-Folder/Makefile b/mail/p5-Email-Folder/Makefile
index b9e95ba3ca88..9555d66e5915 100644
--- a/mail/p5-Email-Folder/Makefile
+++ b/mail/p5-Email-Folder/Makefile
@@ -6,20 +6,20 @@
#
PORTNAME= Email-Folder
-PORTVERSION= 0.85
+PORTVERSION= 0.85.1
CATEGORIES= mail perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Email
+MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-0.851
MAINTAINER= lth@FreeBSD.org
COMMENT= Read all the messages from a folder as Email::Simple objects
-BUILD_DEPENDS= ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
- ${SITE_PERL}/Email/FolderType.pm:${PORTSDIR}/mail/p5-Email-FolderType
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Email-Simple>0:${PORTSDIR}/mail/p5-Email-Simple \
+ p5-Email-FolderType>=0.6:${PORTSDIR}/mail/p5-Email-FolderType
+BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+PERL_CONFIGURE= yes
MAN3= Email::Folder.3 \
Email::Folder::MH.3 \
@@ -27,4 +27,9 @@ MAN3= Email::Folder.3 \
Email::Folder::Mbox.3 \
Email::Folder::Reader.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ ${PERL} -pi -e '$$_="" if /use warnings;/' ${WRKSRC}/Makefile.PL
+.endif
+.include <bsd.port.post.mk>