aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-IMAP-Admin/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-09-28 23:30:50 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-09-28 23:30:50 +0000
commitf7f555726c297c849eebc678048e3478177fdf0a (patch)
tree28e077db8bede3c00f29bc7ab45ad12413724812 /mail/p5-IMAP-Admin/Makefile
parenta883718e8670b77a3af201d9c9f86e9a8607a378 (diff)
downloadports-f7f555726c297c849eebc678048e3478177fdf0a.tar.gz
ports-f7f555726c297c849eebc678048e3478177fdf0a.zip
Notes
Diffstat (limited to 'mail/p5-IMAP-Admin/Makefile')
-rw-r--r--mail/p5-IMAP-Admin/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/mail/p5-IMAP-Admin/Makefile b/mail/p5-IMAP-Admin/Makefile
index 1447fa131daf..ce9921681d42 100644
--- a/mail/p5-IMAP-Admin/Makefile
+++ b/mail/p5-IMAP-Admin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= IMAP-Admin
-PORTVERSION= 1.6.4
+PORTVERSION= 1.6.6
CATEGORIES= mail perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,17 +17,18 @@ COMMENT= Perl module for basic IMAP server administration
PERL_CONFIGURE= YES
MAN3= IMAP::Admin.3
-EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/${UNIQUENAME}
+.if !defined(NOPORTEXAMPLES)
+PORTEXAMPLES= create.pl delete.pl
post-install:
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/examples/create.pl \
- ${WRKSRC}/examples/delete.pl \
- ${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
@${ECHO_MSG} ""
@${ECHO_MSG} "*******************************************************************************"
@${ECHO_MSG} "See ${EXAMPLESDIR} for some examples..."
@${ECHO_MSG} "*******************************************************************************"
@${ECHO_MSG} ""
+.endif
.include <bsd.port.mk>