aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-Graph/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-11-04 16:36:53 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-11-04 16:36:53 +0000
commitedc503ea716a74f33ec0c0eeaf2079fe8cd74814 (patch)
tree1824b738488a7c3c9f7b10e658e766bd8859e77d /mail/p5-Mail-Graph/Makefile
parent95493bd9554196cc165edc8d5430d29d00492541 (diff)
downloadports-edc503ea716a74f33ec0c0eeaf2079fe8cd74814.tar.gz
ports-edc503ea716a74f33ec0c0eeaf2079fe8cd74814.zip
Notes
Diffstat (limited to 'mail/p5-Mail-Graph/Makefile')
-rw-r--r--mail/p5-Mail-Graph/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/mail/p5-Mail-Graph/Makefile b/mail/p5-Mail-Graph/Makefile
new file mode 100644
index 000000000000..1f19d000bfcb
--- /dev/null
+++ b/mail/p5-Mail-Graph/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: p5-Mail-Graph
+# Date created: Nov 4 2003
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-Graph
+PORTVERSION= 0.12
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Perl module for drawing graphical stats for mails/spams
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt \
+ ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
+ ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
+ ${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
+ ${SITE_PERL}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+EXAMPLESCRIPT= samples/*pl
+EXAMPLEDUMMY= samples/index/dummy.txt
+EXAMPLEOUTPUT= samples/output/w3c.png samples/output/spam.css
+EXAMPLEARCHIVE= samples/archive/*.gz
+
+MAN3= Mail::Graph.3
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}/archive
+ @${MKDIR} ${EXAMPLESDIR}/index
+ @${MKDIR} ${EXAMPLESDIR}/output
+ cd ${WRKSRC} && \
+ ${INSTALL_SCRIPT} ${EXAMPLESCRIPT} ${EXAMPLESDIR} && \
+ ${INSTALL_SCRIPT} ${EXAMPLEDUMMY} ${EXAMPLESDIR}/index && \
+ ${INSTALL_SCRIPT} ${EXAMPLEOUTPUT} ${EXAMPLESDIR}/output && \
+ ${INSTALL_SCRIPT} ${EXAMPLEARCHIVE} ${EXAMPLESDIR}/archive
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>