aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-IMAPTalk/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-24 19:27:32 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-24 19:27:32 +0000
commitc8962b1150530d368fb0edcdc82e32f3d507dbe6 (patch)
tree5bff300dcbf0f38a295240cb1e3b5cb80bc29b09 /mail/p5-Mail-IMAPTalk/Makefile
parent071e5a80bdd2fd69a64d33d2bab1afc81c31b642 (diff)
Adding port mail/p5-Mail-IMAPTalk, a pure-Perl, full-featured IMAP protocol library.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163303
Diffstat (limited to 'mail/p5-Mail-IMAPTalk/Makefile')
-rw-r--r--mail/p5-Mail-IMAPTalk/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/mail/p5-Mail-IMAPTalk/Makefile b/mail/p5-Mail-IMAPTalk/Makefile
new file mode 100644
index 000000000000..303b03ce678c
--- /dev/null
+++ b/mail/p5-Mail-IMAPTalk/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Mail-IMAPTalk
+# Date created: 24 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-IMAPTalk
+PORTVERSION= 1.03
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= IMAP client interface with lots of features
+
+MAN3= Mail::IMAPTalk.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6.0. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>