aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-RBL
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-05 04:32:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-05 04:32:09 +0000
commit2157ceb0bf9852d1e003da0c0a29aecb507a8a0b (patch)
tree7c7cab7289e97c123b1ecfa8b8970416b0538402 /mail/p5-Mail-RBL
parent9883e48d473fb06893550f50596c0a358581e83c (diff)
downloadports-2157ceb0bf9852d1e003da0c0a29aecb507a8a0b.tar.gz
ports-2157ceb0bf9852d1e003da0c0a29aecb507a8a0b.zip
Notes
Diffstat (limited to 'mail/p5-Mail-RBL')
-rw-r--r--mail/p5-Mail-RBL/Makefile33
-rw-r--r--mail/p5-Mail-RBL/distinfo1
-rw-r--r--mail/p5-Mail-RBL/files/patch-Makefile.PL10
-rw-r--r--mail/p5-Mail-RBL/pkg-comment1
-rw-r--r--mail/p5-Mail-RBL/pkg-descr17
-rw-r--r--mail/p5-Mail-RBL/pkg-plist5
6 files changed, 67 insertions, 0 deletions
diff --git a/mail/p5-Mail-RBL/Makefile b/mail/p5-Mail-RBL/Makefile
new file mode 100644
index 000000000000..dfe4c822fad1
--- /dev/null
+++ b/mail/p5-Mail-RBL/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Mail-RBL
+# Date created: July 24th 2002
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-RBL
+PORTVERSION= 1.00
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Mail::RBL.3
+
+FILES= Makefile.PL test.pl RBL.pm
+
+pre-patch:
+.for i in ${FILES}
+ @${PERL} -pi -e 's/\r//' ${WRKSRC}/${i}
+.endfor
+ @${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
+ -e '$$_="" if /require 5/;' \
+ -e '$$_="" if /use warnings/;' \
+ ${WRKSRC}/RBL.pm
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-RBL/distinfo b/mail/p5-Mail-RBL/distinfo
new file mode 100644
index 000000000000..dcac53d735fa
--- /dev/null
+++ b/mail/p5-Mail-RBL/distinfo
@@ -0,0 +1 @@
+MD5 (Mail-RBL-1.00.tar.gz) = ad7efa148982ac264dc5dcb08feef8d4
diff --git a/mail/p5-Mail-RBL/files/patch-Makefile.PL b/mail/p5-Mail-RBL/files/patch-Makefile.PL
new file mode 100644
index 000000000000..8da82d367460
--- /dev/null
+++ b/mail/p5-Mail-RBL/files/patch-Makefile.PL
@@ -0,0 +1,10 @@
+--- Makefile.PL.orig Thu Jul 25 10:12:25 2002
++++ Makefile.PL Thu Jul 25 10:12:25 2002
+@@ -3,6 +3,6 @@
+ # the contents of the Makefile that is written.
+ WriteMakefile(
+ 'NAME' => 'Mail::RBL',
+- 'VERSION_FROM' => 'RBL.pm', # finds $VERSION
++ 'VERSION' => '1.00',
+ 'PREREQ_PM' => {}, # e.g., Module::Name => 1.1
+ );
diff --git a/mail/p5-Mail-RBL/pkg-comment b/mail/p5-Mail-RBL/pkg-comment
new file mode 100644
index 000000000000..d4119b70c536
--- /dev/null
+++ b/mail/p5-Mail-RBL/pkg-comment
@@ -0,0 +1 @@
+Perl extension to access RBL-style host verification services
diff --git a/mail/p5-Mail-RBL/pkg-descr b/mail/p5-Mail-RBL/pkg-descr
new file mode 100644
index 000000000000..53e646d1b733
--- /dev/null
+++ b/mail/p5-Mail-RBL/pkg-descr
@@ -0,0 +1,17 @@
+This module eases the task of checking if a given host is in the list.
+The methods available are described below:
+
+`->new(suffix)'
+ Creates a list handle. The `suffix' parameter is mandatory and
+ specifies which suffix to append to the queries.
+
+`->check($host)'
+ `$host' can be either a hostname or an IP address. In the case of an
+ IP Address, any trailing netmask (anything after a '/' character)
+ will be ignored. In the case of a hostname, all the IP addresses
+ will be looked up and checked against the list. If any of the
+ addresses is in the list, the host will be considered in the list as
+ a whole.
+
+AUTHOR: Luis E. Munoz <lem@cantv.net>
+WWW: http://search.cpan.org/search?dist=Mail-RBL
diff --git a/mail/p5-Mail-RBL/pkg-plist b/mail/p5-Mail-RBL/pkg-plist
new file mode 100644
index 000000000000..c6fbb6e5b3a8
--- /dev/null
+++ b/mail/p5-Mail-RBL/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Mail/RBL.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Mail 2>/dev/null || true
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/RBL/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/RBL
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail 2>/dev/null || true