aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-qpsmtpd
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-11-24 17:40:44 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-11-24 17:40:44 +0000
commitd77405fd6ddcab0d74954f84af513301be928298 (patch)
treef9d8301a9f6d3b115d6bf94c75a45e2ab5278877 /mail/p5-qpsmtpd
parent4a5323a0ff234534ebccba59d01996ac41ba379d (diff)
downloadports-d77405fd6ddcab0d74954f84af513301be928298.tar.gz
ports-d77405fd6ddcab0d74954f84af513301be928298.zip
- Wrap up cd && foo in parenthesis, it'd break with bmake -j
- Replace some FIND ... CPIO with COPYTREE_SHARE.
Notes
Notes: svn path=/head/; revision=334748
Diffstat (limited to 'mail/p5-qpsmtpd')
-rw-r--r--mail/p5-qpsmtpd/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/mail/p5-qpsmtpd/Makefile b/mail/p5-qpsmtpd/Makefile
index 40de795f0a7e..50f1c8fded5f 100644
--- a/mail/p5-qpsmtpd/Makefile
+++ b/mail/p5-qpsmtpd/Makefile
@@ -58,16 +58,16 @@ pre-configure:
@${RM} ${WRKSRC}/plugins/milter
post-install:
- @${MKDIR} ${DATADIR}/
+ @${MKDIR} ${DATADIR}
@${MKDIR} ${DATADIR}/plugins
- cd ${WRKSRC}/plugins/ && ${COPYTREE_SHARE} \* ${DATADIR}/plugins/
+ (cd ${WRKSRC}/plugins && ${COPYTREE_SHARE} . ${DATADIR}/plugins)
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README* ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README* ${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}/
- cd ${WRKSRC}/config.sample/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/config.sample/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>