aboutsummaryrefslogtreecommitdiff
path: root/mail/pear-Mail
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-06-08 06:54:25 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-06-08 06:54:25 +0000
commit6c3e009476c39f04b9f0350fedbb631d1a5e27d9 (patch)
treeb4228f7249b027bc9f610e371f55ec1c90bb0772 /mail/pear-Mail
parent413c4f99ce34793cada9d6c29d5994afa2ad87f9 (diff)
downloadports-6c3e009476c39f04b9f0350fedbb631d1a5e27d9.tar.gz
ports-6c3e009476c39f04b9f0350fedbb631d1a5e27d9.zip
Notes
Diffstat (limited to 'mail/pear-Mail')
-rw-r--r--mail/pear-Mail/Makefile26
-rw-r--r--mail/pear-Mail/distinfo1
-rw-r--r--mail/pear-Mail/pkg-descr9
-rw-r--r--mail/pear-Mail/pkg-plist8
4 files changed, 44 insertions, 0 deletions
diff --git a/mail/pear-Mail/Makefile b/mail/pear-Mail/Makefile
new file mode 100644
index 000000000000..899789c2eabc
--- /dev/null
+++ b/mail/pear-Mail/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-Mail
+# Date created: 26 November 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail
+PORTVERSION= 1.0.2
+CATEGORIES= mail www
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR class that provides multiple interfaces for sending emails
+
+BUILD_DEPENDS= ${PEARDIR}/Net/SMTP.php:${PORTSDIR}/net/pear-Net_SMTP
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Mail*
+ @${CHMOD} a-x ${PEARDIR}/Mail.php
+
+.include <bsd.port.post.mk>
diff --git a/mail/pear-Mail/distinfo b/mail/pear-Mail/distinfo
new file mode 100644
index 000000000000..e0e26fdb3159
--- /dev/null
+++ b/mail/pear-Mail/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Mail-1.0.2.tgz) = d146356060ec1e7bcf62120f62579088
diff --git a/mail/pear-Mail/pkg-descr b/mail/pear-Mail/pkg-descr
new file mode 100644
index 000000000000..172ef76a79b3
--- /dev/null
+++ b/mail/pear-Mail/pkg-descr
@@ -0,0 +1,9 @@
+The PEAR's Mail:: interface, defines the interface for implementing mailers
+under the PEAR hierarchy, and provides supporting functions useful in multiple
+mailer backends.
+
+Currently supported are native PHP mail() function, sendmail and SMTP.
+This package also provides a RFC 822 Email address list validation utility
+class.
+
+WWW: http://pear.php.net/package-info.php?package=Mail
diff --git a/mail/pear-Mail/pkg-plist b/mail/pear-Mail/pkg-plist
new file mode 100644
index 000000000000..f93aaa425f56
--- /dev/null
+++ b/mail/pear-Mail/pkg-plist
@@ -0,0 +1,8 @@
+%%PEARDIR%%/Mail/RFC822.php
+%%PEARDIR%%/Mail/mail.php
+%%PEARDIR%%/Mail/sendmail.php
+%%PEARDIR%%/Mail/smtp.php
+%%PEARDIR%%/Mail.php
+%%PKGREGDIR%%/package.xml
+@dirrm %%PEARDIR%%/Mail
+@dirrm %%PKGREGDIR%%