aboutsummaryrefslogtreecommitdiff
path: root/mail/pecl-mailparse
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
commit077b4b53b0d0814df73a850dfa8625101c7b8404 (patch)
tree1635d75a5b1ebd11d644c2d01607580c9063de35 /mail/pecl-mailparse
parent95cfdcc8b6a9c07b40477662aa446e3bdd99525b (diff)
downloadports-077b4b53b0d0814df73a850dfa8625101c7b8404.tar.gz
ports-077b4b53b0d0814df73a850dfa8625101c7b8404.zip
Notes
Diffstat (limited to 'mail/pecl-mailparse')
-rw-r--r--mail/pecl-mailparse/Makefile40
-rw-r--r--mail/pecl-mailparse/pkg-deinstall13
-rw-r--r--mail/pecl-mailparse/pkg-plist2
3 files changed, 12 insertions, 43 deletions
diff --git a/mail/pecl-mailparse/Makefile b/mail/pecl-mailparse/Makefile
index d401f211d2f1..21a45939745c 100644
--- a/mail/pecl-mailparse/Makefile
+++ b/mail/pecl-mailparse/Makefile
@@ -7,53 +7,35 @@
PORTNAME= mailparse
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= mail www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR classes to create and decode MIME messages
-BUILD_DEPENDS= ${LOCALBASE}/bin/phpize:${PORTSDIR}/www/mod_php4 \
- ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR
-RUN_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
-USE_AUTOMAKE= yes
-USE_AUTOCONF= yes
-
-.include <bsd.port.pre.mk>
-
-# Don't call autoconf directly, ./buildconf does this
-GNU_CONFIGURE= yes
-USE_AUTOCONF= no
-USE_LIBTOOL= no
+USE_PHPIZE= yes
USE_REINPLACE= yes
-
REINPLACE_ARGS= -i.before_mailparse
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+
.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e \
"s:${PHP_BASE}/::"
-.else
-PHP_BASE= ${LOCALBASE}
.endif
-PEAR= ${LOCALBASE}/bin/pear
-LPHP_LIB= lib/php
PHP_DIR?= ${LOCALBASE}/etc
PHP_INI= ${PHP_DIR}/php.ini
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= EXTDIR=${EXT_DIR} PEARDIR=${LPHP_LIB}
+PLIST_SUB+= EXTDIR=${EXT_DIR}
DOCSDIR= ${PEARDIR}/docs/${PORTNAME}
DOCS= CREDITS README try.php
TESTDIR= ${PEARDIR}/tests/${PORTNAME}
-post-patch:
- (cd ${WRKSRC} && ${LOCALBASE}/bin/phpize)
-
pre-configure:
@if ! ${LOCALBASE}/bin/php -i | ${GREP} -q -e "--enable-mbstring"; then \
${ECHO_MSG} "" ; \
@@ -62,7 +44,7 @@ pre-configure:
${FALSE} ; \
fi
-post-install:
+post-install-script:
@${STRIP_CMD} ${PHP_BASE}/${EXT_DIR}/mailparse.so
# Configure extension_dir
@if [ ! -f ${PHP_INI} ]; then \
@@ -85,7 +67,5 @@ post-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${TESTDIR}
@${ECHO_MSG} "===> Examples installed in ${TESTDIR}."
.endif
-# Register a new package
- @${PEAR} install -r -f ${WRKDIR}/package.xml
.include <bsd.port.post.mk>
diff --git a/mail/pecl-mailparse/pkg-deinstall b/mail/pecl-mailparse/pkg-deinstall
deleted file mode 100644
index c17e9d19ced0..000000000000
--- a/mail/pecl-mailparse/pkg-deinstall
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# Remove package declaration from PEAR's registry.
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-PKG_NAME=${1%%-[0-9._]*}
-PACKAGE=$(echo $PKG_NAME | sed 's/pear-//')
-
-${PKG_PREFIX}/bin/pear uninstall -r ${PACKAGE} || true
diff --git a/mail/pecl-mailparse/pkg-plist b/mail/pecl-mailparse/pkg-plist
index a22d5cbce5da..0ec98dc03925 100644
--- a/mail/pecl-mailparse/pkg-plist
+++ b/mail/pecl-mailparse/pkg-plist
@@ -1,4 +1,5 @@
%%EXTDIR%%/mailparse.so
+%%PKGREGDIR%%/package.xml
%%PORTDOCS%%%%PEARDIR%%/docs/mailparse/CREDITS
%%PORTDOCS%%%%PEARDIR%%/docs/mailparse/README
%%PORTDOCS%%%%PEARDIR%%/docs/mailparse/try.php
@@ -22,3 +23,4 @@
%%PORTDOCS%%@dirrm %%PEARDIR%%/docs/mailparse
%%PORTDOCS%%@dirrm %%PEARDIR%%/tests/mailparse/tests/testdata
%%PORTDOCS%%@dirrm %%PEARDIR%%/tests/mailparse/tests/
+@dirrm %%PKGREGDIR%%