aboutsummaryrefslogtreecommitdiff
path: root/mail/pine-pgp-filters
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-02-06 22:59:21 +0000
committerJohn Marino <marino@FreeBSD.org>2015-02-06 22:59:21 +0000
commit239cd9d9b378fb68a5058fe740b7c56ee595bf3c (patch)
treec21bc243058a01bce6b7fa873955e48dc2873a24 /mail/pine-pgp-filters
parentb9640de8a0a28790abed778f09e56f098079f726 (diff)
downloadports-239cd9d9b378fb68a5058fe740b7c56ee595bf3c.tar.gz
ports-239cd9d9b378fb68a5058fe740b7c56ee595bf3c.zip
mail/pine-pgp-filters: use gnupg only, fix MASTER_SITES
When dougb released the port, he also reset the MASTER_SITES. It has been pulling off the cache ever since. If the cache gets cleared, this port would break. I've moved the distfiles to my LOCAL site so this never happens. The other big change is to remove this hacky dependency logic. Someone tried to select between gnupg and gnupg1 depending on what was already installed. For the standard packages builders, this meant the port always used the old gnupg1 because gnupg was never installed in the clean jail. As both gnupg packages are range between 1.0M and 1.5M in size and can coexist, the savings of resources in miniscule assuming they weren't both installed anyway. Let's just pick the new gnupg as the unconditional dependency and remove the hack. Inspired by discussion on PR which was trying to fix a bug in the hack. PR: 195426 Submitted by: Trond Endrestol
Notes
Notes: svn path=/head/; revision=378568
Diffstat (limited to 'mail/pine-pgp-filters')
-rw-r--r--mail/pine-pgp-filters/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/mail/pine-pgp-filters/Makefile b/mail/pine-pgp-filters/Makefile
index 2ddd8ff8976e..3dd40d4892a9 100644
--- a/mail/pine-pgp-filters/Makefile
+++ b/mail/pine-pgp-filters/Makefile
@@ -2,14 +2,17 @@
PORTNAME= pine-pgp-filters
PORTVERSION= 1.8
+PORTREVISION= 1
CATEGORIES= mail security
-#MASTER_SITES=
+MASTER_SITES= LOCAL/marino
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple /bin/sh-based filters to use GnuPG with Alpine
+BUILD_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
+RUN_DEPENDS+= gpg2:${PORTSDIR}/security/gnupg
RUN_DEPENDS= alpine:${PORTSDIR}/mail/alpine
PORTDOCS= BUGS CHANGES INSTALL LICENSE README
@@ -17,16 +20,6 @@ PLIST_FILES= bin/ppf_mime bin/ppf_mime_decrypt \
libexec/ppf_decrypt libexec/ppf_encrypt libexec/ppf_mime \
libexec/ppf_mime_decrypt libexec/ppf_sign libexec/ppf_verify
-# We want to be version-agnostic here, but also record the right dependency
-# if the user installs the package and already has one or the other installed.
-.if exists(${LOCALBASE}/bin/gpg2)
-BUILD_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
-RUN_DEPENDS+= gpg2:${PORTSDIR}/security/gnupg
-.else
-BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg1
-RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg1
-.endif
-
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc