aboutsummaryrefslogtreecommitdiff
path: root/mail/pine4
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2002-12-17 22:33:31 +0000
committerDoug Barton <dougb@FreeBSD.org>2002-12-17 22:33:31 +0000
commitd3779e8b5b0453d7e703dcd85eaff47ab32f2286 (patch)
treebe321e621ae5f5b8f491231afbd1033a01171e0a /mail/pine4
parentbc81abb89f844332dc1b043d7c63312e90b774f5 (diff)
downloadports-d3779e8b5b0453d7e703dcd85eaff47ab32f2286.tar.gz
ports-d3779e8b5b0453d7e703dcd85eaff47ab32f2286.zip
Notes
Diffstat (limited to 'mail/pine4')
-rw-r--r--mail/pine4/Makefile6
-rw-r--r--mail/pine4/distinfo2
-rw-r--r--mail/pine4/files/patch-al21
-rw-r--r--mail/pine4/files/patch-reply.c29
4 files changed, 33 insertions, 25 deletions
diff --git a/mail/pine4/Makefile b/mail/pine4/Makefile
index 7f61741a7f2d..146ec958622b 100644
--- a/mail/pine4/Makefile
+++ b/mail/pine4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pine
-PORTVERSION= 4.50
+PORTVERSION= 4.51
CATEGORIES= mail news
MASTER_SITES= ftp://ftp.cac.washington.edu/pine/
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -38,7 +38,7 @@ pre-fetch:
.endif
post-patch:
- for i in ${WRKSRC}/doc/pine.1 \
+ @for i in ${WRKSRC}/doc/pine.1 \
${WRKSRC}/pine/init.c \
${WRKSRC}/pine/pine.hlp \
${WRKSRC}/pine/mailcap.c \
@@ -48,7 +48,7 @@ post-patch:
$$i.sed >$$i ; \
${RM} $$i.sed ; \
done
- for i in ${WRKSRC}/doc/tech-notes.txt \
+ @for i in ${WRKSRC}/doc/tech-notes.txt \
${WRKSRC}/doc/tech-notes/*.html ; do \
${MV} $$i $$i.sed ; \
${SED} -e "s:/usr/local/lib/:${PREFIX}/etc/:g" \
diff --git a/mail/pine4/distinfo b/mail/pine4/distinfo
index 7b7bf466d922..84d005df1d15 100644
--- a/mail/pine4/distinfo
+++ b/mail/pine4/distinfo
@@ -1 +1 @@
-MD5 (pine4.50.tar.gz) = 5f517297242f625de9a9ccbaf48578f0
+MD5 (pine4.51.tar.gz) = 4ce7c7776b56177852975a2ad19f7202
diff --git a/mail/pine4/files/patch-al b/mail/pine4/files/patch-al
index fef99259e733..60f4c3f09cd2 100644
--- a/mail/pine4/files/patch-al
+++ b/mail/pine4/files/patch-al
@@ -1,7 +1,7 @@
-*** build.orig Tue Nov 5 18:17:56 2002
---- build Tue Nov 26 03:16:11 2002
+*** build.orig Mon Dec 9 09:54:38 2002
+--- build Mon Dec 16 02:16:44 2002
***************
-*** 350,411 ****
+*** 362,424 ****
echo "Including SSL functionality"
fi
@@ -48,7 +48,8 @@
- fi
- eval echo eval make "$makeargs" "SSLTYPE=$SSL" "SPECIALS=`cat SPECIALS`" "$K2" $ccltarg
- eval make "$makeargs" "SSLTYPE=$SSL" "SPECIALS=`cat SPECIALS`" "$K2" $ccltarg
-- if [ $? != "0" ]
+- rc=$?
+- if [ $rc != "0" ]
- then
- echo "+---------------------------------------------+"
- echo "| Problems building c-client |"
@@ -57,16 +58,16 @@
- echo "| possible explanation for this failure |"
- echo "+---------------------------------------------+"
- echo ""
-- exit $?
+- exit $rc
- fi
- echo ''
-
echo "Making Pico and Pilot"
cd "$PHOME/pico"
eval echo make "$makeargs" -f makefile.$picotarg
---- 350,355 ----
+--- 362,367 ----
***************
-*** 435,441 ****
+*** 450,456 ****
cd "$PHOME"
echo ''
echo "Links to executables are in bin directory:"
@@ -74,7 +75,7 @@
case $maketarg in
mnt) echo "Fixing stacksizes ..."
fixstk 64K bin/pine bin/pico bin/imapd bin/mtest bin/pilot
---- 379,385 ----
+--- 393,399 ----
cd "$PHOME"
echo ''
echo "Links to executables are in bin directory:"
@@ -83,7 +84,7 @@
mnt) echo "Fixing stacksizes ..."
fixstk 64K bin/pine bin/pico bin/imapd bin/mtest bin/pilot
***************
-*** 469,478 ****
+*** 484,493 ****
rm -f sslnopwd sslunix.nopwd sslsco.nopwd sslunix sslsco sslnone
echo "Cleaning Pine"
cd "$PHOME/pine"
@@ -94,7 +95,7 @@
echo "Done"
cd "$PHOME"
;;
---- 413,422 ----
+--- 427,436 ----
rm -f sslnopwd sslunix.nopwd sslsco.nopwd sslunix sslsco sslnone
echo "Cleaning Pine"
cd "$PHOME/pine"
diff --git a/mail/pine4/files/patch-reply.c b/mail/pine4/files/patch-reply.c
index e829cd5c3a82..8e38b85419c8 100644
--- a/mail/pine4/files/patch-reply.c
+++ b/mail/pine4/files/patch-reply.c
@@ -1,6 +1,6 @@
---- pine/reply.c.orig Tue Aug 7 15:52:03 2001
-+++ pine/reply.c Fri Sep 28 00:29:19 2001
-@@ -4997,23 +4997,24 @@
+--- pine/reply.c.orig Wed Dec 4 21:10:12 2002
++++ pine/reply.c Mon Dec 16 03:40:23 2002
+@@ -5092,7 +5092,10 @@
char *
generate_message_id()
{
@@ -12,26 +12,33 @@
char *id;
time_t now;
struct tm *now_x;
+@@ -5100,14 +5103,11 @@
now = time((time_t *)0);
now_x = localtime(&now);
- id = (char *)fs_get(128 * sizeof(char));
+ id = (char *)fs_get(384 * sizeof(char));
-- if(now_x->tm_sec == osec){
-- cnt++;
-- }else{
+- if(now_x->tm_sec == osec)
+- cnt++;
+- else{
- cnt = 0;
- osec = now_x->tm_sec;
- }
-- sprintf(id,"<Pine.%.4s.%.20s.%02d%02d%02d%02d%02d%02d%X.%d@%.50s>",
-- SYSTYPE, pine_version, (now_x->tm_year) % 100, now_x->tm_mon + 1,
+ cnt = 'A';
+ if(gettimeofday(&tp, &tzp) == 0)
-+ cnt += (time_t)tp.tv_usec % ('Z' - 'A');
-+
++ cnt += (time_t)tp.tv_usec % ('Z' - 'A');
+
+ hostpart = F_ON(F_ROT13_MESSAGE_ID, ps_global)
+ ? rot13(ps_global->hostname)
+@@ -5116,8 +5116,8 @@
+ if(!hostpart)
+ hostpart = cpystr("huh");
+
+- sprintf(id,"<Pine.%.4s.%.20s.%02d%02d%02d%02d%02d%02d%X.%d@%.50s>",
+- SYSTYPE, pine_version, (now_x->tm_year) % 100, now_x->tm_mon + 1,
+ sprintf(id,"<%d%02d%02d%02d%02d%02d.%c%d@%s>",
+ (now_x->tm_year) + 1900, now_x->tm_mon + 1,
now_x->tm_mday, now_x->tm_hour, now_x->tm_min, now_x->tm_sec,
- cnt, getpid(), ps_global->hostname);
+ cnt, getpid(), hostpart);