aboutsummaryrefslogtreecommitdiff
path: root/mail/pop-before-smtp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-28 20:44:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-28 20:44:40 +0000
commitef77dcdcb9379ae1a308cb6545083b4531962c9f (patch)
tree05bad2ffc8d85443e72779df9357b38484377915 /mail/pop-before-smtp
parent679feb98cf004b1b52827f89127c88bb7d398abf (diff)
downloadports-ef77dcdcb9379ae1a308cb6545083b4531962c9f.tar.gz
ports-ef77dcdcb9379ae1a308cb6545083b4531962c9f.zip
Notes
Diffstat (limited to 'mail/pop-before-smtp')
-rw-r--r--mail/pop-before-smtp/Makefile14
-rw-r--r--mail/pop-before-smtp/distinfo6
-rw-r--r--mail/pop-before-smtp/files/pkg-message.in (renamed from mail/pop-before-smtp/pkg-message)0
-rw-r--r--mail/pop-before-smtp/files/pop-before-smtp.sh100
-rw-r--r--mail/pop-before-smtp/files/pop-before-smtp.sh.in58
-rw-r--r--mail/pop-before-smtp/pkg-plist1
6 files changed, 64 insertions, 115 deletions
diff --git a/mail/pop-before-smtp/Makefile b/mail/pop-before-smtp/Makefile
index 5035de2c4656..491f43142ccc 100644
--- a/mail/pop-before-smtp/Makefile
+++ b/mail/pop-before-smtp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pop-before-smtp
-PORTVERSION= 1.37
+PORTVERSION= 1.39
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= popbsmtp
@@ -22,15 +22,12 @@ RUN_DEPENDS= ${SITE_PERL}/File/Tail.pm:${PORTSDIR}/devel/p5-File-Tail \
NO_BUILD= yes
USE_PERL5= yes
-USE_REINPLACE= yes
+USE_RC_SUBR= pop-before-smtp.sh
+SUB_FILES= pkg-message
POD2MAN?= pod2man
-PKGMESSAGE= ${WRKDIR}/.pkg-message
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
MAN8= ${PORTNAME}.8
-# Override this as you see fit
-POPBSMTP_RC_SCRIPT?= ${PREFIX}/etc/rc.d/pop-before-smtp.sh.sample
-
post-patch:
@${REINPLACE_CMD} 's|^#!/usr/bin/perl|#!${PERL}|; \
s|/etc/postfix/pop-before-smtp|${PREFIX}/etc/postfix/pop-before-smtp|g;' \
@@ -44,9 +41,6 @@ do-install:
${INSTALL_SCRIPT} \
${WRKSRC}/pop-before-smtp-conf.pl \
${PREFIX}/etc/pop-before-smtp-conf.pl.sample
- @${SED} -e "s|%PREFIX%|${PREFIX}|g" \
- < ${FILESDIR}/pop-before-smtp.sh > ${POPBSMTP_RC_SCRIPT}
- @${CHMOD} 755 ${POPBSMTP_RC_SCRIPT}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in COPYING ChangeLog README TODO
@@ -62,8 +56,6 @@ do-install:
.endif
post-install:
- @${SED} -e "s|%PREFIX%|${PREFIX}|" \
- ${.CURDIR}/pkg-message > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/mail/pop-before-smtp/distinfo b/mail/pop-before-smtp/distinfo
index 72858099ffb8..0e9b39bba351 100644
--- a/mail/pop-before-smtp/distinfo
+++ b/mail/pop-before-smtp/distinfo
@@ -1,3 +1,3 @@
-MD5 (pop-before-smtp-1.37.tar.gz) = 8c1fc935708163168f7870ccf730fc0e
-SHA256 (pop-before-smtp-1.37.tar.gz) = d577d9ebbc5defeb1519c4ef12285424e0a3e3fed57e46dcdc3d01d53fc00811
-SIZE (pop-before-smtp-1.37.tar.gz) = 36249
+MD5 (pop-before-smtp-1.39.tar.gz) = c54513af8e9a8f2245826b23b6807da4
+SHA256 (pop-before-smtp-1.39.tar.gz) = 19b5b280c1550ba0d3cd9a804b3762d16757c0646ceb4c8dd79c5d036be2b463
+SIZE (pop-before-smtp-1.39.tar.gz) = 38741
diff --git a/mail/pop-before-smtp/pkg-message b/mail/pop-before-smtp/files/pkg-message.in
index c9f547be9014..c9f547be9014 100644
--- a/mail/pop-before-smtp/pkg-message
+++ b/mail/pop-before-smtp/files/pkg-message.in
diff --git a/mail/pop-before-smtp/files/pop-before-smtp.sh b/mail/pop-before-smtp/files/pop-before-smtp.sh
deleted file mode 100644
index d3a226b5b0e6..000000000000
--- a/mail/pop-before-smtp/files/pop-before-smtp.sh
+++ /dev/null
@@ -1,100 +0,0 @@
-#!/bin/sh
-# File: pop-before-smtp.sh
-# Date: Fri Mar 7 11:20:43 2003
-# Time-stamp: <2003-03-08 23:58:53 ericx>
-# Description: start/stop script for pop-before-smtp daemon
-#
-# $FreeBSD$
-
-# Thanks to ume@FreeBSD.org for a nifty saslauthd.sh to steal from...
-
-action=$1
-
-PREFIX=%PREFIX%
-
-# Suck in the configuration variables.
-if [ -z "${source_rc_confs_defined}" ]; then
- if [ -r /etc/defaults/rc.conf ]; then
- . /etc/defaults/rc.conf
- source_rc_confs
- elif [ -r /etc/rc.conf ]; then
- . /etc/rc.conf
- fi
-fi
-
-# The following pop_before_smtp_* variables may be defined in rc.conf
-#
-# pop_before_smtp_enable - Set to YES to enable pop-before-smtp
-# Default: no
-#
-# pop_before_smtp_program - Path to pop-before-smtp program
-# Default: ${PREFIX}/sbin/pop-before-smtp
-#
-# pop_before_smtp_config - Path to pop-before-smtp configuration
-# Default:
-# ${PREFIX}/etc/pop-before-smtp-conf.pl
-#
-# pop_before_smtp_flags - Flags to pop-before-smtp program
-# Default: [none]
-#
-# pop_before_smtp_pid - Path to pop-before-smtp pid file
-# Default: /var/run/pop-before-smtp.pid
-#
-
-if [ -z "${pop_before_smtp_enable}" ]; then
- pop_before_smtp_enable=no
-fi
-
-if [ -z "${pop_before_smtp_program}" ]; then
- pop_before_smtp_program=${PREFIX}/sbin/pop-before-smtp
-fi
-
-if [ -z "${pop_before_smtp_config}" ]; then
- pop_before_smtp_config=${PREFIX}/etc/pop-before-smtp-conf.pl
-fi
-
-if [ -z "${pop_before_smtp_flags}" ]; then
- pop_before_smtp_flags=""
-fi
-
-if [ -z "${pop_before_smtp_pid}" ]; then
- pop_before_smtp_pid=/var/run/pop-before-smtp.pid
-fi
-
-rc=0
-
-case "${pop_before_smtp_enable}" in
- [Yy][Ee][Ss])
- case "${action}" in
-
- start)
- if [ -x ${pop_before_smtp_program} ] ; then
- ${pop_before_smtp_program} \
- --config=${pop_before_smtp_config} \
- ${pop_before_smtp_flags} \
- --daemon=${pop_before_smtp_pid} \
- >/dev/null 2>&1 && \
- echo -n " pop-before-smtp "
- fi
- ;;
-
- stop)
- if [ -r ${pop_before_smtp_pid} ]; then
- kill `cat ${pop_before_smtp_pid}` && \
- echo -n " pop-before-smtp"
- rm ${pop_before_smtp_pid}
- fi
- ;;
-
- *)
- echo "usage: $0 {start|stop}" 1>&2
- rc=64
- ;;
- esac
- ;;
- *)
- rc=0
- ;;
-esac
-
-exit $rc
diff --git a/mail/pop-before-smtp/files/pop-before-smtp.sh.in b/mail/pop-before-smtp/files/pop-before-smtp.sh.in
new file mode 100644
index 000000000000..06031caba619
--- /dev/null
+++ b/mail/pop-before-smtp/files/pop-before-smtp.sh.in
@@ -0,0 +1,58 @@
+#!/bin/sh
+# File: pop-before-smtp.sh
+# Date: Fri Mar 7 11:20:43 2003
+# Time-stamp: <2006-01-26 11:54:41 ericx>
+# Description: start/stop script for pop-before-smtp daemon
+#
+# $FreeBSD$
+
+# PROVIDE: pop-before-smtp
+# REQUIRE: DAEMON
+# BEFORE: mail
+# KEYWORD: shutdown
+#
+# PLEASE note the distinction between dashes [-] and underscores [_]...
+#
+# The following pop_before_smtp_* variables may be defined in
+# /etc/rc.conf or /etc/rc.conf.d/pop_before_smtp
+#
+# pop_before_smtp_enable - Set to YES to enable pop-before-smtp
+# Default: no
+#
+# pop_before_smtp_program - Path to pop-before-smtp program
+# Default: ${PREFIX}/sbin/pop-before-smtp
+#
+# pop_before_smtp_config - Path to pop-before-smtp configuration
+# Default:
+# ${PREFIX}/etc/pop-before-smtp-conf.pl
+#
+# pop_before_smtp_flags - Flags to pop-before-smtp program
+# Default: [none]
+#
+# pop_before_smtp_pid - Path to pop-before-smtp pid file
+# Default: /var/run/pop-before-smtp.pid
+#
+
+. %%RC_SUBR%%
+
+PREFIX=%PREFIX%
+
+# sh interprets dash chars as the numeric minus operator...
+name="pop_before_smtp"
+filename="pop-before-smtp"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+command=${pop_before_smtp_program:-"${PREFIX}/sbin/${filename}"}
+pidfile=${pop_before_smtp_pid:-"/var/run/${filename}.pid"}
+config=${pop_before_smtp_config:-"${PREFIX}/etc/${filename}-conf.pl"}
+
+command_args="--config=${config}"
+command_args="${command_args} ${pop_before_smtp_flags:-''}"
+command_args="${command_args} --daemon=${pidfile}"
+
+command_interpreter=%PERL%
+required_files=${config}
+
+run_rc_command "$1"
diff --git a/mail/pop-before-smtp/pkg-plist b/mail/pop-before-smtp/pkg-plist
index bcc73914cdf4..76aea1158816 100644
--- a/mail/pop-before-smtp/pkg-plist
+++ b/mail/pop-before-smtp/pkg-plist
@@ -1,6 +1,5 @@
@comment $FreeBSD$
etc/pop-before-smtp-conf.pl.sample
-etc/rc.d/pop-before-smtp.sh.sample
sbin/pop-before-smtp
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog