aboutsummaryrefslogtreecommitdiff
path: root/mail/pop-before-smtp
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-03-21 20:23:15 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-03-21 20:23:15 +0000
commit8be8ea452cdc3b83d126ed01fda9df8cd1e2a377 (patch)
tree663f43e78b89c816ccb95ad4d24f874f185da58c /mail/pop-before-smtp
parent654406613e60b2093ac22e7031d4e9a96a4b68b6 (diff)
downloadports-8be8ea452cdc3b83d126ed01fda9df8cd1e2a377.tar.gz
ports-8be8ea452cdc3b83d126ed01fda9df8cd1e2a377.zip
Notes
Diffstat (limited to 'mail/pop-before-smtp')
-rw-r--r--mail/pop-before-smtp/Makefile14
-rw-r--r--mail/pop-before-smtp/files/pop-before-smtp.sh.in10
2 files changed, 10 insertions, 14 deletions
diff --git a/mail/pop-before-smtp/Makefile b/mail/pop-before-smtp/Makefile
index d7ef1bde8aea..cf2e57c18354 100644
--- a/mail/pop-before-smtp/Makefile
+++ b/mail/pop-before-smtp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pop-before-smtp
PORTVERSION= 1.41
+PORTREVISION= 1
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= popbsmtp
@@ -14,27 +15,24 @@ MASTER_SITE_SUBDIR= popbsmtp
MAINTAINER= ericx@vineyard.net
COMMENT= A log parser to identify valid POP/IMAP logins for later smtp
-RUN_DEPENDS= ${SITE_PERL}/File/Tail.pm:${PORTSDIR}/devel/p5-File-Tail \
- ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
- ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
+RUN_DEPENDS= ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
${SITE_PERL}/Date/Format.pm:${PORTSDIR}/devel/p5-TimeDate
NO_BUILD= yes
-USE_PERL5= yes
+USE_PERL5_RUN= yes
USE_RC_SUBR= pop-before-smtp.sh
SUB_FILES= pkg-message
-POD2MAN?= pod2man
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+SUB_LIST= PERL=${PERL}
+
MAN8= ${PORTNAME}.8
post-patch:
@${REINPLACE_CMD} 's|^#!/usr/bin/perl|#!${PERL}|; \
s|/etc/postfix/pop-before-smtp|${PREFIX}/etc/postfix/pop-before-smtp|g;' \
${WRKSRC}/pop-before-smtp
-
pre-install:
- @${POD2MAN} ${WRKSRC}/${PORTNAME} > ${PREFIX}/man/man8/${PORTNAME}.8
+ @pod2man ${WRKSRC}/${PORTNAME} > ${MANPREFIX}/man/man8/${PORTNAME}.8
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/pop-before-smtp ${PREFIX}/sbin
diff --git a/mail/pop-before-smtp/files/pop-before-smtp.sh.in b/mail/pop-before-smtp/files/pop-before-smtp.sh.in
index 06031caba619..7ed1e2688a89 100644
--- a/mail/pop-before-smtp/files/pop-before-smtp.sh.in
+++ b/mail/pop-before-smtp/files/pop-before-smtp.sh.in
@@ -1,7 +1,7 @@
#!/bin/sh
# File: pop-before-smtp.sh
# Date: Fri Mar 7 11:20:43 2003
-# Time-stamp: <2006-01-26 11:54:41 ericx>
+# Time-stamp: <2006-03-17 15:29:06 ericx>
# Description: start/stop script for pop-before-smtp daemon
#
# $FreeBSD$
@@ -35,8 +35,6 @@
. %%RC_SUBR%%
-PREFIX=%PREFIX%
-
# sh interprets dash chars as the numeric minus operator...
name="pop_before_smtp"
filename="pop-before-smtp"
@@ -44,15 +42,15 @@ rcvar=`set_rcvar`
load_rc_config $name
-command=${pop_before_smtp_program:-"${PREFIX}/sbin/${filename}"}
+command=${pop_before_smtp_program:-"%%PREFIX%%/sbin/${filename}"}
pidfile=${pop_before_smtp_pid:-"/var/run/${filename}.pid"}
-config=${pop_before_smtp_config:-"${PREFIX}/etc/${filename}-conf.pl"}
+config=${pop_before_smtp_config:-"%%PREFIX%%/etc/${filename}-conf.pl"}
command_args="--config=${config}"
command_args="${command_args} ${pop_before_smtp_flags:-''}"
command_args="${command_args} --daemon=${pidfile}"
-command_interpreter=%PERL%
+command_interpreter=%%PERL%%
required_files=${config}
run_rc_command "$1"