aboutsummaryrefslogtreecommitdiff
path: root/mail/pop3proxy
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2004-05-11 17:09:06 +0000
committerMartin Blapp <mbr@FreeBSD.org>2004-05-11 17:09:06 +0000
commit84b2d4156f26e028832557269d7786d16386514a (patch)
tree51c76b46496bc6d5c2837c47694a87fb1608e5fb /mail/pop3proxy
parent41726bea73e42c927d3156ed1056886576a62fd8 (diff)
downloadports-84b2d4156f26e028832557269d7786d16386514a.tar.gz
ports-84b2d4156f26e028832557269d7786d16386514a.zip
Notes
Diffstat (limited to 'mail/pop3proxy')
-rw-r--r--mail/pop3proxy/Makefile41
-rw-r--r--mail/pop3proxy/distinfo2
-rw-r--r--mail/pop3proxy/files/pop3proxyd.conf11
-rw-r--r--mail/pop3proxy/files/pop3proxyd.sh25
-rw-r--r--mail/pop3proxy/pkg-descr2
-rw-r--r--mail/pop3proxy/pkg-message9
-rw-r--r--mail/pop3proxy/pkg-plist4
7 files changed, 94 insertions, 0 deletions
diff --git a/mail/pop3proxy/Makefile b/mail/pop3proxy/Makefile
new file mode 100644
index 000000000000..4b1689bbb461
--- /dev/null
+++ b/mail/pop3proxy/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: pop3proxy
+# Date created: 11.05.04
+# Whom: Martin Blapp
+#
+# $FreeBSD$
+#
+
+PORTNAME= pop3proxy
+PORTVERSION= 1.1
+CATEGORIES= mail
+MASTER_SITES= http://people.freebsd.org/~mbr/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mbr@FreeBSD.org
+COMMENT= POP3 Proxy Server derived from UP IMAP Proxy
+
+GNU_CONFIGURE= YES
+USE_AUTOCONF= YES
+USE_RC_SUBR= YES
+
+SAMPLE_EXT= sample
+
+.include <bsd.port.pre.mk>
+
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
+ RC_SUBR=${RC_SUBR}
+
+post-install:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ < ${FILESDIR}/pop3proxyd.conf > ${WRKSRC}/pop3proxyd.conf ;
+ @if [ ! -f ${PREFIX}/etc/pop3proxyd.conf ]; then \
+ @${INSTALL} -c ${WRKSRC}/pop3proxyd.conf ${PREFIX}/etc/pop3proxyd.conf ; \
+ fi
+ @${INSTALL} -c ${WRKSRC}/pop3proxyd.conf ${PREFIX}/etc/pop3proxyd.conf.${SAMPLE_EXT} ;
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ < ${FILESDIR}/pop3proxyd.sh > ${WRKSRC}/pop3proxyd.sh
+ @${INSTALL_SCRIPT} ${WRKSRC}/pop3proxyd.sh ${PREFIX}/etc/rc.d/pop3proxyd.sh
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/mail/pop3proxy/distinfo b/mail/pop3proxy/distinfo
new file mode 100644
index 000000000000..3f113f07e660
--- /dev/null
+++ b/mail/pop3proxy/distinfo
@@ -0,0 +1,2 @@
+MD5 (pop3proxy-1.1.tgz) = 28404e5f595f68b5b66c92ba4f93bc1f
+SIZE (pop3proxy-1.1.tgz) = 167942
diff --git a/mail/pop3proxy/files/pop3proxyd.conf b/mail/pop3proxy/files/pop3proxyd.conf
new file mode 100644
index 000000000000..a21870cc99c5
--- /dev/null
+++ b/mail/pop3proxy/files/pop3proxyd.conf
@@ -0,0 +1,11 @@
+server_hostname yourserver.host.com
+cache_size 10000
+listen_port 10110
+server_port 110
+cache_expiration_time 60
+proc_username nobody
+proc_groupname nogroup
+stat_filename /var/run/pop3proxystats
+protocol_log_filename /var/log/pop3proxy_protocol.log
+syslog_facility LOG_MAIL
+send_tcp_keepalives no
diff --git a/mail/pop3proxy/files/pop3proxyd.sh b/mail/pop3proxy/files/pop3proxyd.sh
new file mode 100644
index 000000000000..cf3f51c05ce6
--- /dev/null
+++ b/mail/pop3proxy/files/pop3proxyd.sh
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: pop3proxyd
+# REQUIRE: LOGIN
+# BEFORE: mail
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following line to /etc/rc.conf to enable pop3proxyd:
+#
+#pop3proxyd_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=pop3proxyd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/pop3proxyd
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/mail/pop3proxy/pkg-descr b/mail/pop3proxy/pkg-descr
new file mode 100644
index 000000000000..d7217080303f
--- /dev/null
+++ b/mail/pop3proxy/pkg-descr
@@ -0,0 +1,2 @@
+This is a POP3 proxycache server useful for use with webmail clients.
+It keeps track of existing connections and caches them.
diff --git a/mail/pop3proxy/pkg-message b/mail/pop3proxy/pkg-message
new file mode 100644
index 000000000000..4f3d5b21cbcc
--- /dev/null
+++ b/mail/pop3proxy/pkg-message
@@ -0,0 +1,9 @@
+****************************************************************************
+
+Please change the name of your mailserver in the pop3proxyd.conf and setup
+the correct ports.
+
+To run the pop3proxyd from startup, add pop3proxyd_enable="YES" in your
+/etc/rc.conf.
+
+****************************************************************************
diff --git a/mail/pop3proxy/pkg-plist b/mail/pop3proxy/pkg-plist
new file mode 100644
index 000000000000..faa0ab35f94f
--- /dev/null
+++ b/mail/pop3proxy/pkg-plist
@@ -0,0 +1,4 @@
+sbin/pop3proxystat
+sbin/pop3proxyd
+etc/rc.d/pop3proxyd.sh
+etc/pop3proxyd.conf.sample