aboutsummaryrefslogtreecommitdiff
path: root/mail/pop3vscan
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-06-06 03:31:30 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-06-06 03:31:30 +0000
commit216ff92287c2c2c1df55f8d4ea455aeaed4fef98 (patch)
tree7667c6cd4385ff610b194d126e65989c144315ab /mail/pop3vscan
parent98429e0a05632846624ddd353338fbd409e4558b (diff)
downloadports-216ff92287c2c2c1df55f8d4ea455aeaed4fef98.tar.gz
ports-216ff92287c2c2c1df55f8d4ea455aeaed4fef98.zip
Notes
Diffstat (limited to 'mail/pop3vscan')
-rw-r--r--mail/pop3vscan/Makefile1
-rw-r--r--mail/pop3vscan/files/patch-Makefile2
-rw-r--r--mail/pop3vscan/files/patch-pop3vscan.c9
-rw-r--r--mail/pop3vscan/files/patch-pop3vscan.h9
4 files changed, 9 insertions, 12 deletions
diff --git a/mail/pop3vscan/Makefile b/mail/pop3vscan/Makefile
index 2c717324e640..826df6e227a4 100644
--- a/mail/pop3vscan/Makefile
+++ b/mail/pop3vscan/Makefile
@@ -23,6 +23,7 @@ RUN_DEPENDS= uvscan:${PORTSDIR}/security/vscan
USE_REINPLACE= yes
USE_GMAKE= yes
USE_GETOPT_LONG=yes
+MAKE_ENV= _LDFLAGS="${LDFLAGS}"
pre-fetch:
.if !defined(WITHOUT_UVSCAN)
diff --git a/mail/pop3vscan/files/patch-Makefile b/mail/pop3vscan/files/patch-Makefile
index 261ddff58c85..06a8d53feb2f 100644
--- a/mail/pop3vscan/files/patch-Makefile
+++ b/mail/pop3vscan/files/patch-Makefile
@@ -10,7 +10,7 @@
-CFLAGS=-Wall -O2
-LDFLAGS=-L. -lmime -lpcre #-static
+CFLAGS=-Wall -O2 -I$(PREFIX)/include -DPREFIX=\"${PREFIX}\"
-+LDFLAGS=-L. -lmime -lpcre -L$(PREFIX)/lib #-static
++LDFLAGS=-L. -lmime -lpcre -L$(PREFIX)/lib $(_LDFLAGS) #-static
OBJECTS=getline.o parsefile.o pop3vscan.o \
scanner_basic.o scanner_avpd.o scanner_trophie.o
diff --git a/mail/pop3vscan/files/patch-pop3vscan.c b/mail/pop3vscan/files/patch-pop3vscan.c
index cdb33b9f7ace..80c2af892c8e 100644
--- a/mail/pop3vscan/files/patch-pop3vscan.c
+++ b/mail/pop3vscan/files/patch-pop3vscan.c
@@ -1,11 +1,14 @@
--- pop3vscan.c.orig Wed Jun 12 08:19:05 2002
+++ pop3vscan.c Tue Jun 3 03:23:38 2003
-@@ -29,9 +29,10 @@
+@@ -27,11 +27,12 @@
+ #include <stdio.h>
+ #include <stdlib.h>
#include <string.h>
- #include <arpa/inet.h>
- #include <netinet/in.h>
+-#include <arpa/inet.h>
+#include <sys/types.h>
+ #include <netinet/in.h>
+#include <netinet/in_systm.h>
++#include <arpa/inet.h>
#include <netinet/ip.h>
#include <sys/socket.h>
-#include <sys/types.h>
diff --git a/mail/pop3vscan/files/patch-pop3vscan.h b/mail/pop3vscan/files/patch-pop3vscan.h
index 2a528645c2ff..22c75c3ed0fd 100644
--- a/mail/pop3vscan/files/patch-pop3vscan.h
+++ b/mail/pop3vscan/files/patch-pop3vscan.h
@@ -3,15 +3,8 @@
@@ -28,6 +28,7 @@
/* includes {{{1 */
#include <syslog.h> /* do_log */
- #include <arpa/inet.h> /* config */
+#include <netinet/in.h>
+ #include <arpa/inet.h> /* config */
/* definitions {{{1 */
#define PROGNAME "POP3VScan"
-@@ -129,5 +130,5 @@
- extern void do_log(int level, const char *fmt,...);
-
- /* }}} */
--#endif _POP3VSCAN_H
-+#endif
- /* vim:set fdm=marker: */