aboutsummaryrefslogtreecommitdiff
path: root/mail/popcheck
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-26 18:41:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-26 18:41:09 +0000
commit48c3b91e1041bcfe82123d5f4ff2f6fa7b8f999a (patch)
tree728365f717a6e37b6ca5602cfda06b2128b82000 /mail/popcheck
parent38a01f9fb355a7dfdb863df2cc49026bef79c734 (diff)
downloadports-48c3b91e1041bcfe82123d5f4ff2f6fa7b8f999a.tar.gz
ports-48c3b91e1041bcfe82123d5f4ff2f6fa7b8f999a.zip
Notes
Diffstat (limited to 'mail/popcheck')
-rw-r--r--mail/popcheck/Makefile31
-rw-r--r--mail/popcheck/distinfo1
-rw-r--r--mail/popcheck/files/patch-Makefile22
-rw-r--r--mail/popcheck/pkg-descr7
4 files changed, 61 insertions, 0 deletions
diff --git a/mail/popcheck/Makefile b/mail/popcheck/Makefile
new file mode 100644
index 000000000000..5d354fd85c22
--- /dev/null
+++ b/mail/popcheck/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: popcheck
+# Date created: 25 Jan 2004
+# Whom: Radim Kolar
+#
+# $FreeBSD$
+#
+
+PORTNAME= popcheck
+PORTVERSION= 1.3
+CATEGORIES= mail
+MASTER_SITES= http://www.ludd.luth.se/~staham/linux/programs/
+DISTNAME= popcheck
+
+MAINTAINER= hsn@netmag.cz
+COMMENT= Preview and delete messages in POP3 mailbox
+
+ALL_TARGET= popcheck
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= popcheck.1
+.endif
+
+PLIST_FILES= bin/popcheck
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/popcheck ${PREFIX}/bin
+.if !defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${WRKSRC}/popcheck.1 ${MAN1PREFIX}/man/man1
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/popcheck/distinfo b/mail/popcheck/distinfo
new file mode 100644
index 000000000000..fe15cb90ce89
--- /dev/null
+++ b/mail/popcheck/distinfo
@@ -0,0 +1 @@
+MD5 (popcheck.tar.gz) = 22976e558030c88531fd848a8f06c503
diff --git a/mail/popcheck/files/patch-Makefile b/mail/popcheck/files/patch-Makefile
new file mode 100644
index 000000000000..5cd192e03cfe
--- /dev/null
+++ b/mail/popcheck/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig Tue May 8 19:26:58 2001
++++ Makefile Sun Jan 25 22:08:08 2004
+@@ -24,9 +24,9 @@
+ # Edit the options below to suit your needs
+ #
+
+-CC = gcc
++CC?= gcc
+
+-CFLAGS = -O2 -Wall -pipe
++CFLAGS?= -O2 -Wall -pipe
+
+ # Uncomment for Sparc Solaris
+ # LDFLAGS = -lcurses -lresolv -lnsl -lsocket
+@@ -37,6 +37,7 @@
+ INSTPATH = /usr/local
+
+ $(PROG): $(PROG).o
++ $(CC) $(LDFLAGS) -o $(PROG) $(PROG).o
+
+ $(PROG).o: $(PROG).c
+ $(CC) $(CFLAGS) -c $(PROG).c -o $(PROG).o
diff --git a/mail/popcheck/pkg-descr b/mail/popcheck/pkg-descr
new file mode 100644
index 000000000000..75484efb9460
--- /dev/null
+++ b/mail/popcheck/pkg-descr
@@ -0,0 +1,7 @@
+Log onto a popserver to see a list of all messages that you have on there, with
+sender, subject and size for each message. With an ncurses interface that
+easily lets you scroll through them, and optionally deleting messages without
+ever downloading them. This can be useful when you've received big mails that
+you don't really want to download.
+
+WWW: http://www.ludd.luth.se/~staham/linux/programs.html