aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-current
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2007-04-14 16:45:08 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2007-04-14 16:45:08 +0000
commit0c43565a879ef67b8a7c54ec3dec8f0df8f0fd9d (patch)
treefa466d5478813bd88c0c1aa23c6f4030c4464c87 /mail/postfix-current
parent4b78b044c206524e2a3d6ca0a462df4015a94a5e (diff)
downloadports-0c43565a879ef67b8a7c54ec3dec8f0df8f0fd9d.tar.gz
ports-0c43565a879ef67b8a7c54ec3dec8f0df8f0fd9d.zip
Notes
Diffstat (limited to 'mail/postfix-current')
-rw-r--r--mail/postfix-current/Makefile25
1 files changed, 2 insertions, 23 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index 666aa662c3a9..f9948db705b7 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -30,7 +30,6 @@ USE_RC_SUBR= postfix.sh
OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
- SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" off \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" off \
DOVECOT "Dovecot SASL authentication method" off \
SASLKRB "If your SASL req. Kerberos select this option" off \
@@ -91,17 +90,8 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
POSTFIX_CCARGS+= -DNO_PCRE
.endif
-.if defined(WITH_SASL)
-.if defined(WITH_SASL2) || defined(WITH_DOVECOT)
-BROKEN= Select only one SASL authentication method
-.endif
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl1
-POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl -lpam -lcrypt
-.endif
-
.if defined(WITH_SASL2)
-.if defined(WITH_SASL) || defined(WITH_DOVECOT)
+.if defined(WITH_DOVECOT)
BROKEN= Select only one SASL authentication method
.endif
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
@@ -110,7 +100,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
.if defined(WITH_DOVECOT)
-.if defined(WITH_SASL) || defined(WITH_SASL2)
+.if defined(WITH_SASL2)
BROKEN= Select only one SASL authentication method
.endif
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
@@ -204,17 +194,6 @@ READMEDIR=${PREFIX}/share/doc/postfix
SUB_LIST+= REQUIRE="${_REQUIRE}"
pre-patch:
-.if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
- @if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
- ${ECHO_MSG}; \
- ${ECHO_MSG} "Your SASL library it's compiled with MYSQL"; \
- ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
- ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
- ${ECHO_MSG} "# make clean config"; \
- ${ECHO_MSG}; \
- sleep 5; \
- fi
-.endif
.if defined(WITH_SASL2) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl2.a)
@if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | ${GREP} -wq "mysql_init"; then \
${ECHO_MSG}; \