aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-policyd-sf/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-08 17:56:17 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-08 17:56:17 +0000
commit828d733316bf7f1c4ee2b0ac31f56ed5ac89ee8a (patch)
tree363418e14bcc4b63f60ff8e3e1566081c6215abc /mail/postfix-policyd-sf/Makefile
parent1931333c1998c3fdbed1ccb84b7e18463e3c85b8 (diff)
downloadports-828d733316bf7f1c4ee2b0ac31f56ed5ac89ee8a.tar.gz
ports-828d733316bf7f1c4ee2b0ac31f56ed5ac89ee8a.zip
Notes
Diffstat (limited to 'mail/postfix-policyd-sf/Makefile')
-rw-r--r--mail/postfix-policyd-sf/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/mail/postfix-policyd-sf/Makefile b/mail/postfix-policyd-sf/Makefile
index ea3dbe04a678..fedb8ade5d34 100644
--- a/mail/postfix-policyd-sf/Makefile
+++ b/mail/postfix-policyd-sf/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: policyd-sf
+# New ports collection makefile for: postfix-policyd-sf
# Date created: 2005-08-02
# Whom: Xavier Beaudouin <kiwi@oav.net>
#
@@ -6,7 +6,7 @@
#
PORTNAME= policyd
-PORTVERSION= 1.66
+PORTVERSION= 1.67
CATEGORIES= mail
MASTER_SITES= http://policyd.sourceforge.net/
PKGNAMEPREFIX= postfix-
@@ -27,19 +27,27 @@ SUB_LIST+= REALNAME=${REALNAME}
ALL_TARGET= linux
-PORTDOCS= Changelog.txt README.txt License.txt WHITELIST.sql
+DOCS= Changelog.txt README.txt License.txt DATABASE.mysql \
+ doc/WHITELIST.sql doc/SUPPORT.txt
+PORTDOCS= *
PLIST_FILES= sbin/${REALNAME}-cleanup \
+ sbin/${REALNAME}-stats \
sbin/${REALNAME} \
etc/${REALNAME}.conf.sample
+post-patch:
+ @${REINPLACE_CMD} -e 's,policyd.pid,postfix-policyd-sf.pid,' \
+ ${WRKSRC}/policyd.conf
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cleanup ${PREFIX}/sbin/${REALNAME}-cleanup
+ ${INSTALL_PROGRAM} ${WRKSRC}/stats ${PREFIX}/sbin/${REALNAME}-stats
${INSTALL_PROGRAM} ${WRKSRC}/policyd ${PREFIX}/sbin/${REALNAME}
${INSTALL_DATA} ${WRKSRC}/policyd.conf ${PREFIX}/etc/${REALNAME}.conf.sample
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- for f in ${PORTDOCS}; do \
+ for f in ${DOCS}; do \
${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
done
.endif