aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-policyd-spf/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-22 03:43:31 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-22 03:43:31 +0000
commit37215e5368f28cd422d8df19efbc4c727721f890 (patch)
tree9c72d772ff91d4da1d9656e81fa49b8e11add91a /mail/postfix-policyd-spf/Makefile
parentadd996bba32444ec46d60744b7c273f6fd31982d (diff)
downloadports-37215e5368f28cd422d8df19efbc4c727721f890.tar.gz
ports-37215e5368f28cd422d8df19efbc4c727721f890.zip
Notes
Diffstat (limited to 'mail/postfix-policyd-spf/Makefile')
-rw-r--r--mail/postfix-policyd-spf/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/mail/postfix-policyd-spf/Makefile b/mail/postfix-policyd-spf/Makefile
new file mode 100644
index 000000000000..c47b86cb20d4
--- /dev/null
+++ b/mail/postfix-policyd-spf/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: policyd
+# Date created: 19 Dec 2004
+# Whom: Marcus Grando <marcus@corp.grupos.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= policyd
+PORTVERSION= 1.0.1
+CATEGORIES= mail
+MASTER_SITES= http://www.libspf2.org/patch/
+
+MAINTAINER= marcus@corp.grupos.com.br
+COMMENT= Implements SPF for postfix, as a policy daemon
+
+LIB_DEPENDS= spf2.1:${PORTSDIR}/mail/libspf2
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+GNU_CONFIGURE= yes
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>