aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-12-02 11:58:21 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-12-02 11:58:21 +0000
commit8b4093cba5775260e98d51f74cd187fb9af825a8 (patch)
tree4a28bf50f532fa82a149cbc3f9c041d48a23921b /mail/postfix/Makefile
parentf38d6cb92bbd96d100bae02b23ace94acea1cf8e (diff)
downloadports-8b4093cba5775260e98d51f74cd187fb9af825a8.tar.gz
ports-8b4093cba5775260e98d51f74cd187fb9af825a8.zip
Do not use post-stage. Use post-install instead.
The only reason to use post-stage is because the port needs to do "things" at a later time, like some plist manipulation. While there, fold post-install in do-install targets when they are defined. PR: 214780 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=427552
Diffstat (limited to 'mail/postfix/Makefile')
-rw-r--r--mail/postfix/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index c8661c9288c1..2f2c41873def 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -329,11 +329,6 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/auxiliary/qshape/qshape.pl ${STAGEDIR}${PREFIX}/bin/qshape
${INSTALL_MAN} ${WRKSRC}/man/man1/qshape.1 ${STAGEDIR}${MANPREFIX}/man/man1
-do-install-TEST-on:
- ${INSTALL_PROGRAM} ${BINTEST:S|^|${WRKSRC}/bin/|} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${MANTEST:S|^|${WRKSRC}/man/man1/|} ${STAGEDIR}${MANPREFIX}/man/man1
-
-post-stage:
# == do not overwrite existing config
${MV} ${STAGEDIR}${ETCDIR}/main.cf ${STAGEDIR}${ETCDIR}/main.cf.sample
${MV} ${STAGEDIR}${ETCDIR}/master.cf ${STAGEDIR}${ETCDIR}/master.cf.sample
@@ -363,4 +358,8 @@ post-stage:
-@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/*
-@${STRIP_CMD} ${STAGEDIR}${SHLIB_DIRECTORY}/*.so
+do-install-TEST-on:
+ ${INSTALL_PROGRAM} ${BINTEST:S|^|${WRKSRC}/bin/|} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${MANTEST:S|^|${WRKSRC}/man/man1/|} ${STAGEDIR}${MANPREFIX}/man/man1
+
.include <bsd.port.mk>