aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix1/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 15:50:43 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 15:50:43 +0000
commitd9c1c83acd648cf463ac06318fcfb6a208f74347 (patch)
tree60b6d1879dc35ba3148bba10aa9179e924a34cba /mail/postfix1/Makefile
parentb65790585c214ac105bd6fcd817640241bb8557c (diff)
downloadports-d9c1c83acd648cf463ac06318fcfb6a208f74347.tar.gz
ports-d9c1c83acd648cf463ac06318fcfb6a208f74347.zip
Notes
Diffstat (limited to 'mail/postfix1/Makefile')
-rw-r--r--mail/postfix1/Makefile28
1 files changed, 27 insertions, 1 deletions
diff --git a/mail/postfix1/Makefile b/mail/postfix1/Makefile
index 6b47f15e39d2..6adf63b1ee81 100644
--- a/mail/postfix1/Makefile
+++ b/mail/postfix1/Makefile
@@ -12,7 +12,7 @@
# the options are the same names as in the scripts/configure.postfix file
PORTNAME= postfix
-PORTVERSION= 1.1.11
+PORTVERSION= 1.1.12
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -28,6 +28,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= khera@kciLink.com
USE_SUBMAKE= yes
+USE_REINPLACE= yes
MAN1= mailq.1 newaliases.1 postalias.1 postcat.1 postconf.1 postdrop.1 \
postfix.1 postkick.1 postlock.1 postlog.1 postmap.1 postqueue.1 \
@@ -40,6 +41,10 @@ MAN8= bounce.8 cleanup.8 defer.8 error.8 flush.8 lmtp.8 local.8 \
master.8 nqmgr.8 pickup.8 pipe.8 qmgr.8 qmqpd.8 showq.8 smtp.8 \
smtpd.8 spawn.8 trivial-rewrite.8 virtual.8
+# TLS patch adds to MAN8 but doesn't have .html file, so avoid trying to
+# patch it.
+MAN8base=$(MAN8:S/tlsmgr.8//)
+
CONF1= main.cf master.cf access aliases canonical pcre_table regexp_table \
relocated transport virtual
@@ -66,6 +71,27 @@ post-patch:
CCARGS="${POSTFIX_CCARGS}" AUXLIBS="${POSTFIX_AUXLIBS}" && \
${ECHO} "all: default" >> Makefile)
+pre-patch:
+.for file in ${MAN1}
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
+ ${WRKSRC}/man/man1/${file} ${WRKSRC}/html/${file}.html
+.endfor
+.for file in ${MAN5}
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
+ ${WRKSRC}/man/man5/${file} ${WRKSRC}/html/${file}.html
+.endfor
+.for file in ${MAN8base}
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
+ ${WRKSRC}/man/man8/${file} ${WRKSRC}/html/${file}.html
+.endfor
+.for file in faq rate rewrite uce
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
+ ${WRKSRC}/html/${file}.html
+.endfor
+.for file in ${CONF1}
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" ${WRKSRC}/conf/${file}
+.endfor
+
pre-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL