aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix22/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-03-04 07:31:25 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-03-04 07:31:25 +0000
commitad1a88f01167098e905896ab7eef4a30a7c95ab9 (patch)
tree61111fc1f2012c83a4250511fb735708cb4353a1 /mail/postfix22/Makefile
parent4e097dc65e6a90ff7c5b3c94dcfd5dbf36827049 (diff)
downloadports-ad1a88f01167098e905896ab7eef4a30a7c95ab9.tar.gz
ports-ad1a88f01167098e905896ab7eef4a30a7c95ab9.zip
Notes
Diffstat (limited to 'mail/postfix22/Makefile')
-rw-r--r--mail/postfix22/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/mail/postfix22/Makefile b/mail/postfix22/Makefile
index 19822150046a..6e1e8c9a8334 100644
--- a/mail/postfix22/Makefile
+++ b/mail/postfix22/Makefile
@@ -7,11 +7,13 @@
# To pre-select options in batch mode, run make like this:
#
-# make -DBATCH POSTFIX_OPTIONS="DB3 PCRE"
+# make -DBATCH POSTFIX_OPTIONS="DB3 IPv6TLS"
#
# the options are the same names as in the scripts/configure.postfix file.
# POSTFIX_OPTIONS can be set in /etc/make.conf also.
+# NOTE: PCRE is enabled by default unless you specifically disable it.
+
PORTNAME= postfix
PORTVERSION= 2.0.4
PORTEPOCH= 1
@@ -70,6 +72,15 @@ pre-fetch:
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
+.if defined(WITHOUT_PCRE)
+POSTFIX_CCARGS+= -DNO_PCRE
+.else
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+POSTFIX_CCARGS+= -DHAS_PCRE -I${LOCALBASE}/include
+POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
+.endif
+
+
post-patch:
(cd ${WRKSRC} && ${MAKE} -f Makefile.init makefiles ${MAKEFILEFLAGS} \
CCARGS="${POSTFIX_CCARGS}" AUXLIBS="${POSTFIX_AUXLIBS}" && \