aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix26
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2011-07-30 01:34:51 +0000
committerSahil Tandon <sahil@FreeBSD.org>2011-07-30 01:34:51 +0000
commitb9f86503bbe0f49a4cfcc293248e3de02016555b (patch)
tree065389e3ca2fec30e523dc9879117483d7945149 /mail/postfix26
parent74945092b0619281f03b11c41a16ab29de245978 (diff)
downloadports-b9f86503bbe0f49a4cfcc293248e3de02016555b.tar.gz
ports-b9f86503bbe0f49a4cfcc293248e3de02016555b.zip
Notes
Diffstat (limited to 'mail/postfix26')
-rw-r--r--mail/postfix26/Makefile7
-rw-r--r--mail/postfix26/distinfo4
-rw-r--r--mail/postfix26/files/pkg-install.in74
3 files changed, 6 insertions, 79 deletions
diff --git a/mail/postfix26/Makefile b/mail/postfix26/Makefile
index aa4ea3b7a355..bed739d76047 100644
--- a/mail/postfix26/Makefile
+++ b/mail/postfix26/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postfix
-PORTVERSION= 2.6.10
+PORTVERSION= 2.6.11
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -25,6 +25,8 @@ VDAVERSION= 2.6.5
CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-57-9].* postfix-current-2.* \
sendmail-8.* sendmail+*-8.* smail-3.* zmailer-2.*
+USERS= postfix
+GROUPS= mail maildrop postfix
NO_LATEST_LINK= yes
USE_SUBMAKE= yes
USE_PERL5_BUILD=yes
@@ -302,9 +304,6 @@ do-configure:
CCARGS="${POSTFIX_CCARGS}" AUXLIBS="${POSTFIX_AUXLIBS}" && \
${ECHO} "all: default" >> Makefile)
-pre-su-install:
- @${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
do-install:
@cd ${WRKSRC} && ${SH} postfix-install -non-interactive install_root=/ tempdir=/tmp \
config_directory=${ETCDIR} \
diff --git a/mail/postfix26/distinfo b/mail/postfix26/distinfo
index bd60a2148e80..50f99558adf7 100644
--- a/mail/postfix26/distinfo
+++ b/mail/postfix26/distinfo
@@ -1,4 +1,4 @@
-SHA256 (postfix/postfix-2.6.10.tar.gz) = a13d70efe724102e36e7c707257e475d9d6ad73437a255bd6dee08b3c16b569b
-SIZE (postfix/postfix-2.6.10.tar.gz) = 3332241
+SHA256 (postfix/postfix-2.6.11.tar.gz) = 4cda20aba2c5b1b0d8f89127378dee9746ce781c0a250c0eb449aee61a881164
+SIZE (postfix/postfix-2.6.11.tar.gz) = 3333362
SHA256 (postfix/postfix-2.6.5-vda-ng.patch.gz) = e1c04e9d268dc84832334997e1f593af9877dbd5030708280427a0dc4452e797
SIZE (postfix/postfix-2.6.5-vda-ng.patch.gz) = 12435
diff --git a/mail/postfix26/files/pkg-install.in b/mail/postfix26/files/pkg-install.in
index 6b67fe4b5982..29cdef068aad 100644
--- a/mail/postfix26/files/pkg-install.in
+++ b/mail/postfix26/files/pkg-install.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/files/pkg-install.in,v 1.5 2010-11-27 06:48:55 sahil Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/files/pkg-install.in,v 1.6 2011-07-30 01:34:51 sahil Exp $
#
# If the POSTFIX_DEFAULT_MTA environment variable is set to YES, it
@@ -56,64 +56,6 @@ yesno() {
done
}
-if [ "$2" = "PRE-INSTALL" ]; then
- USER=postfix
- UID=125
- GROUP=postfix
- GID=125
- GROUP2=maildrop
- GID2=126
-
- if /usr/sbin/pw groupshow "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if /usr/sbin/pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw groupshow "${GROUP2}" 2>/dev/null; then
- echo "You already have a group \"${GROUP2}\", so I will use it."
- else
- if /usr/sbin/pw groupadd ${GROUP2} -g ${GID2}; then
- echo "Added group \"${GROUP2}\"."
- else
- echo "Adding group \"${GROUP2}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if /usr/sbin/pw useradd ${USER} -u ${UID} -g ${GROUP} -h - -d /var/spool/postfix -s ${NOLOGIN} -c "Postfix Mail System"; then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw show group mail | grep -q "${USER}" 2>/dev/null; then
- echo "You already have user \"${USER}\" in group \"mail\", so I will use it."
- else
- echo "You need user \"${USER}\" added to group \"mail\"."
- if yesno "Would you like me to add it" y; then
- /usr/sbin/pw groupmod mail -m ${USER} || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-fi
-
if [ "$2" = "POST-INSTALL" ]; then
SAMPLES="main.cf master.cf"
for file in $SAMPLES
@@ -130,20 +72,6 @@ if [ "$2" = "POST-INSTALL" ]; then
upgrade-package
fi
-replace() {
- local orig repl
-
- orig=$1
- repl=$2
- if [ -e ${orig} ]; then
- /bin/mv -f ${orig} ${orig}.OFF
- /bin/chmod 0 ${orig}.OFF
- fi
- if [ -e ${repl} ]; then
- /bin/ln -s ${repl} ${orig}
- fi
-}
-
if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" ]; then
egrep -q "^sendmail.*${PREFIX}/sbin/sendmail" ${MC} && \
egrep -q "^send-mail.*${PREFIX}/sbin/sendmail" ${MC} && \