aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix28
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2013-01-28 02:45:24 +0000
committerSahil Tandon <sahil@FreeBSD.org>2013-01-28 02:45:24 +0000
commit9cf3da16705555855c566320ff78f97008135ff2 (patch)
tree23a7a065e2c03104afdb427efb32a29ad6cd7345 /mail/postfix28
parente8c48eb21e78aff916cfa9c7879601d8bd25a509 (diff)
downloadports-9cf3da16705555855c566320ff78f97008135ff2.tar.gz
ports-9cf3da16705555855c566320ff78f97008135ff2.zip
Notes
Diffstat (limited to 'mail/postfix28')
-rw-r--r--mail/postfix28/Makefile8
-rw-r--r--mail/postfix28/distinfo8
-rw-r--r--mail/postfix28/files/patch-src-util-inet_proto.c20
-rw-r--r--mail/postfix28/files/patch-src::util::sys_defs.h8
-rw-r--r--mail/postfix28/files/pkg-install.in16
5 files changed, 42 insertions, 18 deletions
diff --git a/mail/postfix28/Makefile b/mail/postfix28/Makefile
index 7b87eb8e063b..c48ddfbf8c57 100644
--- a/mail/postfix28/Makefile
+++ b/mail/postfix28/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= postfix
-PORTVERSION= 2.8.12
-PORTREVISION= 2
+PORTVERSION= 2.8.13
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -21,7 +20,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= sahil@FreeBSD.org
COMMENT= A secure alternative to widely-used Sendmail
-VDAVERSION= 2.8.9
+VDAVERSION= 2.8.13
CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-79].* postfix-base-2.[0-79].* \
postfix-current-2.* postfix-current-base-2.* sendmail-8.* \
sendmail+*-8.* smail-3.* zmailer-2.* opensmtpd-[0-9]*
@@ -222,6 +221,9 @@ POSTFIX_CCARGS+= -DHAS_LDAP -I${LOCALBASE}/include
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lldap -llber
_REQUIRE+= slapd
.if defined(WITH_LDAP_SASL)
+.if !defined(WITH_SASL2)
+BROKEN= Compile with Cyrus SASL to use LDAP_SASL
+.endif
POSTFIX_CCARGS+= -DUSE_LDAP_SASL
.endif
.endif
diff --git a/mail/postfix28/distinfo b/mail/postfix28/distinfo
index 4dff6481dc23..0ec3eb3af238 100644
--- a/mail/postfix28/distinfo
+++ b/mail/postfix28/distinfo
@@ -1,6 +1,6 @@
-SHA256 (postfix/postfix-2.8.12.tar.gz) = f46b0117cab52e862b12869810327e2bd248a60f209079a875818ee2653de087
-SIZE (postfix/postfix-2.8.12.tar.gz) = 3641269
+SHA256 (postfix/postfix-2.8.13.tar.gz) = 66d278471b790eed663d6fe991403395e6340d45c92c8d0c445f7e9d77881502
+SIZE (postfix/postfix-2.8.13.tar.gz) = 3641782
SHA256 (postfix/postfix-2.8.0-libspf2-1.2.x-0.patch.gz) = e5c38e5bc226cab109c02a4e530ab1aefd3bb06f2169f3e052bdf83d2727aacc
SIZE (postfix/postfix-2.8.0-libspf2-1.2.x-0.patch.gz) = 8191
-SHA256 (postfix/postfix-vda-v10-2.8.9.patch) = e671f7349173349d66f1b091359761ed5a5d517f8a58c86a42ff461997d2cd7e
-SIZE (postfix/postfix-vda-v10-2.8.9.patch) = 56777
+SHA256 (postfix/postfix-vda-v10-2.8.13.patch) = 87166c1f52840d5caf6e24a1f9e07fd7a2f5dfc7b4c340a212e387dace509c42
+SIZE (postfix/postfix-vda-v10-2.8.13.patch) = 56805
diff --git a/mail/postfix28/files/patch-src-util-inet_proto.c b/mail/postfix28/files/patch-src-util-inet_proto.c
new file mode 100644
index 000000000000..b8578a3ab9e7
--- /dev/null
+++ b/mail/postfix28/files/patch-src-util-inet_proto.c
@@ -0,0 +1,20 @@
+--- src/util/inet_proto.c.orig 2013-01-27 19:07:09.000000000 +0000
++++ src/util/inet_proto.c 2013-01-27 19:08:12.000000000 +0000
+@@ -205,7 +205,7 @@
+ pf->dns_atype_list = make_unsigned_vector(2, T_AAAA, 0);
+ pf->sa_family_list = make_uchar_vector(2, AF_INET6, 0);
+ break;
+- } else if (errno == EAFNOSUPPORT) {
++ } else if (errno == EAFNOSUPPORT || errno == EPROTONOSUPPORT) {
+ msg_fatal("%s: IPv6 support is disabled: %m", context);
+ } else {
+ msg_fatal("socket: %m");
+@@ -219,7 +219,7 @@
+ pf->dns_atype_list = make_unsigned_vector(3, T_A, T_AAAA, 0);
+ pf->sa_family_list = make_uchar_vector(3, AF_INET, AF_INET6, 0);
+ break;
+- } else if (errno == EAFNOSUPPORT) {
++ } else if (errno == EAFNOSUPPORT || errno == EPROTONOSUPPORT) {
+ msg_warn("%s: IPv6 support is disabled: %m", context);
+ msg_warn("%s: configuring for IPv4 support only", context);
+ /* FALLTHROUGH */
diff --git a/mail/postfix28/files/patch-src::util::sys_defs.h b/mail/postfix28/files/patch-src::util::sys_defs.h
index a13c320759ff..76df458b53b2 100644
--- a/mail/postfix28/files/patch-src::util::sys_defs.h
+++ b/mail/postfix28/files/patch-src::util::sys_defs.h
@@ -1,11 +1,11 @@
---- src/util/sys_defs.h.orig 2011-03-01 19:35:19.000000000 -0500
-+++ src/util/sys_defs.h 2011-03-01 19:36:54.000000000 -0500
+--- src/util/sys_defs.h.orig 2013-01-27 19:14:53.000000000 +0000
++++ src/util/sys_defs.h 2013-01-27 19:15:20.000000000 +0000
@@ -25,7 +25,7 @@
*/
#if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
|| defined(FREEBSD5) || defined(FREEBSD6) || defined(FREEBSD7) \
-- || defined(FREEBSD8) \
+- || defined(FREEBSD8) || defined(FREEBSD9) \
+ || defined(FREEBSD8) || defined(FREEBSD9) || defined(FREEBSD10) \
|| defined(BSDI2) || defined(BSDI3) || defined(BSDI4) \
|| defined(OPENBSD2) || defined(OPENBSD3) || defined(OPENBSD4) \
- || defined(NETBSD1) || defined(NETBSD2) || defined(NETBSD3) \
+ || defined(OPENBSD5) \
diff --git a/mail/postfix28/files/pkg-install.in b/mail/postfix28/files/pkg-install.in
index 91011cc3301a..1be5afe2e2a4 100644
--- a/mail/postfix28/files/pkg-install.in
+++ b/mail/postfix28/files/pkg-install.in
@@ -56,7 +56,6 @@ yesno() {
done
}
-
if [ "$2" = "POST-INSTALL" ]; then
SAMPLES="main.cf master.cf"
for file in $SAMPLES
@@ -66,13 +65,16 @@ if [ "$2" = "POST-INSTALL" ]; then
fi
done
- /bin/sh ${DAEMONDIR}/post-install tempdir=/tmp \
- daemon_directory=${DAEMONDIR} \
- html_directory=${READMEDIR} \
- readme_directory=${READMEDIR} \
- upgrade-package
-fi
+ cmp ${DAEMONDIR}/main.cf ${ETCDIR}/main.cf >/dev/null 2>&1 \
+ && POSTARG="set-permissions" \
+ || POSTARG="upgrade-package"
+ /bin/sh ${DAEMONDIR}/post-install tempdir=/tmp \
+ daemon_directory=${DAEMONDIR} \
+ html_directory=${READMEDIR} \
+ readme_directory=${READMEDIR} \
+ ${POSTARG}
+fi
if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" -a -f "${MC}" ]; then
egrep -q "^sendmail.*${PREFIX}/sbin/sendmail" ${MC} && \