aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix28
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-18 15:33:08 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-18 15:33:08 +0000
commit9ca785ab6d87b671e3eb7e2168b25cf25cf08264 (patch)
tree30d057b27dfef89496694699938a7b21f65f064b /mail/postfix28
parentdb4b399c7cfa578dcbcf178af2bc9c14116b8dae (diff)
downloadports-9ca785ab6d87b671e3eb7e2168b25cf25cf08264.tar.gz
ports-9ca785ab6d87b671e3eb7e2168b25cf25cf08264.zip
Notes
Diffstat (limited to 'mail/postfix28')
-rw-r--r--mail/postfix28/distinfo2
-rw-r--r--mail/postfix28/pkg-plist1
-rw-r--r--mail/postfix28/scripts/configure.postfix20
3 files changed, 21 insertions, 2 deletions
diff --git a/mail/postfix28/distinfo b/mail/postfix28/distinfo
index 6c6b60b774f8..2ed26576c47d 100644
--- a/mail/postfix28/distinfo
+++ b/mail/postfix28/distinfo
@@ -6,3 +6,5 @@ MD5 (postfix/ipv6-1.25-pf-2.1.3.patch.gz) = cd99ff3ddf9bb88e23a7e33ae42d0772
SIZE (postfix/ipv6-1.25-pf-2.1.3.patch.gz) = 79473
MD5 (postfix/tls+ipv6-1.25-pf-2.1.3.patch.gz) = 71181d8dcf26c24e6fe373ad1ac7e741
SIZE (postfix/tls+ipv6-1.25-pf-2.1.3.patch.gz) = 256591
+MD5 (postfix/postfix-libspf2-2.1.3-4.patch) = 0312a568fdf96861dbd6ac206b395630
+SIZE (postfix/postfix-libspf2-2.1.3-4.patch) = 25713
diff --git a/mail/postfix28/pkg-plist b/mail/postfix28/pkg-plist
index 23f7b45d2de0..37366b49d560 100644
--- a/mail/postfix28/pkg-plist
+++ b/mail/postfix28/pkg-plist
@@ -130,6 +130,7 @@ bin/mailq
%%PORTDOCS%%%%DOCSDIR%%/SMTPD_POLICY_README.html
%%PORTDOCS%%%%DOCSDIR%%/SMTPD_PROXY_README
%%PORTDOCS%%%%DOCSDIR%%/SMTPD_PROXY_README.html
+%%PORTDOCS%%%%SUB_SPF%%%%DOCSDIR%%/SPF_README
%%PORTDOCS%%%%DOCSDIR%%/STANDARD_CONFIGURATION_README
%%PORTDOCS%%%%DOCSDIR%%/STANDARD_CONFIGURATION_README.html
%%PORTDOCS%%%%DOCSDIR%%/TUNING_README
diff --git a/mail/postfix28/scripts/configure.postfix b/mail/postfix28/scripts/configure.postfix
index 05ce9e9a9960..56dff98e9e88 100644
--- a/mail/postfix28/scripts/configure.postfix
+++ b/mail/postfix28/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix28/scripts/Attic/configure.postfix,v 1.51 2004-07-13 16:23:12 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix28/scripts/Attic/configure.postfix,v 1.52 2004-08-18 15:33:08 mat Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -24,6 +24,7 @@ SASL "Cyrus SASLv1 (Simple Authentication and Security Layer)" "$status_SASL" \
SASL2 "Cyrus SASLv2 (Simple Authentication and Security Layer)" "$status_SASL2" \
SASLKRB "If your SASL requires Kerberos select this option" "$status_SASLKRB" \
SASLKRB5 "If your SASL requires Kerberos5 select this option" "$status_SASLKRB5" \
+SPF "SPF support" "$status_SPF" \
TLS "SSL and TLS" "$status_TLS" \
IPv6 "IPv6 support" "$status_IPv6" \
IPv6TLS "IPv6 support with SSL and TLS" "$status_IPv6TLS" \
@@ -65,6 +66,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
SUB_IPV6="@comment "
+SUB_SPF="@comment "
while [ "$1" ]; do
case $1 in
@@ -204,6 +206,19 @@ while [ "$1" ]; do
# echo "MAN1+= smtp-sink.1 smtp-source.1 qmqp-sink.1 qmqp-source.1"
SUB_TEST=""
;;
+ SPF)
+ # see http://www.ipnet6.org/postfix/spf/
+ echo "LIB_DEPENDS+= spf2.1:\${PORTSDIR}/mail/libspf2"
+ echo "PATCH_SITES+= ftp://ftp.stack.nl/pub/postfix/spf/p4/"
+ echo "PATCHFILES+= postfix-libspf2-2.1.3-4.patch"
+ echo "PATCH_DIST_STRIP= -p1"
+ echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lspf2"
+ echo "SPF_SUFFIX= +spf"
+## echo "README+= SPF_README"
+ echo ""
+ SUB_SPF=""
+ ;;
IPv6)
if [ X$SUB_TLS = "X" ]; then
/usr/bin/dialog --msgbox "Select exactly one of the IPv6 and TLS patches" 5 60 > /dev/stderr
@@ -247,9 +262,10 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
+echo "PLIST_SUB+= SUB_SPF=\"${SUB_SPF}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but
# any subsequent build will. so "make; make install" will build twice.
# don't do this for now.
-#echo "PKGNAMESUFFIX= \${NOPCRE_SUFFIX}\${SASL_SUFFIX}\${DB_SUFFIX}\${MYSQL_SUFFIX}\${PGSQL_SUFFIX}\${OPENLDAP_SUFFIX}\${TLS_SUFFIX}\${IPv6_SUFFIX}"
+#echo "PKGNAMESUFFIX= \${NOPCRE_SUFFIX}\${SASL_SUFFIX}\${DB_SUFFIX}\${MYSQL_SUFFIX}\${PGSQL_SUFFIX}\${OPENLDAP_SUFFIX}\${TLS_SUFFIX}\${IPv6_SUFFIX}\${SPF_SUFFIX}"