aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix28
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2011-01-24 23:38:40 +0000
committerSahil Tandon <sahil@FreeBSD.org>2011-01-24 23:38:40 +0000
commit8b9b030efda7b3fd7498816b45eee412ce960cf8 (patch)
tree52736b540fb6e7bcf2cb22df1494c41812a6c15b /mail/postfix28
parentd16d58c82cee013b366e951be39b092e5aaea0af (diff)
Notes
Diffstat (limited to 'mail/postfix28')
-rw-r--r--mail/postfix28/Makefile33
-rw-r--r--mail/postfix28/distinfo8
-rw-r--r--mail/postfix28/files/pkg-message.in4
-rw-r--r--mail/postfix28/pkg-plist11
4 files changed, 38 insertions, 18 deletions
diff --git a/mail/postfix28/Makefile b/mail/postfix28/Makefile
index 85462df57726..fb701b90e19e 100644
--- a/mail/postfix28/Makefile
+++ b/mail/postfix28/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postfix
-PORTVERSION= 2.7.2
+PORTVERSION= 2.8.0
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -21,9 +21,11 @@ MAINTAINER= sahil@FreeBSD.org
COMMENT= A secure alternative to widely-used Sendmail
VDAVERSION= 2.7.0
-CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-68-9].* postfix-current-2.* \
- sendmail-8.* sendmail+*-8.* smail-3.* zmailer-2.*
+CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-79].* postfix-base-2.[0-79].* \
+ postfix-current-2.* postfix-current-base-2.* sendmail-8.* \
+ sendmail+*-8.* smail-3.* zmailer-2.*
+MAKE_JOBS_SAFE= yes
USE_SUBMAKE= yes
USE_PERL5_BUILD=yes
SCRIPTS_ENV+= POSTFIX_DEFAULT_MTA="${POSTFIX_DEFAULT_MTA}"
@@ -49,7 +51,9 @@ OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
BDB "Berkeley DB (choose version with WITH_BDB_VER)" ${STATUS_BDB} \
MYSQL "MySQL maps (choose version with WITH_MYSQL_VER)" ${STATUS_MySQL} \
PGSQL "PostgreSQL maps (choose with DEFAULT_PGSQL_VER)" ${STATUS_PgSQL} \
+ SQLITE "SQLite maps" off \
OPENLDAP "OpenLDAP maps (choose ver. with WITH_OPENLDAP_VER)" ${STATUS_OpenLDAP} \
+ LDAP_SASL "Enable OpenLDAP client-to-server auth via SASL" off \
CDB "CDB maps lookups" ${STATUS_CDB} \
NIS "NIS maps lookups" ${STATUS_NIS} \
VDA "VDA (Virtual Delivery Agent 32Bit)" ${STATUS_VDA} \
@@ -66,11 +70,11 @@ MAN1= postalias.1 postcat.1 postconf.1 postdrop.1 postfix.1 postkick.1 \
MAN5= access.5 aliases.5 bounce.5 canonical.5 cidr_table.5 generic.5 \
header_checks.5 ldap_table.5 master.5 mysql_table.5 nisplus_table.5 \
pcre_table.5 pgsql_table.5 postconf.5 postfix-wrapper.5 regexp_table.5 \
- relocated.5 tcp_table.5 transport.5 virtual.5
+ relocated.5 sqlite_table.5 tcp_table.5 transport.5 virtual.5
-MAN8= anvil.8 bounce.8 cleanup.8 discard.8 error.8 flush.8 local.8 master.8 \
- oqmgr.8 pickup.8 pipe.8 proxymap.8 qmgr.8 qmqpd.8 scache.8 showq.8 \
- smtp.8 smtpd.8 spawn.8 tlsmgr.8 trivial-rewrite.8 verify.8 virtual.8
+MAN8= anvil.8 bounce.8 cleanup.8 discard.8 dnsblog.8 error.8 flush.8 local.8 master.8 \
+ oqmgr.8 pickup.8 pipe.8 postscreen.8 proxymap.8 qmgr.8 qmqpd.8 scache.8 showq.8 \
+ smtp.8 smtpd.8 spawn.8 tlsmgr.8 tlsproxy.8 trivial-rewrite.8 verify.8 virtual.8
MLINKS= sendmail.1 mailq.1 \
sendmail.1 newaliases.1 \
@@ -79,7 +83,7 @@ MLINKS= sendmail.1 mailq.1 \
bounce.8 trace.8 \
smtp.8 lmtp.8
-HTML1= SOHO_README.html body_checks.5.html bounce.5.html postfix-power.png \
+HTML1= body_checks.5.html bounce.5.html postfix-power.png \
scache.8.html tlsmgr.8.html
.if ${OSVERSION} >= 800037
@@ -159,6 +163,7 @@ POSTFIX_AUXLIBS+= -L${OPENSSLLIB} ${LDFLAGS} -lssl -lcrypto
.endif
.if defined(WITH_SPF)
+BROKEN= At the moment, SPF support is unavailable for ${PORTNAME}-${DISTVERSION}
LIB_DEPENDS+= spf2.3:${PORTSDIR}/mail/libspf2
PATCH_SITES+= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= mm
@@ -191,6 +196,12 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -L${LOCALBASE}/pgsql/lib -lpq -lcrypt
_REQUIRE+= postgresql
.endif
+.if defined(WITH_SQLITE)
+USE_SQLITE= yes
+POSTFIX_CCARGS+= -DHAS_SQLITE -I${LOCALBASE}/include
+POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsqlite3
+.endif
+
.if defined(WITH_OPENLDAP)
USE_OPENLDAP= yes
.if defined(WITH_OPENLDAP_VER)
@@ -199,6 +210,9 @@ WANT_OPENLDAP_VER= ${WITH_OPENLDAP_VER}
POSTFIX_CCARGS+= -DHAS_LDAP -I${LOCALBASE}/include
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lldap -llber
_REQUIRE+= slapd
+.if defined(WITH_LDAP_SASL)
+POSTFIX_CCARGS+= -DUSE_LDAP_SASL
+.endif
.endif
.if defined(WITH_CDB)
@@ -214,6 +228,7 @@ _REQUIRE+= ypserv
# 32Bit VDA patch (64Bit has different patch)
.if defined(WITH_VDA)
+BROKEN= At the moment, VDA support is unavailable for ${PORTNAME}-${DISTVERSION}
PATCH_SITES+= http://vda.sourceforge.net/VDA/:vda
PATCHFILES+= postfix-vda-${VDAVERSION}.patch:vda
PATCH_DIST_STRIP= -p1
@@ -310,8 +325,6 @@ pre-patch:
${REINPLACE_CMD} -E -e '${REINPLACE}'
post-patch:
- @${ECHO} '$$readme_directory/SOHO_README:f:root:-:644' \
- >> ${WRKSRC}/conf/postfix-files
.for f in ${HTML1}
@${ECHO} '$$html_directory/$f:f:root:-:644' \
>> ${WRKSRC}/conf/postfix-files
diff --git a/mail/postfix28/distinfo b/mail/postfix28/distinfo
index 86ba04cc28a3..48321d716abc 100644
--- a/mail/postfix28/distinfo
+++ b/mail/postfix28/distinfo
@@ -1,6 +1,2 @@
-SHA256 (postfix/postfix-2.7.2.tar.gz) = 46e2e7a7fcc45da43aff5362632ad5e7cc6a17740fda88bfd9db489b15b20840
-SIZE (postfix/postfix-2.7.2.tar.gz) = 3421671
-SHA256 (postfix/postfix-2.7.1-libspf2-1.2.x-4.patch.gz) = b67efb1ffbcae91f13bf3ed90a5181d4b5bc86ebe15753eaf9db8b2278f5bb16
-SIZE (postfix/postfix-2.7.1-libspf2-1.2.x-4.patch.gz) = 8186
-SHA256 (postfix/postfix-vda-2.7.0.patch) = 6a81aadc21ddd9ffa22fd3a64c924a241b92fc5f2b3bafd352075e830e086e0b
-SIZE (postfix/postfix-vda-2.7.0.patch) = 59667
+SHA256 (postfix/postfix-2.8.0.tar.gz) = 4b6c44601e2ed591b0863ddac43fbe04e30caf9ae0ec65089cb13e9a92aa37ed
+SIZE (postfix/postfix-2.8.0.tar.gz) = 3643132
diff --git a/mail/postfix28/files/pkg-message.in b/mail/postfix28/files/pkg-message.in
index 9b21a7f7a5ec..ff8879440a18 100644
--- a/mail/postfix28/files/pkg-message.in
+++ b/mail/postfix28/files/pkg-message.in
@@ -23,5 +23,5 @@ the sasldb file. This is accomplished by adding postfix to group mail and
making the %%PREFIX%%/etc/sasldb* file(s) readable by group mail (this should
be the default for new installs).
-If you are upgrading from postfix version prior to 2.0, please see the README
-files for recommended changes to your configuration.
+If you are upgrading from Postfix 2.6 or earlier, review the RELEASE_NOTES to
+familiarize yourself with new features and incompatabilities.
diff --git a/mail/postfix28/pkg-plist b/mail/postfix28/pkg-plist
index e47028c3d537..4918bf0c90d2 100644
--- a/mail/postfix28/pkg-plist
+++ b/mail/postfix28/pkg-plist
@@ -4,6 +4,7 @@ libexec/postfix/anvil
libexec/postfix/bounce
libexec/postfix/cleanup
libexec/postfix/discard
+libexec/postfix/dnsblog
libexec/postfix/error
libexec/postfix/flush
libexec/postfix/lmtp
@@ -20,6 +21,7 @@ libexec/postfix/postfix-files
libexec/postfix/postfix-script
libexec/postfix/postfix-wrapper
libexec/postfix/postmulti-script
+libexec/postfix/postscreen
libexec/postfix/proxymap
libexec/postfix/qmgr
libexec/postfix/qmqpd
@@ -28,6 +30,7 @@ libexec/postfix/showq
libexec/postfix/smtp
libexec/postfix/smtpd
libexec/postfix/spawn
+libexec/postfix/tlsproxy
libexec/postfix/trivial-rewrite
libexec/postfix/verify
libexec/postfix/virtual
@@ -115,6 +118,8 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/PCRE_README.html
%%PORTDOCS%%%%DOCSDIR%%/PGSQL_README
%%PORTDOCS%%%%DOCSDIR%%/PGSQL_README.html
+%%PORTDOCS%%%%DOCSDIR%%/POSTSCREEN_README
+%%PORTDOCS%%%%DOCSDIR%%/POSTSCREEN_README.html
%%PORTDOCS%%%%DOCSDIR%%/QSHAPE_README
%%PORTDOCS%%%%DOCSDIR%%/QSHAPE_README.html
%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
@@ -133,6 +138,8 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/SOHO_README
%%PORTDOCS%%%%DOCSDIR%%/SOHO_README.html
%%SPF%%%%PORTDOCS%%%%DOCSDIR%%/SPF_README
+%%PORTDOCS%%%%DOCSDIR%%/SQLITE_README
+%%PORTDOCS%%%%DOCSDIR%%/SQLITE_README.html
%%PORTDOCS%%%%DOCSDIR%%/STANDARD_CONFIGURATION_README
%%PORTDOCS%%%%DOCSDIR%%/STANDARD_CONFIGURATION_README.html
%%PORTDOCS%%%%DOCSDIR%%/STRESS_README
@@ -164,6 +171,7 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/cleanup.8.html
%%PORTDOCS%%%%DOCSDIR%%/defer.8.html
%%PORTDOCS%%%%DOCSDIR%%/discard.8.html
+%%PORTDOCS%%%%DOCSDIR%%/dnsblog.8.html
%%PORTDOCS%%%%DOCSDIR%%/error.8.html
%%PORTDOCS%%%%DOCSDIR%%/flush.8.html
%%PORTDOCS%%%%DOCSDIR%%/header_checks.5.html
@@ -198,6 +206,7 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/postmap.1.html
%%PORTDOCS%%%%DOCSDIR%%/postmulti.1.html
%%PORTDOCS%%%%DOCSDIR%%/postqueue.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postscreen.8.html
%%PORTDOCS%%%%DOCSDIR%%/postsuper.1.html
%%PORTDOCS%%%%DOCSDIR%%/proxymap.8.html
%%PORTDOCS%%%%DOCSDIR%%/qmgr.8.html
@@ -215,7 +224,9 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/smtp.8.html
%%PORTDOCS%%%%DOCSDIR%%/smtpd.8.html
%%PORTDOCS%%%%DOCSDIR%%/spawn.8.html
+%%PORTDOCS%%%%DOCSDIR%%/sqlite_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/tcp_table.5.html
+%%PORTDOCS%%%%DOCSDIR%%/tlsproxy.8.html
%%PORTDOCS%%%%DOCSDIR%%/trace.8.html
%%PORTDOCS%%%%DOCSDIR%%/transport.5.html
%%PORTDOCS%%%%DOCSDIR%%/trivial-rewrite.8.html