aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-11-27 06:48:50 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-11-27 06:48:50 +0000
commit4dcd4152c78ed259ac9d7ae31917035a789352aa (patch)
tree978f0c7e9ccae97b028e5d687495fafaa784b118 /mail/postfix
parent2953dc577e5cb994ca19bfb5d90fd5caf4d3493e (diff)
downloadports-4dcd4152c78ed259ac9d7ae31917035a789352aa.tar.gz
ports-4dcd4152c78ed259ac9d7ae31917035a789352aa.zip
Notes
Diffstat (limited to 'mail/postfix')
-rw-r--r--mail/postfix/Makefile2
-rw-r--r--mail/postfix/distinfo7
-rw-r--r--mail/postfix/files/pkg-install.in32
3 files changed, 24 insertions, 17 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 3d619266f2ec..d69c0d84c0f3 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postfix
-PORTVERSION= 2.7.1
+PORTVERSION= 2.7.2
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
diff --git a/mail/postfix/distinfo b/mail/postfix/distinfo
index 05f762ae0b40..86ba04cc28a3 100644
--- a/mail/postfix/distinfo
+++ b/mail/postfix/distinfo
@@ -1,9 +1,6 @@
-MD5 (postfix/postfix-2.7.1.tar.gz) = b7a5c3ccd309156a65d6f8d2683d4fa1
-SHA256 (postfix/postfix-2.7.1.tar.gz) = 12301aa8dae18d333c8c96dbf7673f8f05139f10406e7afe278cfd4a1f132df0
-SIZE (postfix/postfix-2.7.1.tar.gz) = 3418747
-MD5 (postfix/postfix-2.7.1-libspf2-1.2.x-4.patch.gz) = 195c2477860f77567a458e84720e767a
+SHA256 (postfix/postfix-2.7.2.tar.gz) = 46e2e7a7fcc45da43aff5362632ad5e7cc6a17740fda88bfd9db489b15b20840
+SIZE (postfix/postfix-2.7.2.tar.gz) = 3421671
SHA256 (postfix/postfix-2.7.1-libspf2-1.2.x-4.patch.gz) = b67efb1ffbcae91f13bf3ed90a5181d4b5bc86ebe15753eaf9db8b2278f5bb16
SIZE (postfix/postfix-2.7.1-libspf2-1.2.x-4.patch.gz) = 8186
-MD5 (postfix/postfix-vda-2.7.0.patch) = f73d119fc9e00f31f23599176554e763
SHA256 (postfix/postfix-vda-2.7.0.patch) = 6a81aadc21ddd9ffa22fd3a64c924a241b92fc5f2b3bafd352075e830e086e0b
SIZE (postfix/postfix-vda-2.7.0.patch) = 59667
diff --git a/mail/postfix/files/pkg-install.in b/mail/postfix/files/pkg-install.in
index f69931e37b4e..5aabca2e4dbf 100644
--- a/mail/postfix/files/pkg-install.in
+++ b/mail/postfix/files/pkg-install.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix/files/pkg-install.in,v 1.3 2009-06-11 01:42:24 wxs Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix/files/pkg-install.in,v 1.4 2010-11-27 06:48:50 sahil Exp $
#
# If the POSTFIX_DEFAULT_MTA environment variable is set to YES, it
@@ -13,6 +13,7 @@ DAEMONDIR=${DAEMONDIR:=%%DAEMONDIR%%}
READMEDIR=${READMEDIR:=%%READMEDIR%%}
BATCH=${BATCH:=no}
POSTFIX_DEFAULT_MTA=${POSTFIX_DEFAULT_MTA:=no}
+MC=/etc/mail/mailer.conf
if [ "${POSTFIX_DEFAULT_MTA}" = "no" ]; then
DEFAULT_REPLACE_MAILERCONF=n
@@ -144,15 +145,24 @@ replace() {
}
if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ egrep -q "^sendmail.*${PREFIX}/sbin/sendmail" ${MC} && \
+ egrep -q "^send-mail.*${PREFIX}/sbin/sendmail" ${MC} && \
+ egrep -q "^mailq.*${PREFIX}/sbin/sendmail" ${MC} && \
+ egrep -q "^newaliases.*${PREFIX}/sbin/sendmail" ${MC}
+ ret=$?
+ if [ ${ret} -ne 0 ]; then
+ if yesno "Would you like to activate Postfix in ${MC}" ${DEFAULT_REPLACE_MAILERCONF}; then
+ /bin/mv -f ${MC} ${MC}.old
+ echo "#" > ${MC}
+ echo -n "# Execute the Postfix sendmail program" >> ${MC}
+ echo ", named ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "#" >> ${MC}
+ echo "sendmail ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "send-mail ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "mailq ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "newaliases ${PREFIX}/sbin/sendmail" >> ${MC}
+ fi
+ else
+ echo "Postfix already activated in ${MC}"
fi
fi