aboutsummaryrefslogtreecommitdiff
path: root/mail/postfixadmin
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-01-09 04:05:37 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-01-09 04:05:37 +0000
commit41b6f01a205f9e811471da47f842207530de47d7 (patch)
tree329979f69f1edb3f79a6af7f0b665779cd477654 /mail/postfixadmin
parentbda255a881515a4c76287d3563c9436908631a01 (diff)
downloadports-41b6f01a205f9e811471da47f842207530de47d7.tar.gz
ports-41b6f01a205f9e811471da47f842207530de47d7.zip
Notes
Diffstat (limited to 'mail/postfixadmin')
-rw-r--r--mail/postfixadmin/Makefile16
-rw-r--r--mail/postfixadmin/pkg-descr10
-rw-r--r--mail/postfixadmin/pkg-message25
-rw-r--r--mail/postfixadmin/pkg-plist2
4 files changed, 50 insertions, 3 deletions
diff --git a/mail/postfixadmin/Makefile b/mail/postfixadmin/Makefile
index 5f5e7c4a1f82..a919f9a4e2c8 100644
--- a/mail/postfixadmin/Makefile
+++ b/mail/postfixadmin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfixadmin
PORTVERSION= 2.0.2
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://high5.net/postfixadmin/download.php/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -21,6 +22,9 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/apache2/libphp4.so:${PORTSDIR}/www/mod_php4
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
.endif
+WWW_USER?= www
+WWW_GROUP?= www
+
NO_BUILD= yes
FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
@@ -48,5 +52,17 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/languages/* ${PREFIX}/www/postfixadmin/languages
@${INSTALL_DATA} ${WRKSRC}/templates/* ${PREFIX}/www/postfixadmin/templates
@${INSTALL_DATA} ${WRKSRC}/users/* ${PREFIX}/www/postfixadmin/users
+ @[ -f ${PREFIX}/www/postfixadmin/config.inc.php ] || \
+ ${CP} ${PREFIX}/www/postfixadmin/config.inc.php.sample \
+ ${PREFIX}/www/postfixadmin/config.inc.php
+
+
+post-install:
+ @${CHOWN} -R ${WWW_USER}:${WWW_GROUP} ${PREFIX}/www/postfixadmin
+ @${CHMOD} 640 ${PREFIX}/www/postfixadmin/*.php ${PREFIX}/www/postfixadmin/*.css
+ @${CHMOD} 640 ${PREFIX}/www/postfixadmin/admin/*.php
+ @${CHMOD} 640 ${PREFIX}/www/postfixadmin/users/*.php
+ @${CHMOD} 640 ${PREFIX}/www/postfixadmin/templates/*.tpl
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/mail/postfixadmin/pkg-descr b/mail/postfixadmin/pkg-descr
index afad4d3c168d..a0d9da2d94df 100644
--- a/mail/postfixadmin/pkg-descr
+++ b/mail/postfixadmin/pkg-descr
@@ -1,11 +1,15 @@
Postfix Admin is a Web Based Management tool for Postfix when you
are dealing with Postfix Style Virtual Domains and Virtual Users
-that are stored in MySQL. Written in PHP.
+that are stored in MySQL. It's written in PHP.
Postfix Admin supports:
- - Virtual Mailboxes.
- - Virtual Aliases / Forwarders / Catch-All.
+ - Virtual Mailboxes / Virtual Aliases / Forwarders.
+ - Domain to Domain forwarding / Catch-All.
- Vacation for Virtual Mailboxes (with the additional module).
Requirements:
- Postfix 2.0 or higher.
+ - Apache 1.3.27 or higher.
- PHP 4.1 or higher.
+ - MySQL 3.23.55 or higher.
+
+WWW: http://www.high5.net/postfixadmin
diff --git a/mail/postfixadmin/pkg-message b/mail/postfixadmin/pkg-message
new file mode 100644
index 000000000000..c8125c616fc8
--- /dev/null
+++ b/mail/postfixadmin/pkg-message
@@ -0,0 +1,25 @@
+To Install and use postfixadmin:
+
+1. Create the MySQL Tables
+--------------------------
+In ${PREFIX}/www/postfixadmin/DATABASE.TXT you can find the table
+structure that you need in order to configure Postfix Admin and Postfix
+in general to work with Virtual Domains and Users
+
+2. Configure
+------------
+Check the ${PREFIX}/www/postfixadmin/config.inc.php file. There you
+can specify settings that are relevant to your setup.
+
+The default password for the admin part of Postfix Admin is admin/admin.
+This is specified in the .htpasswd file in the admin directory. Make sure
+that the location of the .htpasswd file matches your path.
+
+3. Configure Apache
+-------------------
+Add a line in your httpd.conf to allow the use of .htaccess file.
+
+<Directory "/usr/local/www/postfixadmin">
+ Options Indexes
+ AllowOverride AuthConfig
+</Directory>
diff --git a/mail/postfixadmin/pkg-plist b/mail/postfixadmin/pkg-plist
index ac9bb41cb134..9b0d6bcef378 100644
--- a/mail/postfixadmin/pkg-plist
+++ b/mail/postfixadmin/pkg-plist
@@ -25,7 +25,9 @@ www/postfixadmin/admin/list-admin.php
www/postfixadmin/admin/list-domain.php
www/postfixadmin/admin/list-virtual.php
www/postfixadmin/admin/viewlog.php
+@unexec if cmp -s %D/www/postfixadmin/config.inc.php %D/www/postfixadmin/config.inc.php.sample; then rm -f %D/www/postfixadmin/config.inc.php; fi
www/postfixadmin/config.inc.php.sample
+@exec [ -f %B/config.inc.php ] || cp %B/%f %B/config.inc.php
www/postfixadmin/create-alias.php
www/postfixadmin/create-mailbox.php
www/postfixadmin/delete.php