aboutsummaryrefslogtreecommitdiff
path: root/mail/postgrey
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2006-01-06 01:56:16 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2006-01-06 01:56:16 +0000
commita075c67d38d65a9c25ba78656ac5aa081cd31e7d (patch)
treef39848f2b6f34e890fb1aed67955fd89ac1b81c1 /mail/postgrey
parent6aa241a33447c5a31e4e0502734901e93ca44ef6 (diff)
downloadports-a075c67d38d65a9c25ba78656ac5aa081cd31e7d.tar.gz
ports-a075c67d38d65a9c25ba78656ac5aa081cd31e7d.zip
Notes
Diffstat (limited to 'mail/postgrey')
-rw-r--r--mail/postgrey/Makefile27
-rw-r--r--mail/postgrey/pkg-plist1
-rw-r--r--mail/postgrey/pkg-req15
3 files changed, 8 insertions, 35 deletions
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index ceea6cebcc86..d3e1f2980257 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postgrey
PORTVERSION= 1.23
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://isg.ee.ethz.ch/tools/postgrey/pub/
@@ -17,7 +18,7 @@ RUN_DEPENDS= ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
${SITE_PERL}/IO/Multiplex.pm:${PORTSDIR}/devel/p5-IO-Multiplex \
${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
-USE_PERL5= yes
+USE_PERL5_RUN= yes
USE_RC_SUBR= yes
USE_REINPLACE= yes
NO_BUILD= yes
@@ -32,25 +33,13 @@ PGY_DIR?= /var/db/postgrey
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-pre-extract:
-.if !defined(SKIP_BDB_CHECK) && !defined(PACKAGE_BUILDING)
-.if !defined(WITH_BDB_VER)
- @${ECHO} "This port requires databases/p5-BerkeleyDB to be built with"
- @${ECHO} "WITH_BDB_VER=41 or later."
- exit 1
-.else
-.if ${WITH_BDB_VER} < 41
- @${ECHO} "This port requires databases/p5-BerkeleyDB to be built with"
- @${ECHO} "WITH_BDB_VER=41 or later."
- exit 1
-.endif
-.endif
-.endif
-
.include <bsd.port.pre.mk>
+# Sys::Syslog::openlog won't return 1 for success in perl 5.00503, and causes
+# "Couldn't open syslog[] at ... Net/Server.pm line ..." problem.
+# See the thread of http://lists.ee.ethz.ch/postgrey/msg00001.html
.if ${PERL_LEVEL} < 500600
-IGNORE= Needs perl 5.6.1 or higher, install lang/perl5.8 and try again
+IGNORE= needs perl 5.6.0 or higher, install lang/perl5.8 and try again
.endif
post-patch:
@@ -64,13 +53,11 @@ pre-install:
-e 's#%%PREFIX%%#${PREFIX}#g' -e 's#%%ETCFILES%%#${ETCFILES}#g' \
-e 's#%%POSTGREYDIR%%#${PGY_DIR}#g' ${MASTERDIR}/pkg-install > \
${PKGINSTALL}
-.if !defined(SKIP_BDB_CHECK) && !defined(PACKAGE_BUILDING)
- ${SH} ${PKGREQ} INSTALL
-.endif
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/postgrey ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/postgreyreport ${PREFIX}/sbin
${INSTALL_SCRIPT} ${WRKDIR}/postgrey.sh ${PREFIX}/etc/rc.d
${MKDIR} ${PREFIX}/etc/postfix
.for i in ${ETCFILES}
diff --git a/mail/postgrey/pkg-plist b/mail/postgrey/pkg-plist
index 15c9e60ae1bc..05da48294884 100644
--- a/mail/postgrey/pkg-plist
+++ b/mail/postgrey/pkg-plist
@@ -1,6 +1,7 @@
@unexec if cmp -s %D/etc/postfix/dist-postgrey_whitelist_recipients %D/etc/postfix/postgrey_whitelist_recipients; then rm -f %D/etc/postfix/postgrey_whitelist_recipients; fi
@unexec if cmp -s %D/etc/postfix/dist-postgrey_whitelist_clients %D/etc/postfix/postgrey_whitelist_clients; then rm -f %D/etc/postfix/postgrey_whitelist_clients; fi
sbin/postgrey
+sbin/postgreyreport
etc/rc.d/postgrey.sh
etc/postfix/dist-postgrey_whitelist_recipients
etc/postfix/dist-postgrey_whitelist_clients
diff --git a/mail/postgrey/pkg-req b/mail/postgrey/pkg-req
deleted file mode 100644
index 085629b82510..000000000000
--- a/mail/postgrey/pkg-req
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-PATH=$PATH:/usr/local/bin
-
-if [ "x$1" = "xINSTALL" -o "x$2" = "xINSTALL" ]; then
- perl -e "use BerkeleyDB;BerkeleyDB::Env->new(-Home => 'test',-Flags => DB_CREATE|DB_RECOVER|DB_INIT_TXN|DB_INIT_MPOOL|DB_INIT_LOG,-SetFlags => DB_AUTO_COMMIT|DB_TXN_NOSYNC);"
- if [ $? != 0 ]; then
- echo "-----------------------------------------------------------"
- echo "Postgrey requires databases/p5-BerkeleyDB to be built with"
- echo "Berkeley DB 4.1 or newer. Please reinstall it with the"
- echo "WITH_BDB_VER set to 41 or newer."
- echo "-----------------------------------------------------------"
- exit 1
- fi
-fi