aboutsummaryrefslogtreecommitdiff
path: root/mail/postgrey
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-10-19 17:51:15 +0000
committerChris Rees <crees@FreeBSD.org>2011-10-19 17:51:15 +0000
commitfe74e5f3f7ec51255e5e440bfd1ac953cd92fe00 (patch)
tree40af642889b8db072d9759449d7b042d8a9354ae /mail/postgrey
parent1e8cfd939efbf1ea9863fe4387af182364e11efe (diff)
downloadports-fe74e5f3f7ec51255e5e440bfd1ac953cd92fe00.tar.gz
ports-fe74e5f3f7ec51255e5e440bfd1ac953cd92fe00.zip
Notes
Diffstat (limited to 'mail/postgrey')
-rw-r--r--mail/postgrey/Makefile7
-rw-r--r--mail/postgrey/files/pkg-install.in19
2 files changed, 5 insertions, 21 deletions
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index f6a7cf8c1714..ad2488c804be 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -35,6 +35,9 @@ PGY_USERID?= 225
PGY_GROUPNAME?= ${PGY_USERNAME}
PGY_GROUPID?= ${PGY_USERID}
PGY_DIR?= /var/db/postgrey
+
+USERS= ${PGY_USERNAME}
+GROUPS= ${PGY_GROUPNAME}
MAN1= ${PORTNAME}.1 policy-test.1 postgreyreport.1
post-patch:
@@ -42,10 +45,8 @@ post-patch:
@${REINPLACE_CMD} -e 's#/etc/postfix#${PREFIX}&#' ${WRKSRC}/postgrey ${WRKSRC}/postgrey_whitelist_*
@${REINPLACE_CMD} -e 's#/var/spool/postfix/postgrey#${PGY_DIR}#' ${WRKSRC}/postgrey ${WRKSRC}/contrib/postgreyreport
-pre-su-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
do-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${POD2MAN} ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
@${POD2MAN} ${WRKSRC}/policy-test ${WRKSRC}/policy-test.1
@${POD2MAN} ${WRKSRC}/contrib/postgreyreport ${WRKSRC}/postgreyreport.1
diff --git a/mail/postgrey/files/pkg-install.in b/mail/postgrey/files/pkg-install.in
index f13c20d305a1..fd0d1ea409e7 100644
--- a/mail/postgrey/files/pkg-install.in
+++ b/mail/postgrey/files/pkg-install.in
@@ -1,6 +1,6 @@
#! /bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/mail/postgrey/files/pkg-install.in,v 1.1 2007-06-27 21:13:24 beech Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postgrey/files/pkg-install.in,v 1.2 2011-10-19 17:51:15 crees Exp $
PATH=/bin:/usr/bin:/usr/sbin
@@ -16,23 +16,6 @@ PRE-INSTALL)
exit 1
fi
- # Create group if required
- if pw group show "%%GROUP%%" >/dev/null 2>&1; then
- echo "---> Using existing group \"%%GROUP%%\""
- else
- echo "---> Adding group \"%%GROUP%%\" (%%GID%%)"
- /usr/sbin/pw groupadd %%GROUP%% -g %%GID%% || exit 1
- fi
-
- # Create user if required
- if pw user show "%%USER%%" >/dev/null 2>&1; then
- echo "---> Using existing user \"%%USER%%\""
- else
- echo "---> Adding user \"%%USER%%\" (%%UID%%)"
- pw useradd "%%USER%%" -u "%%UID%%" -g "%%GROUP%%" -h - \
- -d "%%POSTGREYDIR%%" -s "/sbin/nologin" -c "Postgrey Owner" || exit 1
- fi
-
# Create home directory if required
if [ -d "%%POSTGREYDIR%%" ]; then
echo "---> Using existing Postgrey database directory (%%POSTGREYDIR%%)"