aboutsummaryrefslogtreecommitdiff
path: root/mail/postgrey
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2005-01-27 00:03:28 +0000
committerWill Andrews <will@FreeBSD.org>2005-01-27 00:03:28 +0000
commit4d432f55788c61366221c906c0698ad481b06dda (patch)
tree1f915fd984408c08a901e5f94e2089e93284067c /mail/postgrey
parent10e45b9ad0b301588b0779d7f7e42600a309f407 (diff)
downloadports-4d432f55788c61366221c906c0698ad481b06dda.tar.gz
ports-4d432f55788c61366221c906c0698ad481b06dda.zip
Notes
Diffstat (limited to 'mail/postgrey')
-rw-r--r--mail/postgrey/Makefile10
-rw-r--r--mail/postgrey/distinfo4
-rw-r--r--mail/postgrey/files/postgrey.sh3
3 files changed, 11 insertions, 6 deletions
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index 107b5cd0b09b..b2ae5492f432 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postgrey
-PORTVERSION= 1.16
+PORTVERSION= 1.17
CATEGORIES= mail
MASTER_SITES= http://isg.ee.ethz.ch/tools/postgrey/pub/
@@ -46,6 +46,12 @@ pre-extract:
.endif
.endif
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Needs perl 5.6.1 or higher, install lang/perl5.8 and try again
+.endif
+
pre-install:
${SED} -e 's#%%PREFIX%%#${PREFIX}#g' -e 's#%%RC_SUBR%%#${RC_SUBR}#g' \
${FILESDIR}/postgrey.sh > ${WRKDIR}/postgrey.sh
@@ -70,4 +76,4 @@ do-install:
post-install:
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/postgrey/distinfo b/mail/postgrey/distinfo
index f2750869e099..9db1a9a85816 100644
--- a/mail/postgrey/distinfo
+++ b/mail/postgrey/distinfo
@@ -1,2 +1,2 @@
-MD5 (postgrey-1.16.tar.gz) = f9f0636ee3df680423b0ad7ace1edeec
-SIZE (postgrey-1.16.tar.gz) = 23579
+MD5 (postgrey-1.17.tar.gz) = 5b15bbbfdc3ed22b7c7b366f2a099883
+SIZE (postgrey-1.17.tar.gz) = 24693
diff --git a/mail/postgrey/files/postgrey.sh b/mail/postgrey/files/postgrey.sh
index 34e485594da0..9908e9e2d991 100644
--- a/mail/postgrey/files/postgrey.sh
+++ b/mail/postgrey/files/postgrey.sh
@@ -21,7 +21,6 @@ name=postgrey
rcvar=`set_rcvar`
command=%%PREFIX%%/sbin/postgrey
-command_interpreter=/usr/bin/perl
required_dirs=/var/db/postgrey
extra_commands=reload
@@ -37,7 +36,7 @@ stop_postcmd()
postgrey_enable=${postgrey_enable:-"NO"}
postgrey_pidfile=${postgrey_pidfile:-"/var/run/postgrey.pid"}
postgrey_flags=${postgrey_flags:-"--pidfile=${postgrey_pidfile} \
- --inet=10023 -d --user=postgrey --dbdir=/var/db/postgrey \
+ --inet=10023 -d --user=postgrey --group=postgrey --dbdir=/var/db/postgrey \
--whitelist-clients=%%PREFIX%%/etc/postfix/postgrey_whitelist_clients \
--whitelist-clients=%%PREFIX%%/etc/postfix/postgrey_whitelist_clients.local \
--whitelist-recipients=%%PREFIX%%/etc/postfix/postgrey_whitelist_recipients"}