aboutsummaryrefslogtreecommitdiff
path: root/mail/postilion/files
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-04-17 04:52:04 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-04-17 04:52:04 +0000
commit9faebf2bb2026b3a29ca87f3a7fb5b61255db0ec (patch)
tree383279028a51e70e8736b10c06877ffe6243e362 /mail/postilion/files
parent567722cfa6cc94f7eab55623b1b27abdb433c29d (diff)
Notes
Diffstat (limited to 'mail/postilion/files')
-rw-r--r--mail/postilion/files/patch-aa24
-rw-r--r--mail/postilion/files/patch-ab21
-rw-r--r--mail/postilion/files/patch-ac20
-rw-r--r--mail/postilion/files/patch-ad11
-rw-r--r--mail/postilion/files/patch-ae20
-rw-r--r--mail/postilion/files/patch-af20
6 files changed, 116 insertions, 0 deletions
diff --git a/mail/postilion/files/patch-aa b/mail/postilion/files/patch-aa
new file mode 100644
index 000000000000..6378a70f4fa8
--- /dev/null
+++ b/mail/postilion/files/patch-aa
@@ -0,0 +1,24 @@
+--- configure.orig Sat Nov 28 18:36:04 1998
++++ configure Sun Feb 21 10:24:44 1999
+@@ -2074,7 +2074,7 @@
+ for i in $tcl_dirs ; do
+ tcl_include_dirs="$tcl_include_dirs $i/include"
+ done
+-tcl_include_dirs="$tcl_include_dirs /usr/include/tcl /usr/include"
++tcl_include_dirs="$tcl_include_dirs /usr/local/include/tcl8.0 /usr/local/include/tk8.0 /usr/include"
+ tcl_dir=0
+ for i in $tcl_include_dirs ; do
+ if test -r $i/tcl.h ; then
+@@ -2586,8 +2586,11 @@
+ MP-RAS-*)
+ OSTYPE=Unkown
+ ;;
+- NetBSD-*|FreeBSD-*)
++ NetBSD-*)
+ OSTYPE=neb
++ ;;
++ FreeBSD-*)
++ OSTYPE=bsf
+ ;;
+ NEXTSTEP-*)
+ OSTYPE=nxt
diff --git a/mail/postilion/files/patch-ab b/mail/postilion/files/patch-ab
new file mode 100644
index 000000000000..f0d874a70c0d
--- /dev/null
+++ b/mail/postilion/files/patch-ab
@@ -0,0 +1,21 @@
+--- imap-4.5.BETA/src/osdep/unix/os_bsi.h.orig Sat Oct 19 12:30:04 1996
++++ imap-4.5.BETA/src/osdep/unix/os_bsi.h Sun Feb 21 10:25:47 1999
+@@ -37,7 +37,18 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <sys/types.h>
++
++/*
++ * FreeBSD v3.x and onward whines about <sys/dir.h> being obsolete, so switch
++ * to POSIX semantics.
++ */
++#if __FreeBSD__ >= 3
++#include <dirent.h>
++#define direct dirent
++#else
+ #include <sys/dir.h>
++#endif
++
+ #include <fcntl.h>
+ #include <syslog.h>
+ #include <sys/file.h>
diff --git a/mail/postilion/files/patch-ac b/mail/postilion/files/patch-ac
new file mode 100644
index 000000000000..13aa63f827d0
--- /dev/null
+++ b/mail/postilion/files/patch-ac
@@ -0,0 +1,20 @@
+--- imap-4.5.BETA/src/osdep/unix/Makefile.orig Sun Feb 21 10:27:22 1999
++++ imap-4.5.BETA/src/osdep/unix/Makefile Sun Feb 21 10:29:24 1999
+@@ -100,7 +100,7 @@
+ dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
+ rfc822.o nntp.o smtp.o imap4r1.o pop3.o \
+ unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o
+-CFLAGS=$(BASECFLAGS) $(EXTRACFLAGS)
++CFLAGS+=$(BASECFLAGS) $(EXTRACFLAGS)
+ MAKE=make
+ MV=mv
+ RM=rm -rf
+@@ -190,7 +190,7 @@
+ SPOOLDIR=/var \
+ ACTIVEFILE=/usr/local/news/lib/active \
+ RSHPATH=/usr/bin/rsh \
+- BASECFLAGS="-g -O -pipe -DNFSKLUDGE" \
++ BASECFLAGS="-DNFSKLUDGE -DIGNORE_LOCK_EACCES_ERRORS" \
+ BASELDFLAGS="-lcrypt"
+
+ bsi: # BSD/i386
diff --git a/mail/postilion/files/patch-ad b/mail/postilion/files/patch-ad
new file mode 100644
index 000000000000..141bd67f41af
--- /dev/null
+++ b/mail/postilion/files/patch-ad
@@ -0,0 +1,11 @@
+--- lib/Makefile.in.orig Sun Feb 21 10:57:36 1999
++++ lib/Makefile.in Sun Feb 21 10:58:09 1999
+@@ -101,7 +101,7 @@
+ if test ! -d ${LIB_DIR} ; then\
+ ${INSTALL} -d ${LIB_DIR} ;\
+ fi
+- ${INSTALL} postilion.exec ${LIB_DIR}/postilion.exec
++ ${INSTALL} ${STRIP} postilion.exec ${LIB_DIR}/postilion.exec
+
+ ratAddress.o: ratAddress.c rat.h ../config.h
+ ratAppInit.o: ratAppInit.c ratFolder.h rat.h ../config.h ratPGP.h
diff --git a/mail/postilion/files/patch-ae b/mail/postilion/files/patch-ae
new file mode 100644
index 000000000000..97c6411da5a1
--- /dev/null
+++ b/mail/postilion/files/patch-ae
@@ -0,0 +1,20 @@
+--- imap-4.5.BETA/Makefile.orig Sun Feb 21 11:03:57 1999
++++ imap-4.5.BETA/Makefile Sun Feb 21 11:04:29 1999
+@@ -198,7 +198,7 @@
+
+ # Make the IMAP Toolkit
+
+-all: c-client rebuild bundled
++all: c-client rebuild
+
+
+ # The following ports are defined. These refer to the *standard* compiler
+@@ -384,7 +384,7 @@
+ $(TOOLS)/$@ "$(LN)" src/imapd imapd
+ $(LN) $(TOOLS)/$@ .
+
+-build: OSTYPE rebuild rebuildclean bundled
++build: OSTYPE rebuild rebuildclean
+
+ OSTYPE:
+ @echo Building c-client for $(OS)...
diff --git a/mail/postilion/files/patch-af b/mail/postilion/files/patch-af
new file mode 100644
index 000000000000..1944b9650ba1
--- /dev/null
+++ b/mail/postilion/files/patch-af
@@ -0,0 +1,20 @@
+--- postilion/options.tcl.orig Mon Feb 8 21:02:35 1999
++++ postilion/options.tcl Mon Feb 22 02:05:03 1999
+@@ -211,7 +211,7 @@
+ set option(icon_name) "Postilion v$postilion_version"
+
+ # Command to get default folder
+- set option(default_folder) "INBOX file {} /var/spool/mail/$env(USER)"
++ set option(default_folder) "INBOX file {} /var/mail/$env(USER)"
+
+ # Format of list of messages
+ set option(list_format) "%4S %6d %-24n %4B %s"
+@@ -253,7 +253,7 @@
+ set option(sendprot) smtp
+
+ # Default sending program
+- set option(sendprog) /usr/lib/sendmail
++ set option(sendprog) /usr/sbin/sendmail
+
+ # Can the sending program handle eightbit data
+ set option(sendprog_8bit) false