aboutsummaryrefslogtreecommitdiff
path: root/mail/procmail/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2001-09-29 09:00:32 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2001-09-29 09:00:32 +0000
commit41b16dcb8b7eb984cb5bd63dd8e886454562e5b0 (patch)
treef093618da5442fa89801f4099a18b3e92ba3ff06 /mail/procmail/Makefile
parentbc582f8d870747d5b4ced8e6ec189b076b9cc8bc (diff)
downloadports-41b16dcb8b7eb984cb5bd63dd8e886454562e5b0.tar.gz
ports-41b16dcb8b7eb984cb5bd63dd8e886454562e5b0.zip
Notes
Diffstat (limited to 'mail/procmail/Makefile')
-rw-r--r--mail/procmail/Makefile69
1 files changed, 61 insertions, 8 deletions
diff --git a/mail/procmail/Makefile b/mail/procmail/Makefile
index d3b74cf93532..821fe0b4cc49 100644
--- a/mail/procmail/Makefile
+++ b/mail/procmail/Makefile
@@ -6,26 +6,79 @@
#
PORTNAME= procmail
-PORTVERSION= 3.21
+PORTVERSION= 3.22
CATEGORIES= mail
MASTER_SITES= ftp://ftp.procmail.org/pub/procmail/ \
- ftp://ftp.informatik.rwth-aachen.de/pub/packages/procmail/
+ ftp://ftp.psg.com/pub/unix/procmail/ \
+ ftp://ftp.ucsb.edu/pub/mirrors/procmail/ \
+ ftp://ftp.informatik.rwth-aachen.de/pub/packages/procmail/ \
+ ftp://ftp.fu-berlin.de/pub/unix/mail/procmail/ \
+ ftp://ftp.net.ohio-state.edu/pub/networking/mail/procmail/ \
+ ftp://ftp.fdt.net/pub/unix/packages/procmail/ \
+ ftp://ftp.tamu.edu/pub/mirrors/procmail/ \
+ ftp://ftp.kfki.hu/pub/packages/mail/procmail/ \
+ ftp://giswitch.sggw.waw.pl/pub/unix/procmail/ \
+ ftp://ftp.solarisguide.com/pub/procmail/ \
+ ftp://ftp.win.ne.jp/pub/network/mail/procmail/ \
+ http://www.ring.gr.jp/archives/net/mail/procmail/ \
+ ftp://ftp.ring.gr.jp/pub/net/mail/procmail/ \
+ ftp://ftp.ayamura.org/pub/procmail/ \
+ ftp://sunsite.cnlab-switch.ch/mirror/procmail/ \
+ ftp://ftp.gigabell.net/pub/procmail/ \
+ ftp://ftp.linja.net/pub/mirrors/procmail/ \
+ ftp://ftp.stealth.net/pub/mirrors/ftp.procmail.org/pub/procmail/ \
+ ftp://ftp.mirror.ac.uk/sites/ftp.procmail.org/pub/procmail/
MAINTAINER= ache@FreeBSD.org
-INSTALL_TARGET= install-suid install.man
+# Global variables
+#
# It asks for list of directories to do test for file locking
# (defaults to /tmp and ".", so return should suffice in most cases).
-.if !defined(PACKAGE_BUILDING) # handled in patch-aa
+.if !defined(BATCH) # handled in patch-aa
IS_INTERACTIVE= yes
.endif
+
+INSTALL_TARGET= install-suid install.man
+
MAN1= procmail.1 formail.1 lockfile.1
MAN5= procmailex.5 procmailrc.5 procmailsc.5
-.include <bsd.port.pre.mk>
+# Local variables
+#
+
+DOC_FILES= FAQ FEATURES HISTORY KNOWN_BUGS README
-post-configure:
- @${PERL} -pi -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/config.h
+SAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+SAMPLE_FILES= 1procmailrc 1rmail 2procmailrc 2rmail 3procmailrc 3rmail \
+ advanced dirname forward local_procmail_lmtp.m4 mailstat
+
+# Post-configure
+#
+
+post-configure: patch-config
+
+patch-config:
+ @${PERL} -pi.fbsd -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/config.h
+
+# Post-install
+#
+
+post-install: install-sample install-doc
+
+install-sample:
+ @${MKDIR} ${SAMPLESDIR}
+.for file in ${SAMPLE_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/examples/${file} ${SAMPLESDIR}
+.endfor
+
+install-doc:
+.if !defined(NOPORTSDOC)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>