aboutsummaryrefslogtreecommitdiff
path: root/mail/procmail
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-29 18:51:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-29 18:51:20 +0000
commit745407be1b85c0601b06ae5389ca3f04c4bf23cc (patch)
treef07a33a599595158bf83b082bdf09258f4185dd8 /mail/procmail
parent703ff6d36176652e995eaf56e44c8637531c23a3 (diff)
downloadports-745407be1b85c0601b06ae5389ca3f04c4bf23cc.tar.gz
ports-745407be1b85c0601b06ae5389ca3f04c4bf23cc.zip
Notes
Diffstat (limited to 'mail/procmail')
-rw-r--r--mail/procmail/Makefile4
-rw-r--r--mail/procmail/files/patch-config.h4
-rw-r--r--mail/procmail/files/patch-src-autoconf12
3 files changed, 16 insertions, 4 deletions
diff --git a/mail/procmail/Makefile b/mail/procmail/Makefile
index cee9c152b415..6eaf051c3f17 100644
--- a/mail/procmail/Makefile
+++ b/mail/procmail/Makefile
@@ -3,7 +3,7 @@
PORTNAME= procmail
PORTVERSION= 3.22
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= mail
MASTER_SITES= ftp://ftp.ucsb.edu/pub/mirrors/procmail/ \
ftp://ftp.informatik.rwth-aachen.de/pub/packages/procmail/ \
@@ -30,7 +30,7 @@ PORTEXAMPLES= 1procmailrc 1rmail 2procmailrc 2rmail 3procmailrc 3rmail \
advanced dirname forward local_procmail_lmtp.m4 mailstat
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/config.h
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/config.h ${WRKSRC}/src/autoconf
# Allow parallel builds (-jX) to work
@${FIND} ${WRKSRC} -name 'Makefile*' | ${XARGS} ${REINPLACE_CMD} -E 's|cd (.+); (\$$\(MAKE\))|\2 -C \1|'
diff --git a/mail/procmail/files/patch-config.h b/mail/procmail/files/patch-config.h
index b5bc1b48f429..7c54253b1c1b 100644
--- a/mail/procmail/files/patch-config.h
+++ b/mail/procmail/files/patch-config.h
@@ -26,12 +26,12 @@
system mailbox. This also must be an absolute path */
-#define ETCRC "/etc/procmailrc" /* optional global procmailrc startup
-+#define ETCRC "%%PREFIX%%/etc/procmailrc" /* optional global procmailrc startup
++#define ETCRC "/usr/local/etc/procmailrc" /* optional global procmailrc startup
file (will only be read if procmail
is started with no rcfile on the command line). */
-#define ETCRCS "/etc/procmailrcs/" /* optional trusted path prefix for
-+#define ETCRCS "%%PREFIX%%/etc/procmailrcs/" /* optional trusted path prefix for
++#define ETCRCS "/usr/local/etc/procmailrcs/" /* optional trusted path prefix for
rcfiles which will be executed with
the uid of the owner of the rcfile (this only happens if procmail is
called with the -m option, without variable assignments on the command
diff --git a/mail/procmail/files/patch-src-autoconf b/mail/procmail/files/patch-src-autoconf
index ef615cb599ba..41ab653bd40b 100644
--- a/mail/procmail/files/patch-src-autoconf
+++ b/mail/procmail/files/patch-src-autoconf
@@ -18,3 +18,15 @@
if $MAKE _autotst >$DEVNULL 2>&1
test -f _autotst
then
+@@ -1491,6 +1493,11 @@
+ fi
+ done
+
++case ":$lpath:" in
++ *:/usr/local/bin:*) ;;
++ *) lpath="$lpath:/usr/local/bin" ;;
++esac
++
+ echo "#define defPATH \"PATH=\$HOME/bin:$lpath\"" >>$ACONF
+ echo "#define defSPATH \"PATH=$lpath\"" >>$ACONF
+