aboutsummaryrefslogtreecommitdiff
path: root/mail/prom-wl
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-11-19 17:26:15 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-11-19 17:26:15 +0000
commite1dc5b5364e555601e62de1fd9bbb591ea95c378 (patch)
treebfc9ec3869103889687df39647b22b140173e066 /mail/prom-wl
parent40df0d5e26510bacb5b95a6cf70b013f695802b0 (diff)
downloadports-e1dc5b5364e555601e62de1fd9bbb591ea95c378.tar.gz
ports-e1dc5b5364e555601e62de1fd9bbb591ea95c378.zip
Notes
Diffstat (limited to 'mail/prom-wl')
-rw-r--r--mail/prom-wl/Makefile26
-rw-r--r--mail/prom-wl/pkg-descr7
-rw-r--r--mail/prom-wl/pkg-plist12
3 files changed, 24 insertions, 21 deletions
diff --git a/mail/prom-wl/Makefile b/mail/prom-wl/Makefile
index 0f48ef5a89c4..03499d3202ff 100644
--- a/mail/prom-wl/Makefile
+++ b/mail/prom-wl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= prom-wl
PORTVERSION= 2.7.0
+PORTREVISION= 1
CATEGORIES= mail elisp
MASTER_SITES= http://www.h6.dion.ne.jp/~nytheta/software/pub/
@@ -23,14 +24,23 @@ ELISPDIR= ${PREFIX}/share/emacs/site-lisp
SITEPKGDIR= ${PREFIX}/lib/xemacs/site-packages
do-install:
- @${MKDIR} ${ELISPDIR} ${PREFIX}/share/doc/prom-wl \
- ${PREFIX}/share/examples/prom-wl
- @cd ${WRKSRC}; \
- ${INSTALL_DATA} prom-wl.el ${ELISPDIR}; \
- ${INSTALL_DATA} ChangeLog prom-wl-usage.jis ${PREFIX}/share/doc/prom-wl
- @cd ${FILESDIR}; \
- ${INSTALL_SCRIPT} byte-compile ${PREFIX}/share/doc/prom-wl; \
- ${INSTALL_DATA} dot.emacs dot.procmailrc ${PREFIX}/share/examples/prom-wl
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}; ${INSTALL_DATA} ChangeLog \
+ prom-wl-usage.jis \
+ ${DOCSDIR}/)
+ @(cd ${FILESDIR}; ${INSTALL_SCRIPT} byte-compile ${DOCSDIR}/)
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${FILESDIR} ; ${INSTALL_DATA} dot.emacs dot.procmailrc \
+ ${EXAMPLESDIR}/)
+.endif
+
+ @${MKDIR} ${ELISPDIR}
+ @(cd ${WRKSRC}; ${INSTALL_DATA} prom-wl.el ${ELISPDIR}/)
+
# For xemacs package install configuration
@${MKDIR} ${SITEPKGDIR}/lisp/prom-wl ${SITEPKGDIR}/pkginfo
@${LN} -sf ${ELISPDIR}/prom-wl.el ${SITEPKGDIR}/lisp/prom-wl/prom-wl.el
diff --git a/mail/prom-wl/pkg-descr b/mail/prom-wl/pkg-descr
index d96842645030..7d6f1e724805 100644
--- a/mail/prom-wl/pkg-descr
+++ b/mail/prom-wl/pkg-descr
@@ -1,26 +1,19 @@
Prom-Wl is a procmail reader for Wanderlust on GNU Emacs.
-
If you want to install quickly, you shoud do following steps:
(1) add dot.emacs to your ~/.emacs file and change it suitable for your site
-
% cat /usr/local/share/examples/prom-wl/dot.emacs >> ~/.emacs
% vi ~/.emacs
-
(2) copy dot.procmailrc to ~/.procmailrc and change it suitable for your site
-
% cp /usr/local/share/examples/prom-wl/dot.promailrc ~/.promailrc
% vi ~/.promailrc
-
(3) byte-compile with "byte-comile" script if you want with xemacs-mule code
-
# cd /usr/local/share/emacs/site-lisp
# /usr/local/share/doc/prom-wl/byte-compile -l wl xemacs-mule prom-wl
Where detail specification for .emacs and .procmailrc may be shown in
/usr/local/share/doc/prom-wl/prom-usage.jis or procmail(1). And for
usage of byte_compile scripts, run byte-compile with -h option.
-
Run with "M-x prom-wl" in your emacs editors, Wanderlust will be invoked and
then search unread mails from procmail log to show unread message from top of
entries that you specfied in ~/.pronmailrc.
diff --git a/mail/prom-wl/pkg-plist b/mail/prom-wl/pkg-plist
index 61652a837bca..82f06f60ac48 100644
--- a/mail/prom-wl/pkg-plist
+++ b/mail/prom-wl/pkg-plist
@@ -1,15 +1,15 @@
share/emacs/site-lisp/prom-wl.el
lib/xemacs/site-packages/lisp/prom-wl/prom-wl.el
lib/xemacs/site-packages/pkginfo/MANIFEST.prom-wl
-%%DOCSDIR%%/ChangeLog
-%%DOCSDIR%%/prom-wl-usage.jis
-%%DOCSDIR%%/byte-compile
-%%EXAMPLESDIR%%/dot.emacs
-%%EXAMPLESDIR%%/dot.procmailrc
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/prom-wl-usage.jis
+%%PORTDOCS%%%%DOCSDIR%%/byte-compile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dot.emacs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dot.procmailrc
@dirrm lib/xemacs/site-packages/lisp/prom-wl
@dirrmtry lib/xemacs/site-packages/lisp
@dirrmtry lib/xemacs/site-packages/pkginfo
@dirrmtry lib/xemacs/site-packages
@dirrmtry lib/xemacs
-@dirrm share/examples/prom-wl
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%