aboutsummaryrefslogtreecommitdiff
path: root/mail/py-turbomail/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-02-17 14:15:41 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-02-17 14:15:41 +0000
commit7d3fe10b5a0ddf4791eee6dd607e1dd0768cd921 (patch)
tree77909bf723b7f6c90814e91d50a33d06f6a9bc9d /mail/py-turbomail/Makefile
parente6eda7191ab269200e59f69d1c6bc064f4677604 (diff)
downloadports-7d3fe10b5a0ddf4791eee6dd607e1dd0768cd921.tar.gz
ports-7d3fe10b5a0ddf4791eee6dd607e1dd0768cd921.zip
Notes
Diffstat (limited to 'mail/py-turbomail/Makefile')
-rw-r--r--mail/py-turbomail/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/mail/py-turbomail/Makefile b/mail/py-turbomail/Makefile
new file mode 100644
index 000000000000..7e106f716f0c
--- /dev/null
+++ b/mail/py-turbomail/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: py-turbomail
+# Date created: 2007-01-24
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= turbomail
+PORTVERSION= 2.0.3
+CATEGORIES= mail www
+MASTER_SITES= http://cheeseshop.python.org/packages/source/T/TurboMail/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= TurboMail-${PORTVERSION}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Multi-threaded mail queue manager for TurboGears applications
+
+BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools \
+ tg-admin:${PORTSDIR}/www/py-turbogears
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PLIST_FILES= ${PYTHON_SITELIBDIR:S|${PREFIX}/||}/${PYTURBOMAIL_EGG}
+
+SUB_FILES= pkg-deinstall pkg-install
+SUB_LIST= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR} \
+ EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
+ EGG_VER="${PORTNAME}==${PORTVERSION}"
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
+PYTURBOMAIL_EGG= TurboMail-${PORTVERSION}-py${PYTHON_VER}.egg
+
+.include <bsd.port.mk>