aboutsummaryrefslogtreecommitdiff
path: root/mail/pymsgauth/Makefile
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2002-10-07 15:10:24 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2002-10-07 15:10:24 +0000
commitc74175c3c8062d3d17c466aeafe1b97600b903be (patch)
tree8297050f2e6667a6ae918a643c065e7c727d8252 /mail/pymsgauth/Makefile
parent5e5122ed1f1af5c42e518d5d939ad8ebc30cb2a6 (diff)
downloadports-c74175c3c8062d3d17c466aeafe1b97600b903be.tar.gz
ports-c74175c3c8062d3d17c466aeafe1b97600b903be.zip
Notes
Diffstat (limited to 'mail/pymsgauth/Makefile')
-rw-r--r--mail/pymsgauth/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/mail/pymsgauth/Makefile b/mail/pymsgauth/Makefile
new file mode 100644
index 000000000000..2dfc54983fb7
--- /dev/null
+++ b/mail/pymsgauth/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: pymsgauth
+# Date created: 12 Aug 2002
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pymsgauth
+PORTVERSION= 2.0.0
+CATEGORIES= mail python
+MASTER_SITES= http://www.qcc.ca/~charlesc/software/pymsgauth/
+
+MAINTAINER= sergei@kolobov.com
+
+USE_PYTHON= yes
+USE_REINPLACE= yes
+
+NO_BUILD= yes
+
+DOCS= BUGS CHANGELOG COPYING pymsgauth.txt pymsgauth.html
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
+ ${WRKSRC}/pymsgauth-*
+ ${RM} ${WRKSRC}/pymsgauth-*.bak
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pymsgauth-* ${PYTHON_SITELIBDIR}
+ ${LN} -sf ${PYTHON_SITELIBDIR}/pymsgauth-* ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/*.py ${PYTHON_SITELIBDIR}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/pymsgauthrc-example ${EXAMPLESDIR}
+
+ ${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's,__EXAMPLES__,${EXAMPLESDIR},'
+.include <bsd.port.mk>