aboutsummaryrefslogtreecommitdiff
path: root/mail/pymsgauth
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2005-02-18 13:53:11 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2005-02-18 13:53:11 +0000
commitfb7c154f954227e6d2c2b28eaba93ee152d19e2a (patch)
tree069c2dbd882c3c6160c5f89d4ff3b84ded212319 /mail/pymsgauth
parent413ef4bf433834d9f9af8f1c8c0a25ab9298a45f (diff)
downloadports-fb7c154f954227e6d2c2b28eaba93ee152d19e2a.tar.gz
ports-fb7c154f954227e6d2c2b28eaba93ee152d19e2a.zip
Notes
Diffstat (limited to 'mail/pymsgauth')
-rw-r--r--mail/pymsgauth/Makefile27
-rw-r--r--mail/pymsgauth/distinfo4
-rw-r--r--mail/pymsgauth/files/pkg-message.in (renamed from mail/pymsgauth/pkg-message)2
-rw-r--r--mail/pymsgauth/pkg-descr9
-rw-r--r--mail/pymsgauth/pkg-plist26
5 files changed, 34 insertions, 34 deletions
diff --git a/mail/pymsgauth/Makefile b/mail/pymsgauth/Makefile
index 23c79419f77b..7811e5d5d837 100644
--- a/mail/pymsgauth/Makefile
+++ b/mail/pymsgauth/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= pymsgauth
-PORTVERSION= 2.0.0
+PORTVERSION= 2.1.0
CATEGORIES= mail python
-MASTER_SITES= http://www.qcc.ca/~charlesc/software/pymsgauth/
+MASTER_SITES= http://pyropus.ca/software/pymsgauth/
MAINTAINER= sergei@FreeBSD.org
COMMENT= Automatically process qsecretary confirmation requests
@@ -16,27 +16,26 @@ COMMENT= Automatically process qsecretary confirmation requests
USE_PYTHON= yes
USE_REINPLACE= yes
-NO_BUILD= yes
+SUB_FILES= pkg-message
DOCS= BUGS CHANGELOG pymsgauth.txt pymsgauth.html
+EXAMPLES= pymsgauthrc-example
-post-patch:
- ${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
+do-build:
+ ${REINPLACE_CMD} -e 's,#!/usr/bin/python,#!/usr/bin/env python,' \
${WRKSRC}/pymsgauth-*
${RM} ${WRKSRC}/pymsgauth-*.bak
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/pymsgauth-* ${PYTHON_SITELIBDIR}
- ${LN} -sf ${PYTHON_SITELIBDIR}/pymsgauth-* ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/*.py ${PYTHON_SITELIBDIR}
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${WRKSRC}/pymsgauth-* ${DATADIR}
+ ${LN} -sf ${DATADIR}/pymsgauth-* ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/pymsgauthrc-example ${EXAMPLESDIR}
- @${SED} -e 's,__EXAMPLES__,${EXAMPLESDIR},' ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/mail/pymsgauth/distinfo b/mail/pymsgauth/distinfo
index 45c9b693497b..11fd6874774b 100644
--- a/mail/pymsgauth/distinfo
+++ b/mail/pymsgauth/distinfo
@@ -1,2 +1,2 @@
-MD5 (pymsgauth-2.0.0.tar.gz) = d4fb57bba78c4a902548c8be030f354d
-SIZE (pymsgauth-2.0.0.tar.gz) = 17588
+MD5 (pymsgauth-2.1.0.tar.gz) = b6994bf805250f5a11af94f18c186cb8
+SIZE (pymsgauth-2.1.0.tar.gz) = 17915
diff --git a/mail/pymsgauth/pkg-message b/mail/pymsgauth/files/pkg-message.in
index bff388880b15..150e9fd90f13 100644
--- a/mail/pymsgauth/pkg-message
+++ b/mail/pymsgauth/files/pkg-message.in
@@ -1,6 +1,6 @@
**********************************************************************
After the installation:
- create ~/.pymsgauth directory;
-- copy __EXAMPLES__/pymsgauthrc-example to
+- copy %%EXAMPLESDIR%%/pymsgauthrc-example to
~/.pymsgauth/pymsgauthrc and edit the config file to fit your needs.
**********************************************************************
diff --git a/mail/pymsgauth/pkg-descr b/mail/pymsgauth/pkg-descr
index dc596411087e..c3be925c640d 100644
--- a/mail/pymsgauth/pkg-descr
+++ b/mail/pymsgauth/pkg-descr
@@ -1,7 +1,6 @@
pymsgauth is a toolkit for automatically and securely dealing with qsecretary
-confirmation notices.
+confirmation notices (used on mailing lists run by D.J. Bernstein).
+It is written in Python, and licensed under GPL.
-pymsgauth is written in Python, and licensed under the GNU General Public
-License version 2.
-
-WWW: http://www.qcc.ca/~charlesc/software/pymsgauth/pymsgauth.html
+Author: Charles Cazabon
+WWW: http://pyropus.ca/software/pymsgauth/
diff --git a/mail/pymsgauth/pkg-plist b/mail/pymsgauth/pkg-plist
index 47c5e8e3bed0..97919c168150 100644
--- a/mail/pymsgauth/pkg-plist
+++ b/mail/pymsgauth/pkg-plist
@@ -1,15 +1,17 @@
+@comment $FreeBSD$
bin/pymsgauth-clean
bin/pymsgauth-confirm
bin/pymsgauth-mail
-%%PYTHON_SITELIBDIR%%/ConfParser.py
-%%PYTHON_SITELIBDIR%%/pymsgauth.py
-%%PYTHON_SITELIBDIR%%/pymsgauth-clean
-%%PYTHON_SITELIBDIR%%/pymsgauth-confirm
-%%PYTHON_SITELIBDIR%%/pymsgauth-mail
-%%PORTDOCS%%share/doc/pymsgauth/BUGS
-%%PORTDOCS%%share/doc/pymsgauth/CHANGELOG
-%%PORTDOCS%%share/doc/pymsgauth/pymsgauth.html
-%%PORTDOCS%%share/doc/pymsgauth/pymsgauth.txt
-%%PORTDOCS%%@dirrm share/doc/pymsgauth
-share/examples/pymsgauth/pymsgauthrc-example
-@dirrm share/examples/pymsgauth
+%%DATADIR%%/ConfParser.py
+%%DATADIR%%/pymsgauth.py
+%%DATADIR%%/pymsgauth-clean
+%%DATADIR%%/pymsgauth-confirm
+%%DATADIR%%/pymsgauth-mail
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/pymsgauth.html
+%%PORTDOCS%%%%DOCSDIR%%/pymsgauth.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLESDIR%%/pymsgauthrc-example
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DATADIR%%