aboutsummaryrefslogtreecommitdiff
path: root/mail/qconfirm
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2003-04-02 04:35:20 +0000
committerKevin Lo <kevlo@FreeBSD.org>2003-04-02 04:35:20 +0000
commit6ae90c2baaf7dec03cc64b2dafa9b6ddddc07058 (patch)
treeb0ae6ddd461760031b6a4e14051cbf2d91cf8969 /mail/qconfirm
parent42ca9a21abeb6545f3a5bc79251dfcb92e2ac6f7 (diff)
downloadports-6ae90c2baaf7dec03cc64b2dafa9b6ddddc07058.tar.gz
ports-6ae90c2baaf7dec03cc64b2dafa9b6ddddc07058.zip
Notes
Diffstat (limited to 'mail/qconfirm')
-rw-r--r--mail/qconfirm/Makefile24
-rw-r--r--mail/qconfirm/distinfo2
-rw-r--r--mail/qconfirm/pkg-plist44
3 files changed, 41 insertions, 29 deletions
diff --git a/mail/qconfirm/Makefile b/mail/qconfirm/Makefile
index 2693aec39af5..73e11ec97fb0 100644
--- a/mail/qconfirm/Makefile
+++ b/mail/qconfirm/Makefile
@@ -6,28 +6,34 @@
#
PORTNAME= qconfirm
-PORTVERSION= 0.8.1
+PORTVERSION= 0.9.2
CATEGORIES= mail
MASTER_SITES= http://smarden.org/qconfirm/
MAINTAINER= sergei@kolobov.com
-COMMENT= Request delivery confirmation for mail message under qmail
+COMMENT= Filter spam by requesting confirmation from sender
-WRKSRC= ${WRKDIR}/mail/${DISTNAME}/src
+WRKSRC= ${WRKDIR}/mail/${DISTNAME}
ALL_TARGET= default
-MAN1= qconfirm.1 qconfirm-accept.1 qconfirm-check.1 qconfirm-conf.1 \
+MAN1= qconfirm.1 qconfirm-accept.1 qconfirm-check.1 \
+ qconfirm-check-mid.1 qconfirm-conf.1 \
qconfirm-cdb-check.1 qconfirm-cdb-update.1 \
qconfirm-control.1 qconfirm-return.1
+DOCS= package/CHANGES package/COPYING package/README doc/*.html
+do-configure:
+ ${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/src/conf-cc
+
+do-build:
+ cd ${WRKSRC} && package/compile
+
do-install:
-.for file in ${MAN1}
- ${INSTALL_PROGRAM} ${WRKSRC}/${file:S/.1//} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/../man/${file} ${PREFIX}/man/man1
-.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/command/* ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/*.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/../doc/*.html ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/mail/qconfirm/distinfo b/mail/qconfirm/distinfo
index 164207a649ab..3c9b26711d03 100644
--- a/mail/qconfirm/distinfo
+++ b/mail/qconfirm/distinfo
@@ -1 +1 @@
-MD5 (qconfirm-0.8.1.tar.gz) = 0b08efaa5d1d870a61a23c703af4f2cb
+MD5 (qconfirm-0.9.2.tar.gz) = ab068b19e89dc55a9e420b8cb8c897fd
diff --git a/mail/qconfirm/pkg-plist b/mail/qconfirm/pkg-plist
index fa9f89e2b6da..66b999c88fbb 100644
--- a/mail/qconfirm/pkg-plist
+++ b/mail/qconfirm/pkg-plist
@@ -3,25 +3,31 @@ bin/qconfirm-accept
bin/qconfirm-cdb-check
bin/qconfirm-cdb-update
bin/qconfirm-check
+bin/qconfirm-check-mid
bin/qconfirm-conf
bin/qconfirm-control
bin/qconfirm-return
-%%PORTDOCS%%share/doc/qconfirm/benefits.html
-%%PORTDOCS%%share/doc/qconfirm/bounces.html
-%%PORTDOCS%%share/doc/qconfirm/cdb.html
-%%PORTDOCS%%share/doc/qconfirm/configuration.html
-%%PORTDOCS%%share/doc/qconfirm/control.html
-%%PORTDOCS%%share/doc/qconfirm/faq.html
-%%PORTDOCS%%share/doc/qconfirm/index.html
-%%PORTDOCS%%share/doc/qconfirm/install.html
-%%PORTDOCS%%share/doc/qconfirm/qconfirm.1.html
-%%PORTDOCS%%share/doc/qconfirm/qconfirm-accept.1.html
-%%PORTDOCS%%share/doc/qconfirm/qconfirm-cdb-check.1.html
-%%PORTDOCS%%share/doc/qconfirm/qconfirm-cdb-update.1.html
-%%PORTDOCS%%share/doc/qconfirm/qconfirm-check.1.html
-%%PORTDOCS%%share/doc/qconfirm/qconfirm-conf.1.html
-%%PORTDOCS%%share/doc/qconfirm/qconfirm-control.1.html
-%%PORTDOCS%%share/doc/qconfirm/qconfirm-return.1.html
-%%PORTDOCS%%share/doc/qconfirm/technical.html
-%%PORTDOCS%%share/doc/qconfirm/upgrade.html
-%%PORTDOCS%%@dirrm share/doc/qconfirm
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/benefits.html
+%%PORTDOCS%%%%DOCSDIR%%/bounces.html
+%%PORTDOCS%%%%DOCSDIR%%/cdb.html
+%%PORTDOCS%%%%DOCSDIR%%/configuration.html
+%%PORTDOCS%%%%DOCSDIR%%/control.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%%%DOCSDIR%%/qconfirm.1.html
+%%PORTDOCS%%%%DOCSDIR%%/qconfirm-accept.1.html
+%%PORTDOCS%%%%DOCSDIR%%/qconfirm-cdb-check.1.html
+%%PORTDOCS%%%%DOCSDIR%%/qconfirm-cdb-update.1.html
+%%PORTDOCS%%%%DOCSDIR%%/qconfirm-check.1.html
+%%PORTDOCS%%%%DOCSDIR%%/qconfirm-check-mid.1.html
+%%PORTDOCS%%%%DOCSDIR%%/qconfirm-conf.1.html
+%%PORTDOCS%%%%DOCSDIR%%/qconfirm-control.1.html
+%%PORTDOCS%%%%DOCSDIR%%/qconfirm-return.1.html
+%%PORTDOCS%%%%DOCSDIR%%/technical.html
+%%PORTDOCS%%%%DOCSDIR%%/upgrade.html
+%%PORTDOCS%%%%DOCSDIR%%/usedietlibc.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%