aboutsummaryrefslogtreecommitdiff
path: root/mail/qmail-autoresponder
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2005-08-29 12:17:22 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2005-08-29 12:17:22 +0000
commitd431aff1d4f0649a52d5a7ab2ed450dd3aaa70c7 (patch)
treef88d1c0a3dd8115a8ee050d213b6f2a377c96bd0 /mail/qmail-autoresponder
parentd33ff3a9c0317e90300a509bb88d2d8933c95e7b (diff)
downloadports-d431aff1d4f0649a52d5a7ab2ed450dd3aaa70c7.tar.gz
ports-d431aff1d4f0649a52d5a7ab2ed450dd3aaa70c7.zip
Notes
Diffstat (limited to 'mail/qmail-autoresponder')
-rw-r--r--mail/qmail-autoresponder/Makefile13
-rw-r--r--mail/qmail-autoresponder/distinfo6
-rw-r--r--mail/qmail-autoresponder/files/patch-main.c31
3 files changed, 12 insertions, 38 deletions
diff --git a/mail/qmail-autoresponder/Makefile b/mail/qmail-autoresponder/Makefile
index e151a654f8d6..0f41867339b3 100644
--- a/mail/qmail-autoresponder/Makefile
+++ b/mail/qmail-autoresponder/Makefile
@@ -9,17 +9,20 @@
#
PORTNAME= qmail-autoresponder
-PORTVERSION= 0.96.1
-PORTREVISION= 1
+PORTVERSION= 0.96.2
CATEGORIES= mail
MASTER_SITES= http://untroubled.org/${PORTNAME}/
MAINTAINER= sergei@FreeBSD.org
COMMENT= Rate-limited autoresponder for qmail
-BUILD_DEPENDS= ${LOCALBASE}/lib/libbg-iobuf.a:${PORTSDIR}/devel/bglibs
+BUILD_DEPENDS= ${BGLIBS_LIB}/libbg.a:${PORTSDIR}/devel/bglibs
+USE_GPG= yes
+SIG_SUFFIX= .sig
LDFLAGS?= -s
+BGLIBS_INC= ${LOCALBASE}/include/bglibs
+BGLIBS_LIB= ${LOCALBASE}/lib/bglibs
PROGS= qmail-autoresponder
MAN1= qmail-autoresponder.1
@@ -43,8 +46,8 @@ do-configure:
${ECHO_CMD} "${MANPREFIX}/man" > ${WRKSRC}/conf-man
${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
${ECHO_CMD} "${CC} ${LDFLAGS}" > ${WRKSRC}/conf-ld
- ${ECHO_CMD} "${LOCALBASE}/include/bglibs" > ${WRKSRC}/conf-bgincs
- ${ECHO_CMD} "${LOCALBASE}/lib" > ${WRKSRC}/conf-bglibs
+ ${ECHO_CMD} "${BGLIBS_INC}" > ${WRKSRC}/conf-bgincs
+ ${ECHO_CMD} "${BGLIBS_LIB}" > ${WRKSRC}/conf-bglibs
do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PROGS} ${PREFIX}/bin
diff --git a/mail/qmail-autoresponder/distinfo b/mail/qmail-autoresponder/distinfo
index 1e0caa94181b..4fd4f36e8cfe 100644
--- a/mail/qmail-autoresponder/distinfo
+++ b/mail/qmail-autoresponder/distinfo
@@ -1,2 +1,4 @@
-MD5 (qmail-autoresponder-0.96.1.tar.gz) = e845b37ef3e2b85aa0ca51d1e54f661b
-SIZE (qmail-autoresponder-0.96.1.tar.gz) = 21871
+MD5 (qmail-autoresponder-0.96.2.tar.gz) = f4e4edcd750daa8877088577369a876b
+SIZE (qmail-autoresponder-0.96.2.tar.gz) = 21110
+MD5 (qmail-autoresponder-0.96.2.tar.gz.sig) = c0add59e6f3ead6874f880c4a3ef92a1
+SIZE (qmail-autoresponder-0.96.2.tar.gz.sig) = 189
diff --git a/mail/qmail-autoresponder/files/patch-main.c b/mail/qmail-autoresponder/files/patch-main.c
deleted file mode 100644
index 2ac8f8de9634..000000000000
--- a/mail/qmail-autoresponder/files/patch-main.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- main.c.orig Mon Oct 13 16:17:08 2003
-+++ main.c Mon Oct 13 16:17:41 2003
-@@ -244,17 +244,17 @@ static void copy_input(obuf* out)
- }
-
- static const char* usage_str =
--"usage: %s [-cqDNT] [-n NUM] [-s STR] [-t TIME] %s
-- -c Copy message into response
-- -n NUM Set the maximum number of replies (defaults to 1)
-- -s STR Add the subject to the autoresponse, prefixed by STR
-- -t TIME Set the time interval, in seconds (defaults to 1 hour)
-- -q Don't show error messages
-- -D Don't remove old response records
-- -N Don't send, just send autoresponse to standard output
-- If more than NUM messages are received from the same sender
-- within TIME seconds of each other, no response is sent.
-- This program must be run by qmail.
-+"usage: %s [-cqDNT] [-n NUM] [-s STR] [-t TIME] %s\n\
-+ -c Copy message into response\n\
-+ -n NUM Set the maximum number of replies (defaults to 1)\n\
-+ -s STR Add the subject to the autoresponse, prefixed by STR\n\
-+ -t TIME Set the time interval, in seconds (defaults to 1 hour)\n\
-+ -q Don't show error messages\n\
-+ -D Don't remove old response records\n\
-+ -N Don't send, just send autoresponse to standard output\n\
-+ If more than NUM messages are received from the same sender\n\
-+ within TIME seconds of each other, no response is sent.\n\
-+ This program must be run by qmail.\n\
- %s";
-
- void usage(const char* msg)