aboutsummaryrefslogtreecommitdiff
path: root/mail/qmail-ldap
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-02-12 02:59:37 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-02-12 02:59:37 +0000
commit84436002d7a70b18790a3e2357c7d2ea688de4bb (patch)
tree59d04b17dafdb8450adbbd8d66c8894786382f39 /mail/qmail-ldap
parent4729a174ab71b7c7ad9f845b2aed0229d436e684 (diff)
downloadports-84436002d7a70b18790a3e2357c7d2ea688de4bb.tar.gz
ports-84436002d7a70b18790a3e2357c7d2ea688de4bb.zip
Notes
Diffstat (limited to 'mail/qmail-ldap')
-rw-r--r--mail/qmail-ldap/Makefile42
-rw-r--r--mail/qmail-ldap/files/extra-patch-autohomedirmake11
-rw-r--r--mail/qmail-ldap/files/extra-patch-automaildirmake11
-rw-r--r--mail/qmail-ldap/files/extra-patch-debug11
-rw-r--r--mail/qmail-ldap/files/extra-patch-ldap-cluster11
-rw-r--r--mail/qmail-ldap/pkg-message11
-rw-r--r--mail/qmail-ldap/pkg-plist78
7 files changed, 79 insertions, 96 deletions
diff --git a/mail/qmail-ldap/Makefile b/mail/qmail-ldap/Makefile
index 49c890fe3c28..7340ef91eab6 100644
--- a/mail/qmail-ldap/Makefile
+++ b/mail/qmail-ldap/Makefile
@@ -7,19 +7,21 @@
PORTNAME= qmail
PORTVERSION= ${QMAIL_VERSION}.${LDAP_PATCH_DATE}
-PORTREVISION= 1
CATEGORIES= mail
PKGNAMESUFFIX= -ldap
PATCH_SITES= http://www.nrg4u.com/qmail/
PATCHFILES= qmail-ldap-1.03-${LDAP_PATCH_DATE}.patch.gz
+PATCH_DIST_STRIP+= -p1
MAINTAINER= lioux@FreeBSD.org
LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap
-NO_PACKAGE= djb\'s packaging license does not allow non-standard\
- qmail distributions
+# Patches from the main qmail port are not wanted
+MAIN_QMAIL_PORT_PATCH_BARRIER= yes
+
+LDAP_PATCH_DATE= 20010201
.if !defined(PRE_MK_INCLUDED)
.include <bsd.port.pre.mk>
@@ -31,32 +33,48 @@ DOCFILES+= ${WRKSRC}/QLDAPINSTALL ${WRKSRC}/QLDAPNEWS \
${WRKSRC}/QLDAPTODO ${WRKSRC}/QLDAPPICTURE \
${WRKSRC}/ANTISPAM
-LDAP_PATCH_DATE= 20001201
+yetanotherone-pre-fetch: tls-pre-fetch
+
+tls-pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "WITH_LDAP_CLUSTER=yes enable cluster support"
+ @${ECHO_MSG} "WITH_AUTOMAILDIRMAKE=yes enable the auto-maildir-make feature"
+ @${ECHO_MSG} "WITH_AUTOHOMEDIRMAKE=yes enable the auto-homedir-make feature"
+ @${ECHO_MSG} "WITH_LDAP_DEBUG=yes enable the possibility to log and debug imap and pop"
+ @${ECHO_MSG} "WITH_CLEARTEXTPASSWD=yes use cleartext passwords"
+ @${ECHO_MSG} ""
+yetanotherone-post-patch: tls-post-patch
+
+tls-post-patch:
.if defined(WITH_LDAP_CLUSTER)
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ldap-cluster
+ @${PERL} -pi -ne "s|#LDAPFLAGS=-DQLDAP_CLUSTER|LDAPFLAGS\+=-DQLDAP_CLUSTER|" ${WRKSRC}/Makefile
.endif # WITH_LDAP_CLUSTER
-#
.if defined(WITH_AUTOMAILDIRMAKE)
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-automaildirmake
+ @${PERL} -pi -ne "s|#MDIRMAKE=-DAUTOMAILDIRMAKE|MDIRMAKE=-DAUTOMAILDIRMAKE|" ${WRKSRC}/Makefile
.endif # WITH_AUTOMAILDIRMAKE
-#
.if defined(WITH_AUTOHOMEDIRMAKE)
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-autohomedirmake
+ @${PERL} -pi -ne "s|#HDIRMAKE=-DAUTOHOMEDIRMAKE|HDIRMAKE=-DAUTOHOMEDIRMAKE|" ${WRKSRC}/Makefile
.endif # WITH_AUTOHOMEDIRMAKE
-#
.if defined(WITH_LDAP_DEBUG)
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-debug
+ @${PERL} -pi -ne "s|#DEBUG=-DDEBUG|DEBUG=-DDEBUG|" ${WRKSRC}/Makefile
.endif # WITH_LDAP_DEBUG
+.if defined(WITH_CLEARTEXTPASSWD)
+ @${PERL} -pi -ne "s|# -DCLEARTEXTPASSWD to the LDAPFLAGS|LDAPFLAGS\+=-DCLEARTEXTPASSWD|" \
+ ${WRKSRC}/Makefile
+.endif # WITH_CLEARTEXTPASSWD
# Local overrides
MASTERDIR= ${PORTSDIR}/mail/qmail
#MASTERDIR= ${.CURDIR}/../qmail
PATCHDIR= ${.CURDIR}/files
PKGDIR_LOCAL= ${.CURDIR}
+COMMENT= ${PKGDIR_LOCAL}/pkg-comment
DESCR= ${PKGDIR_LOCAL}/pkg-descr
-PLIST= ${PKGDIR_LOCAL}/pkg-plist
PKGMESSAGE= ${PKGDIR_LOCAL}/pkg-message
+PLIST= ${PKGDIR_LOCAL}/pkg-plist
PRE_MK_INCLUDED= yes
diff --git a/mail/qmail-ldap/files/extra-patch-autohomedirmake b/mail/qmail-ldap/files/extra-patch-autohomedirmake
deleted file mode 100644
index b04c3e84b119..000000000000
--- a/mail/qmail-ldap/files/extra-patch-autohomedirmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Tue Dec 12 12:38:03 2000
-+++ Makefile Tue Dec 12 12:39:00 2000
-@@ -36,7 +36,7 @@
- #MDIRMAKE=-DAUTOMAILDIRMAKE
-
- # to enable the auto-homedir-make feature uncomment the next line
--#HDIRMAKE=-DAUTOHOMEDIRMAKE
-+HDIRMAKE=-DAUTOHOMEDIRMAKE
-
- # on most systems we need this to make checkpassword
- SHADOWLIBS=-lcrypt
diff --git a/mail/qmail-ldap/files/extra-patch-automaildirmake b/mail/qmail-ldap/files/extra-patch-automaildirmake
deleted file mode 100644
index f4491e947dd1..000000000000
--- a/mail/qmail-ldap/files/extra-patch-automaildirmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Tue Dec 12 12:38:03 2000
-+++ Makefile Tue Dec 12 12:38:40 2000
-@@ -33,7 +33,7 @@
- MNW=-DMAKE_NETSCAPE_WORK
-
- # to enable the auto-maildir-make feature uncomment the next line
--#MDIRMAKE=-DAUTOMAILDIRMAKE
-+MDIRMAKE=-DAUTOMAILDIRMAKE
-
- # to enable the auto-homedir-make feature uncomment the next line
- #HDIRMAKE=-DAUTOHOMEDIRMAKE
diff --git a/mail/qmail-ldap/files/extra-patch-debug b/mail/qmail-ldap/files/extra-patch-debug
deleted file mode 100644
index 730c5ec9bcf9..000000000000
--- a/mail/qmail-ldap/files/extra-patch-debug
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Tue Dec 19 00:20:03 2000
-+++ Makefile Tue Dec 19 00:19:59 2000
-@@ -49,7 +49,7 @@
-
- # to enable the possibility to log and debug imap and pop uncoment the
- # next line
--#DEBUG=-DDEBUG
-+DEBUG=-DDEBUG
- # WARNING: you need NONE DEBUG auth_* to run with inetd
-
- # for profiling ...
diff --git a/mail/qmail-ldap/files/extra-patch-ldap-cluster b/mail/qmail-ldap/files/extra-patch-ldap-cluster
deleted file mode 100644
index 2a1e548cff64..000000000000
--- a/mail/qmail-ldap/files/extra-patch-ldap-cluster
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Tue Dec 12 12:38:03 2000
-+++ Makefile Tue Dec 12 12:38:07 2000
-@@ -6,7 +6,7 @@
- # -DQLDAP_CLUSTER for enabling cluster support
- # to use cleartext passwords (a bad idea on production systems) add
- # -DCLEARTEXTPASSWD to the LDAPFLAGS
--#LDAPFLAGS=-DQLDAP_CLUSTER
-+LDAPFLAGS=-DQLDAP_CLUSTER
-
- # Perhaps you have different ldap libraries, change them here
- LDAPLIBS=-L/usr/local/lib -lldap -llber
diff --git a/mail/qmail-ldap/pkg-message b/mail/qmail-ldap/pkg-message
index 0f8b1638a4a6..80255f4051b3 100644
--- a/mail/qmail-ldap/pkg-message
+++ b/mail/qmail-ldap/pkg-message
@@ -8,4 +8,13 @@ You should also add /var/qmail/man to your MANPATH (see manpath(1)
or login.conf(5)).
Do not forget to read /var/qmail/doc/QLDAPINSTALL. After all,
-this is NOT our old stock qmail.
+this is NOT our old stock qmail. And, /var/qmail/doc/ANTISPAM
+for some antispam control measures.
+
+You can enable qmail as your default mailer:
+
+# this will disable the default MTA
+1) do "make disable-sendmail"
+
+# enable qmail as your default MTA
+2) do "make enable-qmail"
diff --git a/mail/qmail-ldap/pkg-plist b/mail/qmail-ldap/pkg-plist
index 1ecb6baf1405..abac72ef2a73 100644
--- a/mail/qmail-ldap/pkg-plist
+++ b/mail/qmail-ldap/pkg-plist
@@ -1,31 +1,31 @@
-%%DOCDIR%%/FAQ
-%%DOCDIR%%/UPGRADE
-%%DOCDIR%%/SENDMAIL
-%%DOCDIR%%/INSTALL
-%%DOCDIR%%/INSTALL.alias
-%%DOCDIR%%/INSTALL.ctl
-%%DOCDIR%%/INSTALL.ids
-%%DOCDIR%%/INSTALL.maildir
-%%DOCDIR%%/INSTALL.mbox
-%%DOCDIR%%/INSTALL.vsm
-%%DOCDIR%%/TEST.deliver
-%%DOCDIR%%/TEST.receive
-%%DOCDIR%%/REMOVE.sendmail
-%%DOCDIR%%/REMOVE.binmail
-%%DOCDIR%%/PIC.local2alias
-%%DOCDIR%%/PIC.local2ext
-%%DOCDIR%%/PIC.local2local
-%%DOCDIR%%/PIC.local2rem
-%%DOCDIR%%/PIC.local2virt
-%%DOCDIR%%/PIC.nullclient
-%%DOCDIR%%/PIC.relaybad
-%%DOCDIR%%/PIC.relaygood
-%%DOCDIR%%/PIC.rem2local
-%%DOCDIR%%/QLDAPINSTALL
-%%DOCDIR%%/QLDAPNEWS
-%%DOCDIR%%/QLDAPTODO
-%%DOCDIR%%/QLDAPPICTURE
-%%DOCDIR%%/ANTISPAM
+%%PORTDOCS%%%%DOCDIR%%/FAQ
+%%PORTDOCS%%%%DOCDIR%%/UPGRADE
+%%PORTDOCS%%%%DOCDIR%%/SENDMAIL
+%%PORTDOCS%%%%DOCDIR%%/INSTALL
+%%PORTDOCS%%%%DOCDIR%%/INSTALL.alias
+%%PORTDOCS%%%%DOCDIR%%/INSTALL.ctl
+%%PORTDOCS%%%%DOCDIR%%/INSTALL.ids
+%%PORTDOCS%%%%DOCDIR%%/INSTALL.maildir
+%%PORTDOCS%%%%DOCDIR%%/INSTALL.mbox
+%%PORTDOCS%%%%DOCDIR%%/INSTALL.vsm
+%%PORTDOCS%%%%DOCDIR%%/TEST.deliver
+%%PORTDOCS%%%%DOCDIR%%/TEST.receive
+%%PORTDOCS%%%%DOCDIR%%/REMOVE.sendmail
+%%PORTDOCS%%%%DOCDIR%%/REMOVE.binmail
+%%PORTDOCS%%%%DOCDIR%%/PIC.local2alias
+%%PORTDOCS%%%%DOCDIR%%/PIC.local2ext
+%%PORTDOCS%%%%DOCDIR%%/PIC.local2local
+%%PORTDOCS%%%%DOCDIR%%/PIC.local2rem
+%%PORTDOCS%%%%DOCDIR%%/PIC.local2virt
+%%PORTDOCS%%%%DOCDIR%%/PIC.nullclient
+%%PORTDOCS%%%%DOCDIR%%/PIC.relaybad
+%%PORTDOCS%%%%DOCDIR%%/PIC.relaygood
+%%PORTDOCS%%%%DOCDIR%%/PIC.rem2local
+%%PORTDOCS%%%%DOCDIR%%/QLDAPINSTALL
+%%PORTDOCS%%%%DOCDIR%%/QLDAPNEWS
+%%PORTDOCS%%%%DOCDIR%%/QLDAPTODO
+%%PORTDOCS%%%%DOCDIR%%/QLDAPPICTURE
+%%PORTDOCS%%%%DOCDIR%%/ANTISPAM
boot/home
boot/home+df
boot/proc
@@ -153,17 +153,17 @@ configure/hostname
configure/dnsip
configure/ipmeprint
configure/dnsptr
-%%DOCDIR%%/BLURB
-%%DOCDIR%%/BLURB2
-%%DOCDIR%%/BLURB3
-%%DOCDIR%%/BLURB4
-%%DOCDIR%%/INTERNALS
-%%DOCDIR%%/SECURITY
-%%DOCDIR%%/THOUGHTS
-%%DOCDIR%%/PORT_NOTES
-%%DOCDIR%%/PORT_NOTES_FreeBSD_40-RELEASE
-%%DOCDIR%%/SYSDEPS
-%%DOCDIR%%/mkaliasdir
+%%PORTDOCS%%%%DOCDIR%%/BLURB
+%%PORTDOCS%%%%DOCDIR%%/BLURB2
+%%PORTDOCS%%%%DOCDIR%%/BLURB3
+%%PORTDOCS%%%%DOCDIR%%/BLURB4
+%%PORTDOCS%%%%DOCDIR%%/INTERNALS
+%%PORTDOCS%%%%DOCDIR%%/SECURITY
+%%PORTDOCS%%%%DOCDIR%%/THOUGHTS
+%%PORTDOCS%%%%DOCDIR%%/PORT_NOTES
+%%PORTDOCS%%%%DOCDIR%%/PORT_NOTES_FreeBSD_40-RELEASE
+%%PORTDOCS%%%%DOCDIR%%/SYSDEPS
+%%PORTDOCS%%%%DOCDIR%%/mkaliasdir
boot/maildir
@dirrm %%DOCDIR%%
@dirrm configure