aboutsummaryrefslogtreecommitdiff
path: root/mail/qmail-mysql
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-02-12 03:08:53 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-02-12 03:08:53 +0000
commit1de2823475b09d5816349c4a7ab9c16526ebfa9e (patch)
tree0594e91929de04f50afb772648f0e760d828be04 /mail/qmail-mysql
parent8c7538ec439094699a1d0990aca3e03d006eb7a5 (diff)
downloadports-1de2823475b09d5816349c4a7ab9c16526ebfa9e.tar.gz
ports-1de2823475b09d5816349c4a7ab9c16526ebfa9e.zip
Add initial revision of port of a patch to stock qmail supporting
MySQL queries from within qmail MySQL patch version 1.1.1. The author does not advise the use of the latest patch version 1.1.6 under FreeBSD This is a meta port both including and dependent on the main port qmail Makefile
Notes
Notes: svn path=/head/; revision=38237
Diffstat (limited to 'mail/qmail-mysql')
-rw-r--r--mail/qmail-mysql/Makefile46
-rw-r--r--mail/qmail-mysql/pkg-comment1
-rw-r--r--mail/qmail-mysql/pkg-descr11
-rw-r--r--mail/qmail-mysql/pkg-message19
4 files changed, 77 insertions, 0 deletions
diff --git a/mail/qmail-mysql/Makefile b/mail/qmail-mysql/Makefile
new file mode 100644
index 000000000000..7b4cee0094d3
--- /dev/null
+++ b/mail/qmail-mysql/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: qmail-mysql
+# Date created: 6 Feb 2001
+# Whom: Mario S F Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qmail
+PORTVERSION= ${QMAIL_VERSION}.${MYSQL_PATCH_VERSION}
+CATEGORIES= mail
+PKGNAMESUFFIX= -mysql
+
+PATCH_SITES+= http://iain.cx/unix/qmail/download/
+PATCHFILES+= qmail-mysql-${MYSQL_PATCH_VERSION}.patch
+
+MAINTAINER= lioux@FreeBSD.org
+
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+
+MYSQL_PATCH_VERSION= 1.1.1
+
+.if !defined(PRE_MK_INCLUDED)
+.include <bsd.port.pre.mk>
+.endif
+
+#PREFIX= /var/qmail-mysql
+
+# Yet anther ugly hack (works due to code inside the main qmail port)
+yetanotherone-post-patch: qmail-mysql-post-patch
+
+qmail-mysql-post-patch:
+ @${PERL} -pi -ne \
+ "s|/usr/local/mysql/lib|${LOCALBASE}/lib|;s|/usr/local/mysql/include|${LOCALBASE}/include|;s|-lm|-lm -lz|" \
+ ${WRKSRC}/Makefile
+
+# Local overrides
+MASTERDIR= ${PORTSDIR}/mail/qmail
+#MASTERDIR= ${.CURDIR}/../qmail
+PKGDIR_LOCAL= ${.CURDIR}
+COMMENT= ${PKGDIR_LOCAL}/pkg-comment
+DESCR= ${PKGDIR_LOCAL}/pkg-descr
+PKGMESSAGE= ${PKGDIR_LOCAL}/pkg-message
+
+PRE_MK_INCLUDED= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/qmail-mysql/pkg-comment b/mail/qmail-mysql/pkg-comment
new file mode 100644
index 000000000000..00bcf9585dd0
--- /dev/null
+++ b/mail/qmail-mysql/pkg-comment
@@ -0,0 +1 @@
+A SECURE, reliable, and FAST MTA for UNIX systems WITH MySQL support
diff --git a/mail/qmail-mysql/pkg-descr b/mail/qmail-mysql/pkg-descr
new file mode 100644
index 000000000000..b9a9449176c5
--- /dev/null
+++ b/mail/qmail-mysql/pkg-descr
@@ -0,0 +1,11 @@
+What is is: [excerpt from the patch homepage]
+
+A few people have done qmail - MySQL integration and this is my
+crack at it. My work is based on takeshi@softagency.co.jp's patches,
+which you can find at http://www.softagency.co.jp/mysql/qmail.en.html.
+However I wanted to tidy up some of the code to make it use strallocs
+and do more error checking. I also wanted to simplify the configuration,
+whilst at the same time allowing more flexibility. Plus there were
+some things I just didn't want: quotas and APOP support for example...
+
+WWW: http://iain.cx/unix/qmail/mysql.php
diff --git a/mail/qmail-mysql/pkg-message b/mail/qmail-mysql/pkg-message
new file mode 100644
index 000000000000..3eeb0f503464
--- /dev/null
+++ b/mail/qmail-mysql/pkg-message
@@ -0,0 +1,19 @@
+ ATTENTIONATTENTION:
+
+Please make sure that you read /var/qmail/doc/PORT_NOTES.
+It contains important information about testing and configuring
+qmail, and finally replacing sendmail with qmail.
+
+You should also add /var/qmail/man to your MANPATH (see manpath(1)
+or login.conf(5)).
+
+Do not forget to read http://iain.cx/unix/qmail/mysql.php. After all,
+this is NOT our old stock qmail.
+
+You can enable qmail as your default mailer:
+
+# this will disable the default MTA
+1) do "make disable-sendmail"
+
+# enable qmail as your default MTA
+2) do "make enable-qmail"