aboutsummaryrefslogtreecommitdiff
path: root/mail/qmail-scanner
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-09-09 07:49:33 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-09-09 07:49:33 +0000
commit48d91ab4d2b669bd912c8ace42e132f310defa43 (patch)
treed9dde7464a8aa6e261b92b3c7e6836f7bbf7199d /mail/qmail-scanner
parentc5a093619a659d54bb2a4409d71902fdf9c28626 (diff)
downloadports-48d91ab4d2b669bd912c8ace42e132f310defa43.tar.gz
ports-48d91ab4d2b669bd912c8ace42e132f310defa43.zip
Notes
Diffstat (limited to 'mail/qmail-scanner')
-rw-r--r--mail/qmail-scanner/Makefile10
-rw-r--r--mail/qmail-scanner/files/pkg-install.in6
-rw-r--r--mail/qmail-scanner/files/pkg-message.in8
3 files changed, 12 insertions, 12 deletions
diff --git a/mail/qmail-scanner/Makefile b/mail/qmail-scanner/Makefile
index 73e163953b65..3af812a50a9d 100644
--- a/mail/qmail-scanner/Makefile
+++ b/mail/qmail-scanner/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qmail-scanner
PORTVERSION= 2.01
+PORTREVISION= 1
CATEGORIES= mail security
MASTER_SITES= SF
EXTRACT_SUFX= .tgz
@@ -58,13 +59,11 @@ CONFIGURE_ARGS+=--qmaildir "${QMAIL_PREFIX}" \
--mime-unpacker "reformime" \
--batch
-SUB_FILES= pkg-message
+SUB_FILES= pkg-message pkg-install
SUB_LIST= SPOOLDIR="${SPOOLDIR}" \
QS_USER=${QS_USER} \
QS_ID=${QS_ID}
-PKGINSTALL?= ${WRKDIR}/pkg-install
-
.include <bsd.port.pre.mk>
.if defined(WITH_TNEF)
@@ -222,7 +221,7 @@ do-configure:
@${SED} -e 's,%%SPOOLDIR%%,${SPOOLDIR},g; s,%%QS_USER%%,${QS_USER},g; \
s,%%QS_ID%%,${QS_ID},g; s,%%PREFIX%%,${PREFIX},g' \
${FILESDIR}/pkg-install.in > ${WRKDIR}/pkg-install
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+ @${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
.if !defined(NOPORTDOCS)
@@ -239,9 +238,10 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/qmail-scanner-queue.template ${PREFIX}/bin/qmail-scanner-queue.pl
@${ECHO_MSG} ""
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} ""
post-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
post-deinstall:
@${ECHO_MSG} ""
diff --git a/mail/qmail-scanner/files/pkg-install.in b/mail/qmail-scanner/files/pkg-install.in
index 523db6e5b97d..9b69e9855472 100644
--- a/mail/qmail-scanner/files/pkg-install.in
+++ b/mail/qmail-scanner/files/pkg-install.in
@@ -13,7 +13,7 @@ QS_ID=%%QS_ID%%
SPOOLDIR=%%SPOOLDIR%%
-case "$1" in
+case "$2" in
PRE-INSTALL)
# User and group
${PW} groupshow -n ${QS_USER} >/dev/null 2>&1 \
@@ -39,10 +39,6 @@ POST-INSTALL)
${CHOWN} ${QS_USER}:${QS_USER} ${PREFIX}/bin/qmail-scanner-queue.pl
${CHMOD} 4755 ${PREFIX}/bin/qmail-scanner-queue.pl
- # Initialize
- ${PREFIX}/bin/qmail-scanner-queue.pl -z
- ${PREFIX}/bin/qmail-scanner-queue.pl -g
-
# Mod and owner (final)
${CHOWN} -R ${QS_USER}:${QS_USER} ${SPOOLDIR}
;;
diff --git a/mail/qmail-scanner/files/pkg-message.in b/mail/qmail-scanner/files/pkg-message.in
index 685b1856f907..2f3f1f42065c 100644
--- a/mail/qmail-scanner/files/pkg-message.in
+++ b/mail/qmail-scanner/files/pkg-message.in
@@ -3,8 +3,8 @@ Congratulations! Qmail-Scanner is now installed!
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
- Please, configure correctly your anti-virus and anti-spam;
- - You HAVE to reinstall this port each time you add or remo-;
-ve one;
+ - You HAVE to reinstall this port each time you add or remo-
+ve an Anti-Virus or Anti-Spam;
- Now configure the environment variable to use qmail-scanner:
You just need to add for your tcpserver file (generally called
@@ -20,3 +20,7 @@ need to restart your smtpd, for it use: "svc -k /service/smtpd".
You can test your installation by running 'make test' in port dir.
+Please, run the following commands:
+
+%%PREFIX%%/bin/qmail-scanner-queue.pl -z
+%%PREFIX%%/bin/qmail-scanner-queue.pl -g