aboutsummaryrefslogtreecommitdiff
path: root/mail/qmail/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-05-17 17:35:10 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-05-17 17:35:10 +0000
commita8971230e48745cd91047b6f93914585b72a7931 (patch)
treeece94e715af06304eec47cab6acb60b98df7cf76 /mail/qmail/Makefile
parentd6472a8e3a397b142fbdf24a4ac23dda515f37f9 (diff)
downloadports-a8971230e48745cd91047b6f93914585b72a7931.tar.gz
ports-a8971230e48745cd91047b6f93914585b72a7931.zip
Notes
Diffstat (limited to 'mail/qmail/Makefile')
-rw-r--r--mail/qmail/Makefile56
1 files changed, 46 insertions, 10 deletions
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index 15d42e880069..aeaf3629af21 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -17,20 +17,32 @@ COMMENT?= A secure, reliable, efficient, simple, and fast MTA
DIST_SUBDIR= qmail
-.if defined(SLAVE_LDAP) || defined(SLAVE_SPAMCONTROL)
-BARRIER_DNS_PATCH=yes
-BARRIER_BIG_CONCURRENCY_PATCH=yes
-BARRIER_QMTPC_PATCH=yes
+.if defined(SLAVE_LDAP) || \
+ defined(SLAVE_SPAMCONTROL) || \
+ defined(SLAVE_MYSQL)
+BARRIER_MAILDIRQUOTA_PATCH= yes
+BARRIER_BLOCKEXEC_PATCH= yes
.endif
-.if defined(SLAVE_LDAP) || defined(SLAVE_SMTP_AUTH_TLS) || \
- defined(SLAVE_SPAMCONTROL) || defined(SLAVE_TLS)
-BARRIER_OUTGOINGIP_PATCH=yes
-BARRIER_RFC2821_PATCH=yes
+.if defined(SLAVE_LDAP) || \
+ defined(SLAVE_SPAMCONTROL)
+BARRIER_DNS_PATCH= yes
+BARRIER_BIG_CONCURRENCY_PATCH= yes
+BARRIER_QMTPC_PATCH= yes
+BARRIER_DISCBOUNCES_PATCH= yes
.endif
-.if defined(SLAVE_MYSQL) || defined(SLAVE_SPAMCONTROL)
-BARRIER_QMAILQUEUE_PATCH=yes
+.if defined(SLAVE_LDAP) || \
+ defined(SLAVE_SMTP_AUTH_TLS) || \
+ defined(SLAVE_SPAMCONTROL) || \
+ defined(SLAVE_TLS)
+BARRIER_OUTGOINGIP_PATCH= yes
+BARRIER_RFC2821_PATCH= yes
+.endif
+
+.if defined(SLAVE_MYSQL) || \
+ defined(SLAVE_SPAMCONTROL)
+BARRIER_QMAILQUEUE_PATCH= yes
.endif
.if defined(SLAVE_SPAMCONTROL)
@@ -116,6 +128,15 @@ OPTIONS+= LOCALTIME_PATCH "emit dates in the local timezone" off
.if !defined(BARRIER_QMTPC_PATCH)
OPTIONS+= QMTPC_PATCH "send email using qmtp protocol" off
.endif
+.if !defined(BARRIER_MAILDIRQUOTA_PATCH)
+OPTIONS+= MAILDIRQUOTA_PATCH "Maildir++ support" off
+.endif
+.if !defined(BARRIER_BLOCKEXEC_PATCH)
+OPTIONS+= BLOCKEXEC_PATCH "block many windows viruses/worms" off
+.endif
+.if !defined(BARRIER_DISCBOUNCES_PATCH)
+OPTIONS+= DISCBOUNCES_PATCH "discard double-bounces" off
+.endif
.if defined(SLAVE_TLS) || defined(SLAVE_SMTP_AUTH_TLS)
OPTIONS+= TLS_DEBUG "enable additional debug information" off
.elif defined(SLAVE_LDAP)
@@ -270,6 +291,21 @@ USE_REINPLACE= yes
BROKEN= "OUTGOINGIP and QMTPC conflicts! Please, make your choice"
.endif
+.if defined(WITH_MAILDIRQUOTA_PATCH) && !defined(BARRIER_MAILDIRQUOTA_PATCH)
+PATCH_SITES+= http://www.alexdupre.com/qmail/:quota
+PATCHFILES+= qmail-maildir++.patch:quota
+.endif
+
+.if defined(WITH_BLOCKEXEC_PATCH) && !defined(BARRIER_BLOCKEXEC_PATCH)
+PATCH_SITES+= http://www.alexdupre.com/qmail/:blockexec
+PATCHFILES+= qmail-block-executables.patch:blockexec
+.endif
+
+.if defined(WITH_DISCBOUNCES_PATCH) && !defined(BARRIER_DISCBOUNCES_PATCH)
+PATCH_SITES+= http://www.alexdupre.com/qmail/:doublebounce
+PATCHFILES+= qmail-discard-double-bounces.patch:doublebounce
+.endif
+
.if !defined(BARRIER_DNS_PATCH) \
||(defined(WITH_QMAILQUEUE_PATCH) && !defined(BARRIER_QMAILQUEUE_PATCH)) \
||(defined(WITH_BIG_TODO_PATCH) && !defined(BARRIER_BIG_TODO_PATCH)) \