aboutsummaryrefslogtreecommitdiff
path: root/mail/qmailadmin
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2004-06-29 01:02:46 +0000
committerPeter Pentchev <roam@FreeBSD.org>2004-06-29 01:02:46 +0000
commit7bf5d442d4240608b2b257fe022605991470f451 (patch)
tree9d97fed7288a38247e23945eb0d3fd1d0b0ee77f /mail/qmailadmin
parentee6be7e1f6f22f4a67bff68a94c24a27b0f5f71f (diff)
downloadports-7bf5d442d4240608b2b257fe022605991470f451.tar.gz
ports-7bf5d442d4240608b2b257fe022605991470f451.zip
Notes
Diffstat (limited to 'mail/qmailadmin')
-rw-r--r--mail/qmailadmin/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/mail/qmailadmin/Makefile b/mail/qmailadmin/Makefile
index e5624340ad1d..0127c386b485 100644
--- a/mail/qmailadmin/Makefile
+++ b/mail/qmailadmin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qmailadmin
PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -57,6 +57,11 @@ USE_GMAKE= YES
# WITHOUT_IDX_SQL - disable the SQL support for mailing lists
# WITH_HELP - display help links on login page
#
+# WITH_SPAM_DETECTION - allow users to enable/disable spam checking
+# SPAM_COMMAND - the command to use to check for spam;
+# default is "|preline /usr/local/bin/maildrop /etc/mailfilter"
+# do not forget the "|" at the start
+#
CGIBINDIR?= www/cgi-bin.default
CGIBINSUBDIR?= qmailadmin
@@ -118,4 +123,11 @@ CONFIGURE_ARGS+= --disable-ezmlm-mysql
CONFIGURE_ARGS+= --enable-help
.endif
+.if defined(WITH_SPAM_DETECTION)
+CONFIGURE_ARGS+= --enable-modify-spam=y
+.if defined(SPAM_COMMAND)
+CONFIGURE_ARGS+= --enable-spam-command="${SPAM_COMMAND}"
+.endif
+.endif
+
.include <bsd.port.post.mk>