aboutsummaryrefslogtreecommitdiff
path: root/mail/qpopper/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-04-17 07:53:49 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-04-17 07:53:49 +0000
commit496f0ea974af9d2f2a15bdceeacbd996b123ee99 (patch)
tree1327a9305ffd64aaafaeb731499faa0012e02d9c /mail/qpopper/Makefile
parent2f4b6bde6ba1179374bb1e3cf577a1335af1075d (diff)
downloadports-496f0ea974af9d2f2a15bdceeacbd996b123ee99.tar.gz
ports-496f0ea974af9d2f2a15bdceeacbd996b123ee99.zip
Notes
Diffstat (limited to 'mail/qpopper/Makefile')
-rw-r--r--mail/qpopper/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index 0f158394bee6..3f16534c5fcf 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qpopper
-PORTVERSION= 3.1.2
-PORTREVISION= 1
+PORTVERSION= 4.0
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.qualcomm.com/eudora/servers/unix/popper/ \
ftp://sunsite.doc.ic.ac.uk/Mirrors/ftp.qualcomm.com/eudora/servers/unix/popper/
@@ -15,11 +14,11 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 400014
-PATCH_SITES= http://www.imasy.or.jp/~ume/ipv6/
-PATCHFILES= qpopper3.1.2-ipv6-20001214.diff.gz
-PATCH_DIST_STRIP= -p1
-.endif
+#.if ${OSVERSION} >= 400014
+#PATCH_SITES= http://www.imasy.or.jp/~ume/ipv6/
+#PATCHFILES= qpopper3.1.2-ipv6-20001214.diff.gz
+#PATCH_DIST_STRIP= -p1
+#.endif
MAINTAINER= lioux@FreeBSD.org
@@ -45,6 +44,14 @@ OS_DEFS+= -DAPOP_ONLY
CONFIGURE_ARGS+= --enable-debugging
.endif
+.if exists(/usr/lib/libssl.a) && exists(/usr/lib/libcrypto.a)
+CONFIGURE_ARGS+= --with-openssl=/usr
+.elif exists(${LOCALBASE}/lib/libssl.a) && exists(${LOCALBASE}/lib/libcrypto.a)
+LIB_DEPENDS+= ssl.1:${PORTSDIR}/security/openssl
+CONFIGURE_ARGS+= -with-includes=${LOCALBASE}/include/openssl --with-openssl=${LOCALBASE}
+CONFIGURE_ENV+= RSAGLUE=-lRSAglue
+.endif
+
post-patch:
@${RM} -f ${WRKSRC}/popper/md5.h
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/man/*