aboutsummaryrefslogtreecommitdiff
path: root/mail/qpopper
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-31 03:44:30 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-31 03:44:30 +0000
commit12bddd24fd8a3ccd29e50b7866b6f5dbd6096c21 (patch)
tree6da42568274e042b4f0093793ff69883826613f6 /mail/qpopper
parent6ea5d2cfbbc9fd59572e7e40b88efab320183efe (diff)
downloadports-12bddd24fd8a3ccd29e50b7866b6f5dbd6096c21.tar.gz
ports-12bddd24fd8a3ccd29e50b7866b6f5dbd6096c21.zip
Notes
Diffstat (limited to 'mail/qpopper')
-rw-r--r--mail/qpopper/Makefile14
-rw-r--r--mail/qpopper/files/pkg-message.in (renamed from mail/qpopper/pkg-message)2
-rw-r--r--mail/qpopper/pkg-plist11
3 files changed, 15 insertions, 12 deletions
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index 3b539d101801..ee7ddc1fc474 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -33,12 +33,14 @@ PLIST_SUB= EPOPPASSD=${EPOPPASSD} \
MAN8= qpopper.8
+SUB_FILES= pkg-message
+
# internal configuration
POP_USER= pop
POP_GROUP= daemon
POP_MODE_DIR= 0711
POP_MODE_CONF= 0444
-POPUSERS_FILE= ${PREFIX}/etc/qpopper/popusers
+POPUSERS_FILE= ${ETCDIR}/popusers
SAMPLE_EXT= .sample
#
PKGDEINSTALL= ${PKGINSTALL}
@@ -57,7 +59,7 @@ OPTIONS= APOP_ONLY "build with APOP authentication only" off \
STANDALONE_MODE "build qpopper to be run without inetd" off \
U_OPTION "include support for user .qpopper-options" on
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if !defined(WITHOUT_IPV6)
PATCH_SITES= http://www.imasy.or.jp/~ume/ipv6/
@@ -68,7 +70,7 @@ PATCH_DIST_STRIP= -p1
.if defined(WITHOUT_APOP)
QPOPAUTH= "@comment "
.else
-CONFIGURE_ARGS+= --enable-apop=${PREFIX}/etc/qpopper/pop.auth \
+CONFIGURE_ARGS+= --enable-apop=${ETCDIR}/pop.auth \
--with-apopuid=pop
MAN8+= qpopauth.8
QPOPAUTH= ""
@@ -131,6 +133,8 @@ CONFIGURE_ARGS+= --enable-standalone
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.endif
+.include <bsd.port.pre.mk>
+
post-patch:
@${RM} -f ${WRKSRC}/popper/md5.h
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/man/*
@@ -165,14 +169,14 @@ do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/password/poppassd ${PREFIX}/libexec/qpoppassd
.endif
@${INSTALL} -d -o ${POP_USER} -g ${POP_GROUP} -m ${POP_MODE_DIR} \
- ${PREFIX}/etc/${PORTNAME}
+ ${ETCDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/GUIDE.pdf ${DOCSDIR}
.endif
post-install: install-conf-file
- @${SED} -e "s:/usr/local:${PREFIX}:g" ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
# based on original from op port, written by Cyrille Lefevre
# <clefevre@citeweb.net>.
diff --git a/mail/qpopper/pkg-message b/mail/qpopper/files/pkg-message.in
index b41a75718797..dcfd3ed808d3 100644
--- a/mail/qpopper/pkg-message
+++ b/mail/qpopper/files/pkg-message.in
@@ -2,5 +2,5 @@
****************************************************************************
To enable the qpopper-daemon, add the following line to your /etc/inetd.conf:
- pop3 stream tcp nowait root /usr/local/libexec/qpopper qpopper -s
+ pop3 stream tcp nowait root %%PREFIX%%/libexec/qpopper qpopper -s
****************************************************************************
diff --git a/mail/qpopper/pkg-plist b/mail/qpopper/pkg-plist
index 8edc790fec83..a633d75506ba 100644
--- a/mail/qpopper/pkg-plist
+++ b/mail/qpopper/pkg-plist
@@ -3,10 +3,9 @@
%%QPOPAUTH%%@exec ln -sf %D/bin/qpopauth %D/bin/qapopauth
libexec/qpopper
%%EPOPPASSD%%libexec/qpoppassd
-@exec mkdir -p %D/etc/qpopper && chown %%POP_USER%%:%%POP_GROUP%% %D/etc/qpopper && chmod %%POP_MODE_DIR%% %D/etc/qpopper
-@mode %%POP_MODE_CONF%%
-etc/qpopper/popusers.sample
+@exec mkdir -p %%ETCDIR%% && chown %%POP_USER%%:%%POP_GROUP%% %%ETCDIR%% && chmod %%POP_MODE_DIR%% %%ETCDIR%%
+%%ETCDIR%%/popusers.sample
etc/qpopper.config.sample
-%%PORTDOCS%%share/doc/qpopper/GUIDE.pdf
-%%PORTDOCS%%@dirrm share/doc/qpopper
-@unexec rmdir %D/etc/qpopper 2>/dev/null || echo "If you are permanently removing this port, you should do a ``rm -rf ${PKG_PREFIX}/etc/qpopper`` to remove any configuration files and logs left." | fmt
+%%PORTDOCS%%%%DOCSDIR%%/GUIDE.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry %%ETCDIR%% || echo "If you are permanently removing this port, you should do a ``rm -rf %%ETCDIR%%`` to remove any configuration files and logs left." | fmt