aboutsummaryrefslogtreecommitdiff
path: root/mail/qsf
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-01-18 01:48:17 +0000
committerClement Laforet <clement@FreeBSD.org>2004-01-18 01:48:17 +0000
commit50f02022120a22b3922a3aee8f9e3f7166ac87f4 (patch)
tree4210e49bb60ce436cfe2350616e024532d006284 /mail/qsf
parentc26c8c8bd9cc602b3ed0ec7a57404712ede0ce35 (diff)
downloadports-50f02022120a22b3922a3aee8f9e3f7166ac87f4.tar.gz
ports-50f02022120a22b3922a3aee8f9e3f7166ac87f4.zip
Notes
Diffstat (limited to 'mail/qsf')
-rw-r--r--mail/qsf/Makefile28
-rw-r--r--mail/qsf/distinfo1
-rw-r--r--mail/qsf/files/quickref.1.in.patch7
-rw-r--r--mail/qsf/pkg-descr7
-rw-r--r--mail/qsf/pkg-plist1
5 files changed, 44 insertions, 0 deletions
diff --git a/mail/qsf/Makefile b/mail/qsf/Makefile
new file mode 100644
index 000000000000..7f8b11b01443
--- /dev/null
+++ b/mail/qsf/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: qsf
+# Date created: 15 January 2004
+# Whom: liamfoy@sepulcrum.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= qsf
+PORTVERSION= 0.9.18
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= qsf
+EXTRACT_SUFX= .tar.bz2
+
+MAINTAINER= liamfoy@sepulcrum.org
+COMMENT= A small fast spam filter intended to be used with procmail
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+
+MAN1= qsf.1
+MANCOMPRESSED= no
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/qsf ${PREFIX}/bin/qsf
+ ${INSTALL_MAN} ${WRKSRC}/doc/quickref.1 ${MAN1PREFIX}/man/man1/qsf.1
+
+.include <bsd.port.mk>
diff --git a/mail/qsf/distinfo b/mail/qsf/distinfo
new file mode 100644
index 000000000000..be720d072a09
--- /dev/null
+++ b/mail/qsf/distinfo
@@ -0,0 +1 @@
+MD5 (qsf-0.9.18.tar.bz2) = d87e90603140dc35d2f4d154468c51f8
diff --git a/mail/qsf/files/quickref.1.in.patch b/mail/qsf/files/quickref.1.in.patch
new file mode 100644
index 000000000000..4cfdb07180da
--- /dev/null
+++ b/mail/qsf/files/quickref.1.in.patch
@@ -0,0 +1,7 @@
+--- doc/quickref.1.in.orig Sat Jan 17 17:38:19 2004
++++ dpc/quickref.1.in Sat Jan 17 17:38:25 2004
+@@ -1,4 +1,3 @@
+-.TH @UCPACKAGE@ 1 "January 2004" Linux "User Manuals"
+ .SH NAME
+ @PACKAGE@ \- quick spam filter
+ .SH SYNOPSIS
diff --git a/mail/qsf/pkg-descr b/mail/qsf/pkg-descr
new file mode 100644
index 000000000000..e68c4cf44169
--- /dev/null
+++ b/mail/qsf/pkg-descr
@@ -0,0 +1,7 @@
+Quick Spam Filter (qsf) is a lightweight statistical spam filter written in C.
+It is designed to be small, fast, reliable, easy to install, and simple to use
+in a procmail recipe
+
+WWW: http://www.ivarch.com/programs/qsf.shtml
+-Liam Foy
+liamfoy@sepulcrum.org
diff --git a/mail/qsf/pkg-plist b/mail/qsf/pkg-plist
new file mode 100644
index 000000000000..d5b0ba9c014c
--- /dev/null
+++ b/mail/qsf/pkg-plist
@@ -0,0 +1 @@
+bin/qsf