aboutsummaryrefslogtreecommitdiff
path: root/mail/qsheff/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-19 10:04:31 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-19 10:04:31 +0000
commitf3e1cc6c7c21152e1424c4cc51cc439a6f9dd992 (patch)
treeb4cef5402e872f3d448691fc1df79d86f4a2bad2 /mail/qsheff/Makefile
parent5b631b7753168fcf228150835eb18fcc081a4803 (diff)
Notes
Diffstat (limited to 'mail/qsheff/Makefile')
-rw-r--r--mail/qsheff/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/mail/qsheff/Makefile b/mail/qsheff/Makefile
index 3598bf70b9da..32f329530e5d 100644
--- a/mail/qsheff/Makefile
+++ b/mail/qsheff/Makefile
@@ -6,16 +6,18 @@
#
PORTNAME= qsheff
-PORTVERSION= 1.0.r1
+PORTVERSION= 1.0.r3
CATEGORIES= mail
-MASTER_SITES= http://www.enderunix.org/qsheff/
-DISTNAME= ${PORTNAME}-1.0-r1
+MASTER_SITES= http://www.enderunix.org/qsheff/ \
+ ${MASTER_SITE_SOURCEFORGE}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-r/}
MAINTAINER= ozkan@enderunix.org
COMMENT= A qmail-queue replacement to filter mail traffic
-RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-queue:${PORTSDIR}/mail/qmail \
+BUILD_DEPENDS= ${QMAIL_DIR}/bin/qmail-queue:${PORTSDIR}/mail/qmail \
${LOCALBASE}/bin/ripmime:${PORTSDIR}/mail/ripmime
+RUN_DEPENDS= ${BUILD_DEPENDS}
USE_REINPLACE= YES
GNU_CONFIGURE= YES
@@ -24,8 +26,6 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PORTDOCS= spamass-qsheff.en.html README COPYING AUTHORS ChangeLog \
INSTALL UPGRADE THANKS TODO
-SUB_FILES= pkg-message
-
OPTIONS= CLAMAV "Integrate with Clam AntiVirus" on
.if exists(${LOCALBASE}/qmail/bin/qmail-queue)
@@ -34,8 +34,6 @@ QMAIL_DIR?= ${LOCALBASE}/qmail
QMAIL_DIR?= /var/qmail
.endif
-PREFIX?= ${QMAIL_DIR}
-
CONFIGURE_ARGS+= --with-qmaildir=${QMAIL_DIR}
.include <bsd.port.pre.mk>
@@ -43,9 +41,6 @@ CONFIGURE_ARGS+= --with-qmaildir=${QMAIL_DIR}
.if !defined(WITHOUT_CLAMAV)
RUN_DEPENDS+= ${LOCALBASE}/bin/clamdscan:${PORTSDIR}/security/clamav
.endif
-.if !defined(WITHOUT_FPROT) & defined(WITHOUT_CLAMAV)
-RUN_DEPENDS+= ${LOCALBASE}/bin/f-prot:${PORTSDIR}/security/f-prot
-.endif
post-patch:
.if defined(NOPORTDOCS)
@@ -60,7 +55,4 @@ post-build:
${WRKSRC}/etc/qsheff.conf-default
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>